Empathy dialpad tones don't work

Bug #482597 reported by Rykel from Singapore on 2009-11-14
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Empathy
Unknown
Unknown
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

Although I can get connected to my SIP VoIP service and also receiving incoming voice calls, there is no dialpad which I can use to call phones. Please advise? Thanks!

Brian Curtis (bcurtiswx) wrote :

rykel, thanks for your bug report and helping to make Ubuntu better. According to upstream you would need to "type in the number in the new conversation dialog" and there is no need for a dialpad. Closing this bug as won't fix.

Changed in empathy (Ubuntu):
status: New → Won't Fix
Germán Pabón (ninboy) wrote :

I think you should reconsider opening this bug again.

When you receive a call, and you need to press a number (like for some options) you CAN'T, because you have no dialpad.

In my Company's Asterisk server, you call the central machine and then you should chose some options (via pressing numbers) to access some functions. This interactions is not possible at this moment...

Brian Curtis (bcurtiswx) wrote :

for now I have reopened this bug, since I believe you've made a decent argument. I will try talking to the devs this afternoon and see their opinions on this.

Changed in empathy (Ubuntu):
status: Won't Fix → New
importance: Undecided → Low
Roman Yepishev (rye) wrote :

This is a must-have option.
I called my bank today and found out that I am unable to get past the IVR that presented me with the language choice.
Since not all human beings are capable of whistling proper DTMF tones, this should be handled by the software.

owenix (justinowen) wrote :

With google voice & gizmo to answer a call you must press 1 to talk or 2 to send to voice mail. This is about to become the largest sip provider in the world with google's acquisition of gizmo. Also see this link http://linux.slashdot.org/story/09/11/28/2332254/Google-Eliminates-Gizmo5-Client-For-Linux

Omer Akram (om26er) wrote :

Can any one please tell me how to reproduce this.

Roman Yepishev (rye) wrote :

Hm, It turns out that there is a dialpad.

It is accessible by clicking on the "Sidebar" button during the call.

Brian Curtis (bcurtiswx) wrote :

It appears as if upstream knows there is a dialpad, but when someone tries to use it there are problems.

Roman, could you please test to make sure that the dialpad works as you would expect?

Changed in empathy (Ubuntu):
status: New → Incomplete
Changed in empathy:
status: Unknown → Incomplete
Danjones (goodevilgenius) wrote :

I just tried to use the dialpad in empathy 2.30.0 in Ubuntu 10.04. The automated system I was using required me to press the # key. Upon pressing the # key, no tone was generated; the automated system I called (sipgate.com's echo number) did not recognize any tone.

Can also confirm this issue that the dialpad exists (very hard to find) but pressing the keys does not generate a DTMF. I was using Empathy 2.30.0.1 on Lucid.

This function is used to navigate through IVR and voicemail systems so it is fairly important to SIP.

For those looking for the dialpad, press sidebar then in the 'audio input' drop down select 'dialpad'.

Pressing numbers in this window should also automatically generate DTMFs without the need for the dialpad.

Jeremy Nickurak (nickurak) wrote :

The tones generated by the dialpad do not produce useful results from IVR systems.

summary: - no dialpad to make phonecalls
+ Empathy dialpad tones don't work
Changed in empathy (Ubuntu):
status: Incomplete → Confirmed
Changed in empathy:
status: Incomplete → Confirmed
Darik Horn (dajhorn) wrote :

I noticed this bug after becoming frustrated with Empathy in Ubuntu Lucid. Empathy is indeed doing DMTF through the dial pad properly, so this is technically not-a-bug, but the user interface is unlike most other VOIP software:

* Empathy buries the keypad under Sidebar -> Audio Input -> Dialpad, whereas most applications show the dialpad by default or have a large button for it.

* Empathy doesn't echo DMTF, which is unlike regular telephone hardware, which makes the user think that Empathy is not sending the tone.

Kamus (kamus) wrote :

this issue is still valid with 2.31.90-1ubuntu1 included with Ubuntu Maverick.

Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Changed in empathy:
importance: Unknown → Medium
frey (fdmitry) wrote :

This bug still happens in empathy 2.32.0.1 (ubuntu 10.10).

Darik Horn (dajhorn) wrote :

The DMTF in Empathy seems to have regressed from Lucid to Maverick. Most IVRs are not recognizing keypad tones from Empathy.

Calabacin (raulgarciag) wrote :

For a change I will comment to say that something DOES work, instead of the opposite.

Just tried this with our local Asterisk server and calling an external line using a commercial voip trunk, and I can confirm that the Dialpad DOES indeed work perfectly with these:
-Linux xxxx 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:44 UTC 2011 x86_64 GNU/Linux
-Ubuntu 10.10 Maverick Meerkat
-telepathy-sofiasip 0.6.3-1
-empathy 2.32.1-0ubuntu1.1

I can also confirm that i would have NEVER found it if not for Darik Horn's previous post in this bug report, and even having it, it took me a moment until I noticed that "Audio Input" was actually a listbox with the option "Autio Input" selected, although that's perhaps "theme's fault" (I use Ubuntu 10.10 with the standard theme).

So, this is not a bug, specially not in the underlying communication plug-in (telepathy-sofiasip), but Empathy clearly needs some GUI modifications so that finding the keypad is not 'so absolutely imposible'. Maybe allowing pressing numbers even if the pad is unseen? Maybe bringing up the pad when a number is pressed? How about showing the keypad by default when you open the sidebar instead of the volume levels? Since I cannot code, I like to at least give ideas, I hope they help :-)

Thank you

Brian Curtis (bcurtiswx) wrote :

Could those with the problem still please try using the versions mentioned by calabacin. Make sure you know where to find the dialpad.

svaens (svaens) wrote :

I just had the same problem;

Couldn't find a dial-pad. Assumed there was none. Used twinkle instead.

Having read someones post, I was surprised to notice that he had an image of a dial pad in empathy.
I needed to read the instructions real carefully, because;

1, you can't get to the dial-pad unless you are actually already in an active call
2, once you are in an active call, finding the dial-pad is tricky. You have to KNOW it is there. It is like looking for a secret door in a room. You can open it if you know it is there to find. If you don't know it is there, or perhaps even you know it is there, but not which corner of the room, you never find it!

The best solution I can think of is simple;

On opening the 'New Call' dialog,
the user is presented with not only the 'Account' field and the 'Contact ID:' field, but underneath that (and above the 'Call' and 'Cancel' buttons) there is the dial pad there, by default, nice and visible.

Clicking the dialpad should;

1. Append numbers to the 'Contact ID:' field
2. echo back the DTMF tone back to you

Simple, and intuitive.

The current state of the 'New Call' dialog breaks that good old rule of 'least surprise'.

Changed in empathy:
status: Confirmed → Unknown
Bilal Shahid (s9iper1) wrote :

this bug is not in empathy see upstream comment:
Danielle Madeley [empathy developer] 2012-01-27 02:51:10 UTC
This is a bug in the connection manager.
so moveing there thanks

no longer affects: empathy
Bilal Shahid (s9iper1) wrote :

is this bug still present in 12.04 ? which version of network manager are you using?

affects: empathy (Ubuntu) → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
status: Triaged → Incomplete
Dawid Wróbel (dawidw) wrote :

I can confirm the bug is still present in 12.04. Try to call this number and choose an option for English language:
+48 22 692 2484 (http://www.citibankonline.pl/formularz/kontakt/)

Bilal Shahid (s9iper1) wrote :

sorry about my last comment

Changed in network-manager (Ubuntu):
status: Incomplete → Triaged
David Ayers (ayers) on 2012-05-06
affects: network-manager (Ubuntu) → empathy (Ubuntu)
David Ayers (ayers) wrote :

Hello Dawid,

I just tried the number you posted on 12.04 and it indeed accepted the DTMF dial tone and I heard the message to activate some card in English. But I also called my own mailbox to press a few numbers and listen to it later. The quality was not overwhelming and I could imagine that some systems could have issues. But I'm not sure whether that has to do with the connection between the SIP provider and me or between the SIP provider and the long distance call to Europe.

How is your speech quality in general? Could you call a mailbox to test whether you hear any DTMF tones?

Dawid Wróbel (dawidw) wrote :

David,
I am sorry for such a late reply, I must have missed your message. I just tried to call the same number under 12.10 and still no reaction whatsoever. Do you actually _hear_ the DTMF tone when pressing the button? Because I do not, however I assumed this is by design.
My speech quality is quite good. My SIP provider does not have a mailbox option so unfortunately I can't test it this way.
There must be something specific with this particular provider that DTMF does not work in empathy. Twinkle, however, works just fine.

Dawid Wróbel (dawidw) wrote :

It just occurred to me: does Twinkle support the DTMF only via the DTMF Info method (that would explain the silence when pressing the buttons)? Because it may be that my provider accepts only the standard, audible signalling.

David Ayers (ayers) wrote :

Hello Dawid,

I do not here the DTMF dial tone from empathy while it sends them... but if I call my mailbox to leave a message and then I type numbers on the dial pad and later I listen to the mailbox, then I do hear the DTMF dial tones on the recording. The quality isn't great, but the dial tones are audible.

Cheers,
David

PS: I'm still on 12.04 btw...

Hello Customer

Become the owner of exquisite and stylish thing!
A vast range of numerous different brand name watches, all of top quality, and at direct wholesale pricing.

---------------------------------
Received my Rolex Daytona yesterday…best replica I have ever seen.
Thanks!
                     Jamal Stratton
---------------------------------

Click here ---> http://phoem.ru

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.