Empathy is almost impossible to set as a startup application

Bug #478178 reported by Duncan Lithgow on 2009-11-08
154
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Empathy
Invalid
Wishlist
One Hundred Papercuts
Low
Unassigned
empathy (Ubuntu)
Low
Ubuntu Desktop Bugs
gnome-session (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: empathy

Ubuntu 9.10 (Karmic)
Empathy 2.28.1.1

Since I like to have my messenger clients running whenever I'm online I wanted to set that to happen automaticaly. So here's what I tried:

* I looked in the preferences of Empathy, and appart from the confusing entry "Automatically connect on startup" described in bug #322314 there is nothing about connecting.
* I looked under 'System > Preferences > Startup applications', there is no entry for Empathy so Itry to make one...
   * The file browser starts in my home directory so I assume there's a good reason for that and try to find an entry there for empathy. Sadly there's no entry there called empathy.
   * Luckily I know a bit about this Ubuntu thing and the Gnome Desktop so I look into the .gnome2 directory. Finally a directory called Empathy. But sadly that only has log files in it.
   * Thinking I'm a bit savvy I navigate to /usr/share/empathy ... but again there is no file I can point to to start empathy ...
   * Now I'm getting annoyed, nothing useful in /usr/share/gnome/autostart
   * Nothing in /usr/share/gnome2
   * /usr/bin/empathy looks promising - maybe I'll be lucky this time.

Now I'm thoroughly annoyed at this stupid system which doesn't seem to have any standard way of starting an application!

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 70577d17832e34b30176c21d9d564ab0
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Sun Nov 8 08:47:59 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/empathy
NonfreeKernelModules: nvidia
Package: empathy 2.28.1.1-0ubuntu1
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_DK.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: empathy
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:2096): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2096): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2141): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2131): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gdu-notification-daemon:2136): GduNotification-WARNING **: No notification area. Notification bubbles will not be displayed.

Duncan Lithgow (duncan-lithgow) wrote :
description: updated
tags: added: 100papercuts gui usability
Changed in empathy (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Triaged
Duncan Lithgow (duncan-lithgow) wrote :

Can I suggest that until/unless a long term solution is found we set the dialog at 'System > Preferences > Startup Application > Startup Programs > Add' to open by default to /usr/bin? That seems to be the most reliable solution for now. This 'adding startup applications' has in reality been a general bug for years now. Surely it's time to do something?

Added the One Hundred Paper Cuts project to this, since it seemed like you wanted it added...

Omer Akram (om26er) wrote :

to do it right way it would be great that empathy itself has the option (it is milestoned to 2.30 by empathy developers). but it will be a new feature in empathy so not a papercut.

Changed in hundredpapercuts:
status: New → Invalid
Vish (vish) wrote :

Upstream has decided to not fix this problem.

They want to use a less discoverable way , Quoting from upstream >

"you just have to dragndrop empathy (a launcher, or the entry in the
applications menu) to the list of gnome-session-properties. Is it enough for
you?"

Changed in hundredpapercuts:
importance: Undecided → Low
status: Invalid → Confirmed
Omer Akram (om26er) wrote :

I think we should milestone it for Lucid.

Adam Lindberg (eproxus) wrote :

@Vish

Maybe something could be in Startup Programs to automatically give a list of programs that are in the applications menu? That would probably solve 95% of users problems trying to find common programs.

What they are referring is that you have to open Startup Applications -> Startup Programs and drag Empathy from the Applications menu to the program list.

Duncan Lithgow (duncan-lithgow) wrote :

As Adam says there is a need for a standard reliable 'add an application' dialog. At the moment none of the various dialogs for adding applications work very well. The one for selecting which application to use for a given filetype is full of double entries, missing entries and isn't even alphabetical, and the one this bug is about is a shambles. Why does it open to my home directory? There are no applications in there by default.

Jim Braux-Zin (j-brauxzin) wrote :

I think there is an additional consitency problem with Lucid. For the user point of view there should be no difference in behaviour between the Gwibber+gwibber-service (which starts automatically) combination and Empathy+telepathy. I mean that for a user both apps will display notification in the background, both apps are manageable through the "MeMenu" and the "Indicator applet", they should have the same startup behaviour.

Jim Braux-Zin (j-brauxzin) wrote :

I have just thought of a simple solution that could make the problem of not automatically launching Empathy less bad, based on my own behaviour and expectations.

I suggest that MeMenu could launch Empathy if the user click on "Online" or "Away", or any state other than "Offline". This way, on standard startup the MeMenu would show that the user is offline (because Empathy has not been launched) and if he wants to go online he just has to click on "Online".

What do you think? It would be an Ubuntu only change which won't annoy Gnome or Empathy. There is still the issue of choosing which IM client to launch if Pidgin is installed for example.

@Jim Braux-Zin

This is very intuitive and this is what I was expecting few days ago when I moved to Lucid (and I still expect it). It would be nice if by selecting the state, empathy will automatically login.

Greetings!
Vasil
//first post :)

Vish (vish) on 2010-05-21
Changed in hundredpapercuts:
status: Confirmed → Triaged
Vish (vish) on 2010-06-11
Changed in hundredpapercuts:
milestone: none → maverick-round-3-chat
Lukian (launchpad-nevyn) wrote :

"Unity" has drawn my attention to /usr/share/applications/ - perhaps this directory would be of use for this bug?

Changed in empathy:
importance: Unknown → Wishlist
status: Unknown → Invalid
Jon Loldrup (loldrup) wrote :

@Jim Braux-Zin:
you are so right - that would be the obvious behavior.

Also, it would be very cool if the me menu could remember ones state between sessions, so, if I was online when I shut down, the me menu (or another part of ubuntu) would automatically try to bring me back to that same state, that is, online.

Vish (vish) on 2010-11-23
Changed in hundredpapercuts:
milestone: maverick-round-3-social-networking → nt2-social-networking
Jim Rorie (jfrorie) wrote :

> "you just have to dragndrop empathy (a launcher, or the entry in the
> applications menu) to the list of gnome-session-properties. Is it enough for
> you?"

If this is the expected procedure, wouldn't a good starting point to be to add a hint or prompt to let users know this is possible?

Jeremy Nickurak (nickurak) wrote :

Affects gnome-session, since this is the only UI where getting it set up is currently possible, if awkward and poorly discoverable.

Hans Hellén (hans-hellen) wrote :

I have succeeded to run scripts and start applications by gnome-schedule.

Brian Curtis (bcurtiswx) wrote :

What about taking the icon from the Applications-->Internet-->Empathy and dragging it to the entry area in System-->Preferences-->Startup Applications ?

Brian Curtis (bcurtiswx) wrote :

OK, upstream won't work on it. So we'll have to ask that someone write a patch to get this done in empathy and submit it upstream. Anyone willing to do this?

Vish (vish) wrote :

Possibly a dup of Bug #140918 , which is to handle all the apps' autostart in gnome-session.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.