ICQ doesn't work in Empathy

Bug #462530 reported by Yuriy Padlyak on 2009-10-28
170
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Empathy
Expired
Critical
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

Message at the top, below status, says "<my icq id> Network error"

ProblemType: Bug
Architecture: i386
Date: Wed Oct 28 12:22:45 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/empathy
NonfreeKernelModules: nvidia
Package: empathy 2.28.1-1ubuntu1
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=uk_UA.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: empathy
Uname: Linux 2.6.31-14-generic i686

Yuriy Padlyak (gneeot) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in empathy (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

Hello,

I have the same problem. I can reproduce it by adding a new ICQ account, entering my ICQ details (number & password) an enabling the account. I get the same "network error". This makes empathy unusable for me.

1. add ICQ account
2. enter account details
3. enable account
4. -> network error

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Ulis (chebotarev) wrote :

Hello,
I have the same problem. But this problem periodically appears. I think because of a small waiting time of connection.

Ulis (chebotarev) wrote :

Empathy debug empathy_account_connection_ready_cb: (/org/freedesktop/Telepathy/Account/haze/icq/_3<my_id>0) Connection failed to become ready: Network error

Same error. But always. It really may be wrong waiting connection time (but I'm not sure), my provider sux :-)

Brian Curtis (bcurtiswx) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

jnns (jnns) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in empathy (Ubuntu):
status: Incomplete → Triaged
kchak79 (kchak79) wrote :

hello i have today the same problem...
network problem

Yesterday i don`t have any problem but today is not working.

jnns (jnns) wrote :

The issue seems to be fixed in 2.29.5.1

Changed in empathy (Ubuntu):
status: Triaged → Fix Released

I have this issue:
$ apt-cache policy empathy
empathy:
  Installed: 2.29.90-0ubuntu2
  Candidate: 2.29.90-0ubuntu2
  Version table:
 *** 2.29.90-0ubuntu2 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

Andrey (andrey-fr) wrote :

I still have the problem logging in to ICQ in Ubuntu Lucid. libpurple0 version: 1:2.6.6-1ubuntu1 (lucid)

Andrey, see here: http://live.gnome.org/Empathy/FAQ, on the very bottom of the page

Marat Dyatko (marat-dyatko) wrote :

empathy:
  Installed: 2.28.1.1-0ubuntu1
  Candidate: 2.28.1.1-0ubuntu1

Brett Randall (javabrett) wrote :

Are there any plans to backport this fix to Karmic?
Thanks
Brett

Sebastien Bacher (seb128) wrote :

icq is not known to be broken in karmic

Brett Randall (javabrett) wrote :

I have both AIM and ICQ broken with the very same symptoms as this ticket, in Karmic. I could open a new ticket, but it's bound to be marked as a duplicate of this ticket.

apt-cache policy empathy
empathy:
  Installed: 2.28.1.1-0ubuntu1
  Candidate: 2.28.1.1-0ubuntu1
  Version table:
 *** 2.28.1.1-0ubuntu1 0
        500 http://ftp.iinet.net.au karmic-updates/main Packages
        100 /var/lib/dpkg/status
     2.28.1-1ubuntu1 0
        500 http://ftp.iinet.net.au karmic/main Packages

As per Marat above @ #16. That is, Karmic is not seeing the 2.29 packages, and I am seeing the same problem.

I wonder how many issues the Lucid package might cause on Karmic - anyone have any thoughts on that? I'd switch back to Pidgin, but it seems to have developed a 100% CPU spin issue since I last used it.

Omer Akram (om26er) wrote :

@Brett to install the development release of empathy on karmic
sudo add-apt-repository ppa:telepathy/ppa ;sudo apt-get update ;sudo apt-get dist-upgrade and then reboot.

Brett Randall (javabrett) wrote :

@Omer - thanks, did that and it looks like a good outcome, Empathy can now connect to AIM and ICQ.

FYI during the partial dist upgrade I had failures on python-2.4 and python-2.5 but seems not to have mattered.

I also can't get my ICQ and AIM accounts working in Empathy even though I have the most recent versions in the official Telepathy PPA. When I try to connect, it says, "Disconnected - Network Error". These accounts work in Pidgin, and I used Empathy's import feature to get these accounts set up. I also tried entering the account information manually. Still has the error. I've been getting this problem for months (since I started using it).

Personally, I prefer the user interface in Pidgin and am sort of annoyed by Empathy, but I love the idea of system integration of IM's on Ubuntu, and I have to use Empathy for the indicator-applet to work properly.

Any more ideas?

Brian Curtis (bcurtiswx) wrote :

@mikefreeman what version of empathy and ubuntu are you using? Bug reports from PPA aren't valid. You may want to try uninstalling the telepathy version and using the one provided by Ubuntu.

Ian (ian-web1) wrote :

Suddenly (I remember no update), ICQ does not work in empathy. But works fine in pidgin and also in kopete on my KDE-Desktop.

Changed in empathy:
importance: Unknown → Critical
status: Unknown → Expired
Vasya Pupkin (shadowlmd) wrote :

I have the same issue. Empathy cannot connect to ICQ from time to time while other clients (Miranda, Jimm) can connect with no problems. Most of time Empathy can connect too, but sometimes it just gives "Network error" and leaves no clue about what is wrong. I tried changing ports and login servers but it didn't help.

Empathy can only connect using SSL mode which is broken with ICQ, while all other clients can use regular connection and thus don't have any problems when Empathy cannot connect.

I'm using Ubuntu 10.04.

Vasya Pupkin (shadowlmd) wrote :

And by the way, it's version 2.30.3 and bug is NOT FIXED.

Ch Iossif (chiossif) wrote :

Same here a few days now: ICQ connection reports Network Error.
Empathy version 2.30.2 Lucid AMD64

Dokuro (hikage-no-dokuro) wrote :

agreed, today is bugged
version 2.32.0.1 of empathy.
dokuro@dokuro-laptop:~$ uname -a
Linux dokuro-laptop 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:36:48 UTC 2010 i686 GNU/Linux

maybe icq changed of their protocols with the new facebook interaction being applied? o.õ

Vasya Pupkin (shadowlmd) wrote :

Well, everything else works, even JIMM compiled in year 2009. So it's obviously a problem with Empathy.

Ivan Galinskiy (ivanko-rus) wrote :

The same bug here - Empathy reports "Network error" while trying to connect to ICQ.

Some debug data (happens when I press the "Reconnect" button):
empathy/Dispatcher-DEBUG: 11/17/2010 17:50:07.993973: dispatcher_connection_invalidated_cb: Error: Network error
empathy/Dispatcher-DEBUG: 11/17/2010 17:50:07.994054: connection_ready_cb: Error: Network error

Info about my system:
Linux ivanko-desktop 2.6.32-25-generic #45-Ubuntu SMP Sat Oct 16 19:52:42 UTC 2010 x86_64 GNU/Linux

All the updates were applied prior to sending this comment.

Thanks in advance!

owang (owangler) wrote :

having the same issue here.
empathy 2.32.0.1

Linux machine 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux

Vasya Pupkin (shadowlmd) wrote :

Some more debug info.

purple/oscar-CRITICAL: 11/19/2010 05:30:01.355962: startOSCARSession response was missing something: <?xml version="1.0" encoding="UTF-8"?>
<response xmlns="http://developer.aim.com/xsd/aim.xsd"><statusCode>200</statusCode><statusText>Ok</statusText><data><ts>1290133801</ts><host>64.12.29.98</host><port>443</port><cookie>DELETED</cookie><upgradeData></upgradeData><betaData></betaData></data></response>
purple/connection-MESSAGE: 11/19/2010 05:30:01.356432: Connection error on 0x8a0e780 (reason: 0 description: Received unexpected response from https://api.oscar.aol.com/aim/startOSCARSession: Ok)

sovsep (sergej-ovsepjan) wrote :

It could be a protocol change. Because I' am using messaging plug-in for webos (Palm Pre) which is based on libpurple also and both empathy and webos gave the network error at the same day.

sovsep (sergej-ovsepjan) wrote :

Well, i have tried pidgin now with and without ssl and it logs in with no problems

ringo (ringo-stahl) wrote :

Yes, it is the lack of an option to not use ssl in Empathy.
At first I had heard from t-com users that they had network problems with ICQ and SSL in July, now this problems spreaded out to other users.

SSL is nice, but no use if you couldn't use it in a network.

daqron (daqron) wrote :

This bug has affected me for several weeks now. At the top of the page it indicates "fix released" but when I try to update from branch I get the error: "bzr: ERROR: Permission denied: "/empathy/": [Errno 13] Permission denied: '/empathy/'". Can you please let me know how I can download and install the new version so I can see if it addresses the problem?

Jan Schlüter (f0k) wrote :

@ringo: There is a way to disable SSL in Empathy. Disable your account, then run "mc-tool update haze/icq/_3youruin0 bool:use-ssl=0", where "youruin" is your ICQ number. See http://live.gnome.org/Empathy/Protocols#A.2BIBw-Empathy_can.27t_connect_to_ICQ.2C_saying_only_.2BIBg-Network_Error.2BIBk..2BIB0-
The web site suggests it as a fix for the connection problems that started in mid-November.

For me this does not solve the problem (Empathy 2.30.3). Anyway, this is still an upstream bug, I'm just posting this to help people who find this bug report while looking for a solution.

Marcus Ilgner (milgner) wrote :

Network problems again. Trying the aforementioned command to disable SSL:

mc-tool update: Protocol 'icq' does not have parameter 'use-ssl'

Vasya Pupkin (shadowlmd) wrote :

Happens to me as well. Please, re-open.

Sebastien Bacher (seb128) wrote :

don't comment on old closed bugs, the new issue is bug #795932

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.