Ubuntu

frequent disconnects from jabber server

Reported by Simone Malacarne on 2009-10-04
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
telepathy-gabble
Invalid
High
empathy (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: empathy

I experience frequent disconnects from jabber server at random intervals (not simultaneous). Nothing but network error is shown in the GUI.
.
The disconnects are very brief (about 1-2 seconds).

in dmesg i see a lot of:
[ 2027.157989] telepathy-gabbl[2830]: segfault at 0 ip 000000000045058b sp 00007fff56a0d0f0 error 4 in telepathy-gabble[400000+b8000]

I 'm using ubuntu 9.10 64bit

ProblemType: Bug
Architecture: amd64
Date: Sun Oct 4 17:04:00 2009
DistroRelease: Ubuntu 9.10
Package: empathy 2.28.0-0ubuntu2
ProcEnviron:
 LANGUAGE=it_IT.UTF-8
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: empathy
Uname: Linux 2.6.31-11-generic x86_64

Simone Malacarne (s-malacarne) wrote :

I get these disconnects too. Pidgin works fine without disconnects and I can exclude network timeouts, because the Jabberserver is on the Localnet.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in empathy (Ubuntu):
importance: Undecided → Low
David Oxland (doxland) wrote :

Same for me debug attached

Omer Akram (om26er) wrote :

Are there any news about this bug? Has someone affected by this bug sent the report upstream? May you tell us the bug number? Thanks in advance.

Omer Akram (om26er) wrote :

we have been wondering if this is still an issue for you. If any one is facing issue. remove all empathy accounts and quit empathy then remove ~/.config/Empathy ~/.gconf/empathy and ~/.mission-control and reboot system and start empathy again and see if that solves the issue. If the problem still exists please use the telepathy ppa https://launchpad.net/~telepathy/+archive/ppa to install latest version of empathy. If that does not solve the problem then we will send this problem to the upstream developers. Thanks in Advance

Changed in empathy (Ubuntu):
status: New → Incomplete

I'll try these step and let you know.

--
Krishnaswamy Subramanian

On Tue, Feb 9, 2010 at 8:38 PM, om26er <email address hidden> wrote:
> we have been wondering if this is still an issue for you. If any one is
> facing issue. remove all empathy accounts and quit empathy then remove
> ~/.config/Empathy ~/.gconf/empathy and ~/.mission-control and reboot
> system and start empathy again and see if that solves the issue. If the
> problem still exists please use the telepathy ppa
> https://launchpad.net/~telepathy/+archive/ppa to install latest version
> of empathy. If that does not solve the problem then we will send this
> problem to the upstream developers. Thanks in Advance
>
> ** Changed in: empathy (Ubuntu)
>       Status: New => Incomplete
>
> --
> frequent disconnects from jabber server
> https://bugs.launchpad.net/bugs/442298
> You received this bug notification because you are a direct subscriber
> of the bug.
>

brianbourke75 (brianbourke75) wrote :

I have attempted the above suggestions and it has not made a difference and I am still experiencing this issue.

Omer Akram (om26er) wrote :

@brian can you please attach the gabble log to this bug report? to do so click on Help>Debug select gabble in the debug window and when jabber disconnects click on the same button of the debug window and attach the gabble log so we can send the bug upstream.

brianbourke75 (brianbourke75) wrote :

I apologize for the delay but our work OpenFire server has gone down and our much overworked IT guy at work has not had a moment to revive it. I will get your the logs as soon as the server is up and running.

brianbourke75 (brianbourke75) wrote :

Here is the gabble log from the frequent disconnects I experience.

originally reported at: https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/442298

"I experience frequent disconnects from jabber server at random intervals (not simultaneous). Nothing but network error is shown in the GUI."

Created an attachment (id=33976)
here is the gabble log from empathy

Omer Akram (om26er) wrote :

I have sent this upstream with the gabble log.

Changed in empathy (Ubuntu):
importance: Low → Medium
status: Incomplete → Triaged
Changed in telepathy-gabble:
status: Unknown → Confirmed

Can any one please look into the log and see whats the problem. i.e is it a problem at user's end or telepathy please.

closing as jabber now works for the reporter.

Omer Akram (om26er) wrote :

Jabber have been working fine here on Lucid. Is this still an issue?

Changed in empathy (Ubuntu):
status: Triaged → Incomplete

Yes it is working fine.

--
Krishnaswamy Subramanian

On Thu, Jul 15, 2010 at 5:21 PM, Omer Akram <email address hidden> wrote:

> Jabber have been working fine here on Lucid. Is this still an issue?
>
> ** Changed in: empathy (Ubuntu)
> Status: Triaged => Incomplete
>
> --
> frequent disconnects from jabber server
> https://bugs.launchpad.net/bugs/442298
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Omer Akram (om26er) on 2010-07-15
Changed in empathy (Ubuntu):
status: Incomplete → Fix Released
Changed in telepathy-gabble:
importance: Unknown → High
status: Confirmed → Invalid
Changed in telepathy-gabble:
importance: High → Unknown
Changed in telepathy-gabble:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.