initial empathy account wizard does not offer IRC as an account

Bug #433714 reported by Tim Potter on 2009-09-20
122
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
NULL Project
Undecided
Unassigned
Baltix
Undecided
Unassigned
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

In both karimc alpha 5 and alpha 6, and the Lucid daily image from 2-24, when starting the empathy IM client, the wizard that starts gives a list of accounts available to create. In this list, IRC is missing. I've seen this both on the live environment and a clean install.

The workaround is to exit and go to Edit -> Accounts (F4) and Add an account. IRC is listed in this location. In Lucid, you have to get past the wizard (basically set up one account) this work around.

A new user that installs Karmic, may want to get to IRC #ubuntu channel, and this gives the initial perception that they cannot accomplish this.

Confirming; I had no accounts created yet on my Karmic alpha 6 install, and this happened when I tried to create an IRC account. (This testing was done by request of the bug submitter to confirm the existence of this bug.)

You'll also see that the "People Nearby" account type is absent as well in the Welcome Screen.

Changed in empathy (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in empathy (Ubuntu):
importance: Undecided → Wishlist
importance: Wishlist → Low
Tim Potter (musikgoat) wrote :

Sebastien,

I have created the upstream bug report and have cross linked the bugs. Thanks for the suggestion.

Changed in empathy:
status: Unknown → Confirmed
Changed in empathy:
status: Confirmed → New
Markus Korn (thekorn) wrote :

As you can see in bug 447098 thinks are getting worse now, "Jabber" and "Google Talk" are the only available protocols in this dropdown

Changed in empathy (Ubuntu):
status: Confirmed → Triaged
David Balažic (xerces8) wrote :

Markus, that is a different option ("Create new account").
This bug is about "use existing account".

But it is a bit confusing as "create new" might be understood as "create new account in Empathy (but use pre-existing MSN account)".

As the removal of IRC is an upstream design choice (???), I suggest getting back Pidgin, which just works.

(although the train is already missed for karmic as far as IRC support is considered:
 - after start empathy gives the impression that it does not support IRC
 - the preconfigured irc: URL hander mibbit.com is banned on freenode
 - if the user happens to investigate and noticed the hint to use webchat.freenode.net , he gets this:
-ChanServ- [#ubuntu-proxy-users] /!\ ATTENTION /!\ This is NOT #ubuntu. | You have been sent to this channel because you are using a proxy service such as Tor or Cgi:IRC. There are better ways to be anonymous. | CGI:IRC users, try connecting to freenode via port 8000, 8001 or 8002. This _may_ bypass your firewalls | Please type !proxy for more information.
)

MarcRandolph (mrand) on 2010-01-22
Changed in empathy (Ubuntu):
importance: Low → Wishlist
tags: added: lucid
Erik B. Andersen (azendale) wrote :

A video of the problem in Lucid, and how frustrating this could be for a new user trying to get to an irc channel.

Anzenketh (anzenketh) on 2010-02-27
tags: added: screencast
Omer Akram (om26er) wrote :

This came from upstream:
"Empathy is currently a pretty poor IRC client so I think the current UI makes sense. There is some vague plans to create a separated Telepathy client for IRC/Muc chat."

Changed in empathy (Ubuntu):
status: Triaged → Won't Fix
Erik B. Andersen (azendale) wrote :

@Omer Akram
Thanks, I see that comment. It makes it frustrating that Ubuntu changed from pidgin to empathy. Ubuntu replaces pidgin, which does great with IRC, with empathy (I'm not sure why, but maybe there is a reason). Then the developer of empathy basically says empathy does such a terrible job of supporting IRC that its worth frustrating a person setting up an IRC account so that they won't use it with IRC. As I see it, Ubuntu went from supporting IRC with pidgin to not supporting it (or supporting it badly). (And all the Ubuntu support related chat channels are on what protocol?) Doesn't that fit the category of regression?

description: updated
Guy Thouret (guy-thouret) wrote :

This is still present in Lucid Beta1. First account creation does not give IRC as an option. Creating any other chat account first then allows you to create an IRC account as the second account.

ortango (ortango) wrote :

first time user of empathy, I dont have any other chat accounts and can not work around this bug.

telepathy-idle is installed by default in lucid. why is this the case if its bugged and featureless

besides being installed by default i would not even had known there was support for irc in empathy if gnome.org didn't list it as a recommended irc client. in ubuntu's defense https://help.ubuntu.com/community/InternetRelayChat does not list empathy as a client so hopefully people will not expect the support.

Hugh Saunders (hughsaunders) wrote :

I had to create an account for a service I dont use, just to get passed the wizard, and add an irc account. UI fail.
If the initial list is too long, have a "more..." option or something like that.

+1

On Mon, Apr 26, 2010 at 2:34 PM, Hugh Saunders <email address hidden> wrote:

> If the initial list is too long, have a "more..." option or something like
> that.
>
>

Omer Akram (om26er) wrote :

This will be fixed in empathy 3.0

Changed in empathy (Ubuntu):
importance: Wishlist → Low
status: Won't Fix → Triaged
Changed in empathy:
status: New → Confirmed
Fred (eldmannen+launchpad) wrote :

This issue is still present in Ubuntu 10.04 "Lucid Lynx".

nUboon2Age (nuboon2age) wrote :

This is a very serious problem because irc is how #ubuntu-beginners, #ubuntu and so many Ubuntu and other support channels are accessed. Since Empathy is the default IRC client it needs to 'just work'. There are many problems with Empathy as an irc client, but this bug is the first one that hits the beginning Ubuntu user when trying to use IRC

Changed in empathy (Ubuntu):
status: Triaged → Confirmed
Omer Akram (om26er) wrote :

as said before this bug will be fixed in empathy 3.0 and triaged means that this bug does not need any other information. its complete.

Changed in empathy (Ubuntu):
status: Confirmed → Triaged
nUboon2Age (nuboon2age) wrote :

I completely disagree with this bug being labeled of 'Low' importance. Note that this is important enough that it will need to be included in the liveCD of Ubuntu 10.04, Lucid Lynx when it gets updated. Otherwise since Empathy is the default IRC client new users of Lucid may mistakenly think IRC is simply unavailable to them. This is vital because our #ubuntu-beginners, #ubuntu, and many other support IRC channels are critically important to new users.

Changed in ayatana-ubuntu:
status: New → Confirmed
Omer Akram (om26er) wrote :

This bug will be fixed in empathy 3.0

affects: ayatana-ubuntu → null
Changed in null:
status: Confirmed → Invalid
Omer Akram (om26er) wrote :

nUboon2Age, generally importance is not relevant for upstream bugs. I talked to the empathy developers a month ago and they will fix this bug in the upcoming release of empathy.

Jeff Stone (stone1343) wrote :

I thought I'd pass this by your technical people, I've just added this comment to GNOME bug 596086, which is the upstream bug for this one

>> I'm sure it's a lot more complicated than I make it out to be, but it seems to
>> me if you remove the strdiff for "irc" in
>> account_assistant_chooser_enter_details_filter_func, won't that make
>> empathy_protocol_chooser_set_visible display IRC in the Assistant?

Maybe you can verify this in some way to add support for getting the fix in GNOME 2.32, and therefore into Maverick.

Jeff Stone (stone1343) wrote :

The hyperlink goes to the Launchpad bug with the same number, I'm talking about this one
https://bugzilla.gnome.org/show_bug.cgi?id=596086
the code is here
http://git.gnome.org/browse/empathy/tree/src/empathy-account-assistant.c

nUboon2Age (nuboon2age) wrote :

I think this fix needs to be put into 10.04.1 . As i wrote above, this is a serious problem for supporting new users and since 10.04 is an LTS we could be faced with this issue for a long time unless the fix is added to the LiveCD. I continue to believe this should be raised from 'low' importance to at least medium or high for empathy (Ubuntu).

Jeff Stone (stone1343) wrote :

Thing is, this is a GNOME problem, we need them to fix it first. That's what I'm trying to do, expedite getting a fix.

I get the feeling, both from what Omer says and from looking at the GNOME bug, that the GNOME people think it's a fair bit of work. If I'm right in my analysis of the code, it's trivial. Whatever encouragement we can give to the GNOME people to verify what I found and get a fix out quick will be best for everyone. Then we figure out if it can be backported to Lucid.

nUboon2Age (nuboon2age) wrote :

@ Jeff how about we fix it and push it upstream to GNOME instead of waiting for them? Lately that's what we (Ubuntu and Canonical) been criticized for failing to do. If it is trivial then we can 1) solve our problem and 2) be heroes to GNOME and good FLOSS community members simultaneously.

Obviously i misspoke above and it would have to be 10.04.2 since 10.04.1 has already been shipped.

Omer Akram (om26er) wrote :

this bug is now fixed upstream. the fix for it will be in empathy 2.31.91 in Maverick

Changed in empathy (Ubuntu):
status: Triaged → Fix Committed
Changed in empathy:
status: Confirmed → Fix Released

Thank you for the good news Omer. I hope we will put it into 10.04.2 as
well.

On Thu, Aug 26, 2010 at 7:03 AM, Omer Akram <email address hidden> wrote:

> this bug is now fixed upstream. the fix for it will be in empathy
> 2.31.91 in Maverick
>
> ** Changed in: empathy (Ubuntu)
> Status: Triaged => Fix Committed
>
> --
> initial empathy account wizard does not offer IRC as an account
> https://bugs.launchpad.net/bugs/433714
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Chat app, and Telepathy user interface: Confirmed
> Status in NULL Project: Invalid
> Status in “empathy” package in Ubuntu: Fix Committed
> Status in Baltix GNU/Linux: New
>
> Bug description:
> Binary package hint: empathy
>
> In both karimc alpha 5 and alpha 6, and the Lucid daily image from 2-24,
> when starting the empathy IM client, the wizard that starts gives a list of
> accounts available to create. In this list, IRC is missing. I've seen this
> both on the live environment and a clean install.
>
> The workaround is to exit and go to Edit -> Accounts (F4) and Add an
> account. IRC is listed in this location. In Lucid, you have to get past the
> wizard (basically set up one account) this work around.
>
> A new user that installs Karmic, may want to get to IRC #ubuntu channel,
> and this gives the initial perception that they cannot accomplish this.
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/empathy/+bug/433714/+subscribe
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 2.31.91.1-0ubuntu1

---------------
empathy (2.31.91.1-0ubuntu1) maverick; urgency=low

  * New upstream release
  * debian/control:
    - add libgcr-dev build-dep
  * debian/patches/91_git_unref_empathyindividualview_later.patch:
    - additional fix from git requested by upstream

empathy (2.31.91-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Support metacontacts (Travis Treitter, Philip Treitter) (LP: #256478)
    - Initial empathy account wizard (Welcome Screen) does not offer IRC as an
      account (Guillaume Desmottes) (LP: #433714)
    - Dragging and dropping a chat tab hides the original window (Guillaume
      Desmottes) (LP: #512746)
    - After upgrade to 2.31.90 (from 2.31.6) empathy does not list users of irc
      chat (Guillaume Desmottes) (LP: #622684)
  * debian/control:
    - Bump build-depends on libgnome-keyring-dev, libfolks-dev,
      libfolks-telepathy-dev, libnautilus-sendto-dev
    - Add build-depends on libgnutls-dev
    - Drop build-depends on libebook1.2-dev
 -- Didier Roche <email address hidden> Thu, 02 Sep 2010 12:40:03 +0200

Changed in empathy (Ubuntu):
status: Fix Committed → Fix Released
Changed in empathy:
importance: Unknown → Medium
nUboon2Age (nuboon2age) wrote :

Thank you for raising the importance of this bug. I hope it will be
included in 10.04.2 since it is important to new users that the capability
to reach irc support channels be available from the start.

On Fri, Sep 10, 2010 at 4:24 PM, Bug Watch Updater <
<email address hidden>> wrote:

> ** Changed in: empathy
> Importance: Unknown => Medium
>
> --
> initial empathy account wizard does not offer IRC as an account
> https://bugs.launchpad.net/bugs/433714
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Chat app, and Telepathy user interface: Fix Released
> Status in NULL Project: Invalid
> Status in “empathy” package in Ubuntu: Fix Released
> Status in Baltix GNU/Linux: New
>
> Bug description:
> Binary package hint: empathy
>
> In both karimc alpha 5 and alpha 6, and the Lucid daily image from 2-24,
> when starting the empathy IM client, the wizard that starts gives a list of
> accounts available to create. In this list, IRC is missing. I've seen this
> both on the live environment and a clean install.
>
> The workaround is to exit and go to Edit -> Accounts (F4) and Add an
> account. IRC is listed in this location. In Lucid, you have to get past the
> wizard (basically set up one account) this work around.
>
> A new user that installs Karmic, may want to get to IRC #ubuntu channel,
> and this gives the initial perception that they cannot accomplish this.
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/empathy/+bug/433714/+subscribe
>

Kangarooo Jānis (kangarooo) wrote :

Still 10.04.04 isnt fixed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.