empathy crashed with SIGSEGV in event_remove()

Bug #432511 reported by Mtt.Castelli on 2009-09-18
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: empathy

Empathy crashed when I've tried to recall it from notification area by clicking its green icon. It was connected to MSN and GoogleGtalk too.

ProblemType: Crash
Architecture: i386
CheckboxSubmission: 0ef392dc384d396201fcb033163b5fb4
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Fri Sep 18 16:03:52 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/empathy
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20090917.1)
Package: empathy 2.27.92-1ubuntu2
ProcCmdline: empathy
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.34-generic
SegvAnalysis:
 Segfault happened at: 0x806d6fd <gtk_toggle_button_set_active@plt+79825>: mov 0xc(%eax),%esi
 PC (0x0806d6fd) ok
 source "0xc(%eax)" (0x0000000c) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: empathy
StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /usr/lib/libglib-2.0.so.0
 g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
 ?? () from /usr/lib/libglib-2.0.so.0
Title: empathy crashed with SIGSEGV in g_main_context_dispatch()
Uname: Linux 2.6.31-10-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Mtt.Castelli (mtt.castelli) wrote :

StacktraceTop:event_remove (event=0x9fe90f0)
autoremove_event_timeout_cb (event=0x9fe90f0)
g_timeout_dispatch (source=0x9fa0d10, callback=0,
IA__g_main_context_dispatch (context=0x9d2e2c8)
g_main_context_iterate (context=0x9d2e2c8,

Changed in empathy (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
summary: - empathy crashed with SIGSEGV in g_main_context_dispatch()
+ empathy crashed with SIGSEGV in event_remove()
visibility: private → public
Brian Curtis (bcurtiswx) wrote :

Thank you for your bug report and helping to make Ubuntu better. Could you please test this with an updated karmic/emapthy version and see if you still can reproduce the same error?

Changed in empathy (Ubuntu):
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

the bug has been fixed in this upload:

empathy (2.28.0.1-1ubuntu3) karmic; urgency=low

  * debian/patches/20_libindicate.patch
    - Fixed a crasher caused by not properly removing
      indicators. When comparing events, we shouldn't compare
      the message content. (LP: #435216)

Changed in empathy (Ubuntu):
status: Incomplete → Fix Released
Sebastien Bacher (seb128) wrote :

there has not been recent duplicates or comment which confirm users stopped having the issue

Changed in empathy (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers