[Feature request]Allow empathy conversation window to be minimized to notification area or messaging menu

Bug #410278 reported by Vish on 2009-08-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Empathy
Expired
Low
empathy (Ubuntu)
Wishlist
Unassigned
indicator-applet (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: empathy

Currently empathy allows the contact list window to be minimized to the notification area ,
It would be nice if the conversation window was also allowed to minimize to the notification area.

ProblemType: Bug
Architecture: i386
Date: Fri Aug 7 18:23:54 2009
DistroRelease: Ubuntu 9.10
Package: empathy 2.27.5-0ubuntu1
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SourcePackage: empathy
Uname: Linux 2.6.31-5-generic i686

Vish (vish) wrote :
Brian Curtis (bcurtiswx) wrote :

Thanks macv for the bug report and helping to make Ubuntu better. This is a wishlist item and its been marked as such.

Changed in empathy (Ubuntu):
importance: Undecided → Wishlist
Brian Curtis (bcurtiswx) wrote :

This is more of a notify-osd wishlist item, and empathy doesn't control this

Changed in empathy (Ubuntu):
status: New → Invalid
Changed in notify-osd (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Vish (vish) wrote :

Brian , notify-osd has nothing to do with this.

I mentioned minimize to notification *area*. [similar to the contacts list]

Brian Curtis (bcurtiswx) wrote :

Seems this bug was already mentioned upstream. Linked that and fixed the package error.

Changed in empathy (Ubuntu):
status: Invalid → New
affects: notify-osd (Ubuntu) → indicator-applet (Ubuntu)
Changed in empathy (Ubuntu):
status: New → Triaged
Changed in empathy:
status: Unknown → Confirmed
Germán Poo-Caamaño (gpoo) wrote :

It used to work on Jaunty. Hence, this bug is not a wish list, it is a regression.

And I do think it was introduced with the code of "message indicators".

Germán Poo-Caamaño (gpoo) wrote :

In fact, this is a duplicate of #451568

Germán Poo-Caamaño (gpoo) wrote :

In this bug it has nothing to do with upstream. Upstream does not suffer of this regression. It is introduced
in introduced by Ubuntu in debian/patches/30_raise_not_toggle.patch

Changed in empathy:
importance: Unknown → Undecided
status: Confirmed → New
Germán Poo-Caamaño (gpoo) wrote :

It seems this bug was introduced on purpose (see #392153), which is a shame.

marc_v: in order to get the same behavior of empathy(upstream), you can do the following:

$ sudo apt-get build-dep empathy
$ apt-get source empathy
$ cd empathy
$ rm debian/patches/30_raise_not_toggle.patch
$ dpkg-buildpackage -rfakeroot -b
$ cd ..
$ sudo dpkg -i empathy_2.28.0.*.deb

A change on this behaviour will not be accepted on the stable upstream.

summary: - [Feature request]Allow empathy conversation window to be minimized to
+ [Regression]Allow empathy conversation window to be minimized to
notification area
summary: - [Regression]Allow empathy conversation window to be minimized to
- notification area
+ [Regression]Allow empathy contact list to be minimized to notification
+ area

Germán Póo-Caamaño :
The contact list can be minimized. You can click metacity close 'x' from the top right corner and the contact list minimizes to the messaging menu.
And clicking on empathy from the messaging menu brings back the contacts list.

This bug was started to allow similar behavior to the conversation window. [in xchat the conversation window can be minized to the notification area] while this option is not allowed for empathy.

If for some reason the contact list does not minimize to the messaging menu , kindly open a separate bug for this.

summary: - [Regression]Allow empathy contact list to be minimized to notification
- area
+ [Feature request]Allow empathy conversation window to be minimized to
+ notification area or messaging menu
Vish (vish) wrote :

Also , this bug was started way back , even before , the Messaging menu patch was applied.

Germán Poo-Caamaño (gpoo) wrote :

Oops. Sorry, I misundertood the first comment. I was looking for the bug to avoid opening a new duplicate.
Hence, #451568 is not duplicated.

Germán Poo-Caamaño (gpoo) wrote :

Restoring back the changes that were misundertood.

Changed in empathy:
importance: Undecided → Unknown
status: New → Unknown
Changed in empathy:
importance: Unknown → Low
status: Unknown → Confirmed
Changed in empathy:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.