contact list oddities with xmonad

Bug #393138 reported by Toni Ruottu on 2009-06-28
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Empathy
Expired
Medium
xmonad
New
Undecided
Unassigned
empathy (Ubuntu)
Low
Unassigned
xmonad (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: empathy

I occasionally use Xmonad window manager instead of Metacity in my mostly vanilla Ubuntu system. While using xmonad, the contact list no longer disappears when I click on the notification bar icon. Also while using xmonad, the contact list window is not visible in the works space switcher. Pidgin works ok with xmonad, so this must be a bug in Empathy.

Sebastien Bacher (seb128) wrote :

doesn't seem an application bug, the fact that it works in one case and not other doesn't make it a software bug

Changed in empathy (Ubuntu):
status: New → Invalid
importance: Undecided → Low
Changed in empathy:
status: New → Invalid
Toni Ruottu (toni-ruottu) wrote :

Do you suggest that Empathy contact list is not supposed to disappear and Pidgin contact list is?

Mark Hepburn (mark-hepburn) wrote :

I can confirm this (in Jaunty and Karmic, xmonad 0.8 and 0.9 -- although I'm using a cabal-installed xmonad rather than a distribution version)

Wei Ribao (rbwei) wrote :

I have this too. And another problem might be related: with this line in xmonad's config:

 , className =? "Empathy" --> doF(W.shift "9:im")

the contact list does not react as expected(automatically be shifted to workspace 9).

kovariadam (kovariadam) wrote :

Same here. Fedora 12.

Martin Ling (martin-launchpad) wrote :

Also seeing this, in current Karmic.

What's worse, the Empathy contact window doesn't respond to the normal xmonad close window command. So it's actually impossible to close it at all when using xmonad. I have never seen another window behave like this, and I've used xmonad extensively with many applications.

Changed in empathy (Ubuntu):
status: Invalid → Confirmed
Brian Curtis (bcurtiswx) wrote :

This is still not a software bug. Please don't change the empathy task away from invalid.

Changed in empathy (Ubuntu):
status: Confirmed → Invalid
Martin Ling (martin-launchpad) wrote :

Brian,

Further to the above:

If I right click the Empathy status icon, there is a checkbox for "Show contact list", which is checked. If I click it, it does not change to unchecked, and the Empathy contact window does not disappear.

How is this not a bug in Empathy?

Brian Curtis (bcurtiswx) wrote :

Martin: does this work in Rhytymbox?

Brian Curtis (bcurtiswx) wrote :

If this works in rhythmbox then it's potentially an empathy problem. If it doesn't work, then this is either a xmonad or gtkstatusicon problem. Since pidgin doesn't use gtkstatusicon while empathy and rhythmbox do.

Martin Ling (martin-launchpad) wrote :

Brian,

Yes, this works fine for Rhythmbox.

Brian Curtis (bcurtiswx) wrote :

OK. Please gather debugging information and attach the logs here. You can find necessary instructions at http://live.gnome.org/Empathy/Debugging .

Changed in empathy (Ubuntu):
status: Invalid → Incomplete
Changed in empathy:
status: Invalid → New
Martin Ling (martin-launchpad) wrote :

Sorry, I've just realised I was running the PPA version of empathy. I'd added the PPA a long while back and forgotten about it. The current karmic version is okay.

I'll check the lucid version for this when I've upgraded to that release.

Omer Akram (om26er) wrote :

Martin, is this still an issue in Lucid?

Mark Hepburn (mark-hepburn) wrote :

It's still an issue, but only if you're not using empathy with the indicator applet (for me). There's an option in the preferences, "Show incoming messages in the messaging menu", which if un-checked displays an empathy icon in the notification panel instead of the indicator applet.

If this is unchecked, then clicking the notification icon opens the empathy window (just like pidgin), but clicking it again doesn't close it and no other close action works either (eg, mod-shift-c from xmonad).

On the other hand, if this option is checked and the buddy list is opened from the indicator messaging menu then it can be closed as normal.

grimborg (grimborg) wrote :

Whenever I double click on a nickname to start a conversation, the conversations window pops up in a random desktop, then I'm switched to that desktop. It's extremely annoying.

Any workarounds, anyone?

Martin Ling (martin-launchpad) wrote :

I have just upgraded to Lucid and am seeing the same problems as Mark Hepburn in comment #15.

Brian Curtis (bcurtiswx) wrote :

@ Martin Ling. This is the behavior I get with metacity as well. Would you rather have the contact list minimize and maximize like the empathy icon does to it when you click it? We can make this a wishlist item for enhancements (and switch to the indicator-applet package) if you think that better solves your bug?

Martin Ling (martin-launchpad) wrote :

Brian,

I'm not sure if you've followed me.

The bug occurs when empathy is *not* set to use the indicator applet (i.e. "Show incoming messages in the messaging menu" is unchecked), and therefore has its own icon in the status area. Under metacity, clicking that empathy icon toggles whether the contact list appears. Under xmonad, it doesn't, and the contact list is also impossible to close manually.

The reason I think this is a bug in empathy rather than xmonad is that right clicking the icon and clicking the "Show Contact List" checkbox has no effect either.

I'm not interested in what the entry in the indicator applet menu does. I want single-click access to the contact list, which is why I chose the setting that retains the separate empathy icon (even though the visual representation of status is then annoyingly duplicated by the session applet).

Hi,

xmonad ignores gtk_window_iconify(). I suppose it has no concept of minimized wndows, unless you program it to handle them.

The gtk docs "note that you shouldn't assume the window is definitely iconified afterward." So to take care of this case, add a gtk_widget_hide() to empathy_window_iconify().

Please see attached patch for empathy 2.30.2. I have tested it in xmonad and metacity. Only problem is that it disables the "minimize" animation.

Cheers,

Rodney

tags: added: patch
Vish (vish) wrote :

Rodney Lorrimar , Thanks for the patch, This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME .
Once submitted upstream , do report back here with the upstream bug number.Thanks in advance!

Changed in empathy (Ubuntu):
status: Incomplete → New
Martin Ling (martin-launchpad) wrote :

Still getting this under 10.10.

I have sent the bug upstream: https://bugzilla.gnome.org/show_bug.cgi?id=636306

Omer Akram (om26er) wrote :

thanks for sending this bug to Gnome.

Changed in empathy:
importance: Undecided → Unknown
status: New → Unknown
Changed in empathy (Ubuntu):
status: New → Triaged
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Changed in empathy:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.