Empathy could use an Ubuntu-specific Adium theme

Bug #392488 reported by Nicolò Chieffo on 2009-06-26
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Adium Theme Ubuntu
Undecided
Ken VanDine
One Hundred Papercuts
Low
Unassigned
empathy (Ubuntu)
Wishlist
Ken VanDine

Bug Description

Binary package hint: empathy

Since adium themes support is now present, empathy needs a default theme that matches ubuntu.
renkoo [1] can be a great start, but it needs some improvements:
- the contact name of the sender should be in the top of the bubble
- the image wastes lots of space because it allows text to appear only at its right
- the javascript appendMessage and appendNextMessage should be fixed to scroll only if the scrollbar is at the bottom of the page
- fix fader to work also with status messages (such as join parts in chat rooms), and prevent the javascript crash which is currently caused

[1] http://www.adiumxtras.com/index.php?a=xtras&xtra_id=2160

Thanks for the report, yeah that's one of the things that would be really nice to have, could you maybe do a mockup of a theme so the artist can work on it later? Thanks in advance Nicolo.

summary: - empathy needs an adium theme
+ empathy needs an Ubuntu adium theme
Changed in empathy (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Nicolò Chieffo (yelo3) wrote :

If you like it I have the source of this theme (derived from renkoo).
I have corrected some problems I reported previously:
- contact name at the top of the bubble
- javascript scrolls well now
- I prevented the javascript crash caused by the fader, but it does not fade when receiving status messages (such as "XXX joined the room") of course it sill fades when receiving and sending normal messages

Alejandro Vidal (mancvso) wrote :

Well, renkoo is a good alternative for a light theme...

AND Ravenant Dust is the best alternative for a dark theme... i'll do a mockup to improve both, i'll post it later.

Ravenant Dust: http://live.gnome.org/Empathy/Themes/Ravenant_Dust

yeap, from gnome Live!

Alejandro Vidal (mancvso) wrote :

can I have the source please?

dael99 gmail com

watch this:
https://wiki.ubuntu.com/Artwork/Incoming/Karmic/EmpathyThemes

Romain Fluttaz (r.fluttaz) wrote :

How could we add adium themes ? There is no ~/.local/share/adium/message-styles/ directory.
So this doesn't work http://live.gnome.org/Empathy/Themes

Any way to make it works with Empathy 2.27.5 ? No adium themes in themes list.

Romain Fluttaz (r.fluttaz) wrote :

Actually we just have to create manualy the directory to make it appears in the theme list :

mkdir ~/.local/share/adium
mkdir ~/.local/share/adium/message-styles

And put your *.AdiumMessageStyle themes directory in ~/.local/share/adium/message-styles/ and you should see the theme in the list !

I suggest we choose an existing theme to minimize work (e.g. Renkoo) and modify it to look splendid on Ubuntu!

Changed in hundredpapercuts:
milestone: none → lucid-round-4
status: New → Confirmed
tgpraveen (tgpraveen89) wrote :

the prob with renkoo is that it is not suited for multiuser chat like irc etc
and currently empathy uses the same theme for both single and multi user chat
a bug for separate themes for separate modes has been requested upstream (by me only iirc)

iTorrey (rice) wrote :

I'm working on making this port. tgpraveen can you given an example of why the Renkoo theme isn't suited to multiuser chat like IRC?

Changed in empathy (Ubuntu):
assignee: nobody → iTorrey (rice)
Nicolò Chieffo (yelo3) wrote :

I use this theme for multi user chats and I find it normally usable

Nicolò Chieffo (yelo3) wrote :

iTorrey if you like I can post the source of the renkoo I modified. I corrected the bugs listed in the bug description

tgpraveen (tgpraveen89) wrote :

in IRC rooms with many people and many msgs, the fadeing effect can take a lot of time and be annoying
and a msg takes a lot of space in the chat window this again can cause problems with many msgs being there.

summary: - empathy needs an Ubuntu adium theme
+ Empathy could use an Ubuntu-specific Adium theme
iTorrey (rice) wrote :

Nicolò Chieffo: That'd be great, thanks.

Nicolò Chieffo (yelo3) wrote :

as requested, an edited version of renkoo to correct some problems.

Nicolò Chieffo (yelo3) wrote :

tgpraveen please try my version, maybe you prefer it

tgpraveen (tgpraveen89) wrote :

@nicolo it is better indeed thx

Achim (ach1m) wrote :

I have tested the the renkoo-edited.tar.bz2 theme and I have noticed that the user image in a chat window look too small and pixelated in comparison to the example image at [1]. I don't know if this is a theme bug or a bug in empathy.

The user image is usually 96x96 maybe it's smalled in the theme, but I
don't remember I changed the default size

Achim (ach1m) wrote :

Thanks for your quick reply Nicolò.

I have changed the size of the avatar to 32px and did a little comparison to the roster avatar which has the same size.
As you can see, the image in the theme looks pixelated. I think this is because the image gets resized without any filtering.

iTorrey (rice) wrote :

Here is an initial mockup of the theme. I could use some direction on the color scheme but these colors are based on the colors used in Ubuntu at the moment.

iTorrey (rice) wrote :

Adding another mockup with adjusted colors.

Rich Jones (richwjones) wrote :

Please no brown oh god no :(

iTorrey (rice) wrote :

Rich Jones: What would you suggest?

Nicolò Chieffo (yelo3) wrote :

I also find not correct to put the nickname at the bottom of the
message: it must be the first thing, as in every chat program

iTorrey (rice) wrote :

I'll move the names and rework the colors tonight or tomorrow.

Rich Jones (richwjones) wrote :

Please avoid Brown. We should really be phasing that out. I would stick with natural colors, perhaps a combination of pale blue and green.

Although this should probably be handled by the design/desktop team.

iTorrey (rice) wrote :

Attached is a mockup which moves the name and timestamp to the top and uses the default Renkoo color scheme.

iTorrey (rice) wrote :

@Nicolò Chieffo your theme looks like it fixes the issues that people were concerned with. So it's just down to what colors to use and that's probably something the design/desktop team should direct us on. I can post the source files here and create the graphics with the colors.

What action should I take?

Nicolò Chieffo (yelo3) wrote :

Did you backport the fixes to the fader and scrollbar?

Now I remember I did lots of other changes, Unfortunately I don't remember exactly what I did, because it was long ago, maybe 1 year or more, but I'll try to remember:

- I edited the font colors, which weren't used with consistency. And maybe I didn't change things accordingly to the possibility to have color variants.
- I then changed Context.html and NextContext.html, which are responsable of handling history messages (conversation logs): I greyed out them and added the word "BACKLOG" (which is not really what a user should expect, also because the string is not internationalized)
-I moved the time (removing the seconds and keeping only the HH:MM format) to the end of the message, so every new message which is appended to the first one will show when it was sent. I also tried to add the day and month in history message, but I wasn't able to do it.
- I added a buddy icon border, because If you choose to have a background of another color, a blank image looks really bad without a border.

Tell me what do you think about these changes, and try to review and improve them (I'm not an expert)

Vish (vish) on 2010-01-25
Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged

@iTorrey Can you please attach a version of the theme that you're proud of so we can put it in a Lucid alpha and begin to test it?

Also, as the Adium duck been replaced yet? :)

iTorrey (rice) wrote :

David,

Here is the latest build. I've replaced the duck with the default Ubuntu 'person' icon. I've put the name first and updated the colors a bit for the timestamp and name. I've also ripped out the old animation code and am now using a webkit CSS animation

Changed in empathy (Ubuntu):
assignee: iTorrey (rice) → Ken VanDine (ken-vandine)
Omer Akram (om26er) wrote :

when using renkoo in IRC If a person send me a message with my name there is no particular color for that so that I could get attention.

iTorrey (rice) wrote :

Can someone provide me with the CSS class name that's used when the IRC client alerts someone that their name has been said?

Changed in adium-theme-ubuntu:
status: New → Fix Committed
assignee: nobody → Ken VanDine (ken-vandine)
Vish (vish) wrote :

We now have an Adium specific theme in Lucid.
Marking bug as fixed

Changed in hundredpapercuts:
status: Triaged → Fix Released
Omer Akram (om26er) wrote :

Now default theme is ubuntu

Changed in adium-theme-ubuntu:
status: Fix Committed → Fix Released
Changed in empathy (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers