offers to import irc accounts from pidgin even if telepathy-idle is not installed

Bug #388906 reported by Roy Jamison on 2009-06-18
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Empathy
Expired
Medium
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

Select import accounts, then choose IRC from pidgin and it does not import it, neither does it connect to the MSN network with username and password.

ProblemType: Bug
Architecture: amd64
Date: Thu Jun 18 11:40:38 2009
DistroRelease: Ubuntu 9.10
Package: empathy 2.27.2-1ubuntu1
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-9.10-generic
SourcePackage: empathy
Uname: Linux 2.6.30-9-generic x86_64

Roy Jamison (xteejx) wrote :
Guillaume Desmottes (cassidy) wrote :

Do you have telepathy-idle installed?

Changed in empathy (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Roy Jamison (xteejx) wrote :

No I don't have, will install it and report back when I can. Shouldn't this be installed with empathy by default, maybe put this in as a dependency for the rebuild of it after the alpha 3 breakage is fixed?

Roumano (roumano-dinoutoo) wrote :

Same problem, resolved with installation of telepathy-idle.

It's will be cool to propose to install this package on telepathy on the import if a irc import is found ?

Roy Jamison (xteejx) wrote :

Can we have this as a dependency or a Suggests in the package?

Changed in empathy (Ubuntu):
status: Incomplete → Confirmed
Jeremy Bicha (jbicha) wrote :
Scott Ritchie (scottritchie) wrote :

The importation doesn't work right. I got a bunch of IRC accounts that all appear to be on "2600 net" (since it's first on the list), and none of my autojoin chats were put into favorites.

Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Brian Curtis (bcurtiswx) wrote :

Scott,

I think you may want to dup one bug into the other and this can't be marked triaged until its been sent upstream to the gnome bugzilla for empathy

Changed in empathy (Ubuntu):
status: Triaged → Confirmed
Scott Ritchie (scottritchie) wrote :

Since there are still issues even when telepathy-idle is installed (eg no "favorite" autojoin IRC chats) I think we should leave this open.

the bug still exists even after todays karmic's updates.
did anyone brought upstream's attention into this ?

telepathy-idle : 0.1.4-1
empathy 2.27.92-1ubuntu2
pidgin 1:2.6.2-1ubuntu3

possible upstream bug reports :
https://bugzilla.gnome.org/show_bug.cgi?id=590130
https://bugzilla.gnome.org/show_bug.cgi?id=586136

summary: - [karmic] empathy does not import irc from pidgin
+ empathy does not import irc from pidgin
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
status: Triaged → New
status: New → Triaged
status: Triaged → New
status: New → Triaged
Roy Jamison (xteejx) on 2009-10-22
Changed in empathy (Ubuntu):
importance: Low → Undecided
importance: Undecided → Low

Still no accounts imported in empathy.

telepathy-idle 0.1.5-1
empathy 2.28.1-1ubuntu1
pidgin 1:2.6.2-1ubuntu7

Tudor Holton (tudor) wrote :

If I deselect my IRC accounts from the import window, it imports all the others. This must mean that importing IRC accounts is stopping the import of other protocols.

This means that this bug is having a direct effect on bug #474929.

Omer Akram (om26er) wrote :

import works fine if telepathy-idle is installed (empathy 2.29.5) but if telepathy idle is not installed then still empathy gives the option to import irc account and does not add it. The upstream bug is the same.

Omer Akram (om26er) on 2010-01-18
summary: - empathy does not import irc from pidgin
+ offers to import irc accounts from pidgin even if telepathy-idle is not
+ installed
Roy Jamison (xteejx) wrote :

Not too sure if this is fixed now:

$ apt-cache rdepends telepathy-idle
telepathy-idle
Reverse Depends:
  telepathy-core
  lernid
  ubuntu-netbook
  ubuntu-desktop
  empathy

Changed in empathy:
importance: Unknown → Medium
status: Unknown → Confirmed
Sam Brightman (sambrightman) wrote :

I have telepathy-idle installed (Karmic). Import failed silently. How do I make it try again? I'd like to repeat this, try only doing some accounts etc.

Sam Brightman (sambrightman) wrote :

You can force it to try again by deleting (or moving) ~/.gconf/apps/empath/%gconf.xml

When I tried again with IRC accounts disabled it imported the others.

Changed in empathy:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.