Add video chat for MSN

Bug #333675 reported by Kẏra on 2009-02-24
190
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Empathy
Unknown
Wishlist
libtelepathy
Invalid
Undecided
Unassigned
telepathy-butterfly
Fix Released
Wishlist
empathy (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Sebastien Bacher
libtelepathy (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Sebastien Bacher
telepathy-butterfly (Debian)
Fix Released
Unknown
telepathy-butterfly (Ubuntu)
Wishlist
Unassigned
Declined for Karmic by Sebastien Bacher

Bug Description

Binary package hint: empathy

Currently, video calling is not supported for MSN. This is a wishlist item i'm filing as a bug to keep track of progress

Kẏra (thekyriarchy) on 2009-02-24
Changed in empathy:
importance: Undecided → Unknown
status: New → Unknown
YoBoY (yoboy-leguesh) wrote :

Thank you for taking the time to make Ubuntu better.

Changed in empathy:
status: New → Confirmed
Changed in empathy:
status: Unknown → Invalid
Daniel Hollocher (chogydan) wrote :

As stated upstream, filing this wishlist item against empathy is invalid

Changed in empathy (Ubuntu):
status: Confirmed → Invalid
WhyteHorse (whytehorse) wrote :

Thank you fer yer support! You can use gtalk2voip to make an MSN vvoip conference with telepathy.

Changed in libtelepathy:
status: New → Invalid
Changed in libtelepathy (Ubuntu):
status: New → Invalid

Creating a bug here since there are many downstream.

The branches to watch are lrfb
  * Papyon branch http://git.collabora.co.uk/?p=user/lfrb/papyon/.git;a=summary
  * Butterfly branch http://git.collabora.co.uk/?p=user/lfrb/telepathy-butterfly/.git;a=summary

Changed in telepathy-butterfly (Ubuntu):
importance: Undecided → Wishlist
Changed in telepathy-butterfly (Debian):
status: Unknown → New
Greg A (etulfetulf) on 2009-06-28
Changed in telepathy-butterfly (Ubuntu):
status: New → Confirmed
Changed in telepathy-butterfly:
importance: Undecided → Unknown
status: New → Unknown
Changed in telepathy-butterfly (Ubuntu):
status: Confirmed → Triaged
Changed in telepathy-butterfly:
status: Unknown → Confirmed
Anders (andersja+launchpad-net) wrote :

MSN Video chat ... Who uses *that* ? ;-) http://xkcd.com/619/

Brian Curtis (bcurtiswx) wrote :

Nice cartoon. But i'm assuming it hasn't been done yet because its complicated. Pidgin has been trying to implement audio/video for all major specs but it has so far failed to do so. If i had to say the next major task for Linux in general should be fully supported video chat, I am as impatient as everyone out there too. I hope it gets done, and if I knew how to code with GTK i would try to do it.

Anders (andersja+launchpad-net) wrote :

Brian - I agree. However aMSN successfully implemented MSN video chat in the past. Unless there has been significant protocol changes, there should be libraries and/or code ripe for re-use...

Nicolò Chieffo (yelo3) wrote :

fix committed in telepathy-butterfly 0.5.1 (upstream)
not yet released in karmic

Brian Curtis (bcurtiswx) on 2009-09-14
Changed in telepathy-butterfly (Ubuntu):
status: Triaged → Fix Committed
Laurent Bigonville (bigon) wrote :

I've uploaded the pkg in debian

Awesome! Hope this will trickle through for the Karmic release.
More info for the interested reader:
http://cass.no-ip.com/~cassidy/blog/index.php/post/2009/09/14/MSN-audio/video-chat-in-Telepathy

Changed in telepathy-butterfly:
status: Confirmed → Fix Released
Guillaume Desmottes (cassidy) wrote :

telepathy-butterfly 0.5.1 is now in the Ubuntu PPA (Karmic)

I installed from Karmic + the telepathy ppa and yet still can't initization anything by an audio call with an MSN user.. are there more bits missing?

Laurent Bigonville (bigon) wrote :

karmic + telepathy ppa should work

And yet that does not seem to work for me, however that is sounding like a bug worth of a separate report since you confirmed that it should work with karmic + ppa

Changed in telepathy-butterfly (Debian):
status: New → Fix Released
Laurent Dinclaux (dreadlox) wrote :

Updated karmic and https://edge.launchpad.net/~telepathy/+archive/ppa: MSN audio and video support is buggy.

Audio works between two empathy clients.
But nothing between MSN client and Empathy. Sometimes it makes the desktop crash. telepathy-butterfly often crashes too.

Bug can't be reported as it is not Ubuntu core package...

jc1985 (jc1985) wrote :

I just did an audio/video call between Karmic Telepathy's ppa packages and the official Windows Live Messenger client (on windows 7) and everything worked perfectly.

Sebastien Bacher (seb128) wrote :

the issue is fixed in lucid now!

Changed in telepathy-butterfly (Ubuntu):
status: Fix Committed → Fix Released

That's great! Will the fix be backported to Karmic?
I know I can also use the Telepathy ppa, but that one does not have the
patches for the indicator-applet, making it useless for me.

On Wed, Nov 25, 2009 at 18:53, Sebastien Bacher <email address hidden> wrote:

> the issue is fixed in lucid now!
>
> ** Changed in: telepathy-butterfly (Ubuntu)
> Status: Fix Committed => Fix Released
>
> --
> Add video chat for MSN
> https://bugs.launchpad.net/bugs/333675
> You received this bug notification because you are a direct subscriber
> of the bug.
>

When will it be released in ubuntu? I am using ubuntu Lucid and I still can't call through MSN with a webcam or even a microphone. Is it planned to be included in Lucid since it is supposed to be stable now? And the thing is that in the documentation, it is said that the audio/video is supported on the MSN prrotocol.

It was released in Lucid and then got disabled because it was broken Microsoft removed the necessary server for this to work.

Ernst (ernst-blaauw) wrote :

I believe there will be no support for msn audio/video anytime soon, as
Microsoft has closed the servers which were used by most (all?) open source
implementations. Read this aMSN blog:
http://kakaroto.homelinux.net/2010/03/amsn-0-98-2-to-be-released-without-audiovideo-support/
<http://kakaroto.homelinux.net/2010/03/amsn-0-98-2-to-be-released-without-audiovideo-support/>

On Wed, Mar 17, 2010 at 15:56, Thibault Saunier
<email address hidden>wrote:

> When will it be released in ubuntu? I am using ubuntu Lucid and I still
> can't call through MSN with a webcam or even a microphone. Is it planned
> to be included in Lucid since it is supposed to be stable now? And the
> thing is that in the documentation, it is said that the audio/video is
> supported on the MSN prrotocol.
>
> --
> Add video chat for MSN
> https://bugs.launchpad.net/bugs/333675
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Tony Pursell (ajpursell) wrote :

This really is a big blow to those of us who have been hoping it would come good in Lucid. Now it looks as though it will not even be in Zingy Zebra (or whatever the April 2017 release is called). We must not lose sight of key features that Windows users expect or we will never solve this bug

https://bugs.launchpad.net/ubuntu/+bug/1

Those of us who support Ubuntu in many ways but do not have the necessary programming skills feel so powerless in these situations.

John McCourt (butterman) wrote :

This is a dealbreaker for me.

I believe we still could get just webcams working, it still works with aMSN. I really would like to see that available in Empathy as it is all I need to switch. I get the voice part from Skype since I have that on my phone and my n810 which unlike my computer I can carry those around the house or take with me to town while I talk to my girlfriend.

diego (marcodiegomesquita) wrote :

Now that the protocol has changed webcam chat is no longer supported. Please re-open this bug.

Changed in telepathy-butterfly:
importance: Unknown → Wishlist
Changed in empathy:
importance: Unknown → Wishlist
status: Invalid → Unknown
diego (marcodiegomesquita) wrote :

Does https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/661609 means that this bug is finally fixed?

Changed in telepathy-butterfly:
importance: Wishlist → Unknown
Changed in telepathy-butterfly:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.