Ubuntu

Empathy doesn't alert to new email messages

Reported by Kẏra on 2009-02-21
162
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Empathy
New
Wishlist
Nominated for Trunk by G.J. Sterenborg
empathy (Ubuntu)
Wishlist
Unassigned
Nominated for Lucid by Eric Obrock

Bug Description

Binary package hint: empathy

Empathy should be able to alert when there is a new email or at least have a link to check for email on all the protocols that support this.

Changed in empathy:
importance: Undecided → Wishlist
Slick (slick666) wrote :

Added this to upstream Gnome Buzilla.

Reported by NY ubuntu Loco Group

Changed in empathy:
importance: Undecided → Unknown
status: New → Unknown
Chris Coulson (chrisccoulson) wrote :

Thank you for sending that upstream Slick. However, Xavier responded to the upstream report and said that he wouldn't be willing to add this functionality to Emapthy, as it is something that Evolution can already do:

"Empathy is not an email client. Evolution can already do email notification...

closing as wontfix unless you have real argument to do that."

I'm going to close this as Won't Fix too.

Thanks

Changed in empathy:
status: New → Won't Fix
Changed in empathy:
status: Unknown → Won't Fix
Changed in empathy:
status: Won't Fix → New
Rocko (rockorequin) wrote :

The problem is that Ubuntu is making empathy the default IM application in karmic. Pidgin has the ability to notify about new emails, but empathy doesn't. So moving to empathy is a regression in functionality.

G.J. Sterenborg (gevoelig) wrote :

I have just given empathy a try and definitely agree with Rocko.

G.J. Sterenborg (gevoelig) wrote :

Since you were asking for real arguments...

Most IM application provide this functionality (aMsn, pidgin, gt, etc.)
People have gotten used to this and like to use the webmail interfaces instead of evolution.

Ssaha (shinjansaha) wrote :

i'm using empathy in jaunty and it does not give email notifications...
why has it been marked as'won't fix' i don't know...

Jon Storry (jon-storry) wrote :

My argument for this feature would be the checking of accounts that aren't supported by Evolution such as hotmail and yahoo. Also as these types of accounts are web based it is not necessarily desirable or possible to use evolution to check them. For me this is a make or break feature, if it's not available I will go back to pidgin.

Empathy is the default IM comes with 9.10. Its a basic functionality to notify the users if they login to IM. Is there any chance that this bug will be reconsidered and provide the solution.
I would at least expect the workaround for this small requirement.

Marcello (pogliamarci) wrote :

- Evolution can do email notification for IMAP and POP3 accounts which I've configured in it, not for webmail accounts without IMAP\POP3 support, such as Hotmail\Live maill! (again, Pidgin has this functionality)

Andrew Hayzen (andrew-hayzen) wrote :

This would tip the boat to Empathy over Pidgin. As Empathy is the default it would be nice for it to notify you then have a like to the web mail ( like Pidgin ). Otherwise everyone will go back to Pidgin because of this extra functionality. So this is a deciding factor for me and many other people over which client they will use.

hemebond (hemebond) wrote :

POP3 access to Hotmail accounts has been available since March this year. See http://wiki.answers.com/Q/What_is_the_POP_server_for_hotmail.

roxy (rafal-nowak) wrote :

I have started using emapthy since I installed 9.10. I had had gajim before, and it had notified me about new emails. I agree that this feature is important. Of course one can use evolution, but I don't like email clients other than gmail, so I don't use evolution. But if I want to talk I prefer IM. Emapthy seems to be nice and simpler than pidgin or gajim. But it does not notify .... sad :-(

Brian Curtis (bcurtiswx) wrote :

It's just as easy to load evolution/gmail at startup as it is to have an IM client tell you about your E-mails. Checkgmail is a great tool for gmail. Any other accounts you can use evolution, and have it load at startup. The reason the Empathy devs chose not to is because of the idea that the functionality is already available elsewhere.

If you wish to further your opinion on the matter, it would be better served by going to the upstream developers and discussing there. Discussing here will get nowhere.

JRush (jrush-mail) wrote :

i need this feature too (gmail notification for googletalk user)

I would recommend docky (i know for sure has a gmail notifier) or AWN
0.4 (not sure). Otherwise evolution does the trick.

I really think this should be re-addressed. Many users are making compelling arguments to adding the notifier feature. I beg that it be done.

Changed in empathy (Ubuntu):
status: Won't Fix → New
Changed in empathy (Ubuntu):
status: New → Triaged
Linus_W (linus-wolter) wrote :

I think it should be fixed. This is the only reason that i use pidgin instead of empathy!

Omer Akram (om26er) wrote :

@Linux_W empathy is an upstream project and is not developed by ubuntu developers so ubuntu can't do anything about this *feature* unless its supported upstream :)

Philip Stewart (sodoku) wrote :

For me the reason is, that xmpp supports push. Evolution and other clients need to pull every x seconds.

Brian Curtis (bcurtiswx) wrote :

What I said earlier, and still holds true, is that you need to tell the upstream people that you really want this since us in Ubuntu can do nothing at this point. Click the link the the upstream bug on the top of this bug report and tell them. There hasn't been anyone talking since March of last year.

Brian, are you referring to this forum? https://bugzilla.gnome.org/show_bug.cgi?id=572700

If so, support from as many users as possible on that forum may certainly help our cause.

Linus_W (linus-wolter) wrote :

I added a comment to bugzilla! We need more people who request this function!

Chris Coulson (chrisccoulson) wrote :

On 25 January 2010 20:15, Eric Obrock <email address hidden> wrote:

> Brian, are you referring to this forum?
> https://bugzilla.gnome.org/show_bug.cgi?id=572700
>
> If so, support from as many users as possible on that forum may
> certainly help our cause.
>
>
No, it almost certainly won't help your cause. Encouraging users to add
comments asking for the problem to be fixed will only annoy the developers
that are subscribed to that bug report. Bugzilla is a bugtracker - it is not
a forum for users to post "me too's". Please only add comments if they
contribute something to fixing the problem.

I don't care if we're "annoying the developers". To me it sounds like the whole reason they hadn't worked on this in the first place is a lack of understanding that a mail notifier is an extremely important feature to MANY users.

The issue is Ubuntu has made an Empathy to be the default client, and if the developers can't handle a few requests to improve their software then why are they "developing" in the first place? I find it hard to believe they only want to spend their valuable time fixing bugs, instead of making an inferior product truly ready for the open market.

Omer Akram (om26er) wrote :

please write your suggestions/comments at the ustream bug report

nuttycat (nuttycat) wrote :

Can one of the developers here please point/link to the correct upstream bug report?
There are multiple comments here saying 'tell upstream', but if there was a link to where upstream is, I think it would help people who reach this page looking for a fix to this issue.

Ben (klinerdraken) wrote :

a quick google search and i found this, hope it helps

http://live.gnome.org/Empathy#Bugs

Omer Akram (om26er) wrote :

nuttycat: the link is at the top of the page. any ways here https://bugzilla.gnome.org/show_bug.cgi?id=572700

nuttycat (nuttycat) wrote :

According to Chris (in post #23) the bugzilla link to (bug 572700) is not the place to go?
I'm completely new to this source-code (but not to programming), I'll see, maybe I can help somehow. Thanks anyway.

Changed in empathy (Ubuntu):
importance: Wishlist → Medium
Fabián Rodríguez (magicfab) wrote :

I am raising this to medium, as per https://wiki.ubuntu.com/Bugs/Importance:
* A bug that has a moderate impact on a core application.

My rationale is that Empathy has replaced Pidgin as the core IM application in Ubuntu, and as such there still is an expectation that it should have the same or better/more features. In some cases like this one it's not and it's important functionality present across several services (I checked MSN, GTalk, Yahoo). It's also functionality present in other IM clients in their respective OS, which maintains the expectation even for new Ubuntu users.

I took a brief look to the upstream bug and it's blocked by two other bugs, including another spec and undrafting the original spec. If you look at the spec for this it's been worked on for quite some time now so it's not something that has been ignored, or dismissed. I'll see if I can get more information on how to best help upstream with this.

Changed in empathy:
importance: Unknown → Wishlist

Sorry to be harsh but #2 is a lame cop-out. This wouldn't cause feature overlap with Evolution at all, since running Evolution just for mail notifications currently necessitates running dirty hacks like alltray and also requires running the entire evolution process in the background.

Incorporating this feature into Evolution would fit perfectly into what is probably the most common use case. If a user is available to chat, they probably don't care about being distracted by email notifications, if they aren't logged in, they probably don't want to be distracted.

Also, correct me if I'm wrong but isn't Google Talk capable of sending mail notifications via the XMPP protocol?

Sorry, I meant to say "Incorporating this feature into Empathy" as opposed to "Evolution" in the comment above.

Google Talk does indeed have a documented extension to the XMPP protocol, which allows clients to "subscribe" to push notifications for new emails. The fact that these notifications are "pushed" relieves the client of the need to poll the server on a set interval and makes them (theoretically) almost instant.

Support for this feature is surely worth considering, even if it is only Google Talk that currently offers it. It would be particularly useful for the many people who choose not to use Evolution to read their mail but still require notifications.

The feature is documented at: http://code.google.com/apis/talk/jep_extensions/gmail.html

altima (timashkov) wrote :

the lack of this feature is the only reason why I haven't yet switched to Empathy from Pidgin. and I won't switch to it till the feature appears.
as for Evolution, most people today use webmail as internet connectivity is no longer a problem and web interfaces have become sweet.

Exeleration-G (exeleration-g) wrote :

I'm seconding this. It'd be nice if Empathy could have a small button with a number on it, representing the number of emails. I don't think that it'd be hard to create sort of a 'get' mechanism to retrieve the number of emails. I'm not a coder myself, but I just think that it's possible with few steps.

pablo stach (pablo9586) wrote :

empathy would be much better with a mail alert and the feature to close conversations with ESC

Brian Curtis (bcurtiswx) on 2012-05-24
Changed in empathy (Ubuntu):
importance: Medium → Wishlist
Egor Ananyev (egor-ananyev) wrote :

It would be really nice if this basic feature was implemented.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.