Package description not suitable for end-users

Bug #259788 reported by Matthew Paul Thomas on 2008-08-20
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

Ubuntu Intrepid alpha 3

1. Open Add/Remove Applications.
2. From the "Show" menu, choose "All Open Source applications".
3. Choose the "Internet" category.
4. Scroll through the list to find "Empathy Instant Messenger".
5. Read the description.

What you see:

    Empathy Instant Messenger
    High-level library and user-interface for Telepathy

    Empathy consists of a rich set of reusable instant messaging widgets, and a GNOME client using those widgets. It uses Telepathy and Nokia's Mission Control, and reuses Gossip's UI. The main goal is to permit desktop integration by providing libempathy and libempathy-gtk libraries. libempathy-gtk is a set of powerful widgets that can be embeded [sic] into any GNOME application.

    This packet contains the empathy IM application and account manager.

What you should see: A description that actually helps end users decide whether they want to install the program. If this description uses the words "consists of", "desktop integration", "embeded" (or "embedded"), "GNOME", "Gossip", "high-level", "libempathy", "library", "main goal", "Nokia's Mission Control", "packet", "rich", "Telepathy", "UI", "user-interface", or "widgets", you're doing it wrong.

A useful description might mention which types of account you can use with Empathy, and any interesting features it has.

Matthew Paul Thomas (mpt) wrote :

Steps to fix this:
1. draft a useful description here
2. submit a patch to Debian
3. sync once it's fixed in Debian

Changed in empathy:
importance: Undecided → Low
status: New → Confirmed

how about:

Instant messenger for GNOME
Empathy is an instant messaging and VOIP client capable of using Jabber, Salut, Google Talk, AIM, SIP, Gadu-Gadu, Groupwise, ICQ, IRC, MSN, QQ, and Yahoo.

Empathy also provides of a rich set of reusable instant messaging widgets for use in other GNOME applications. It uses Telepathy and Nokia's Mission Control, and reuses Gossip's UI.

Xavier Claessens (zdra) wrote :

I prefer "Audio/Video" instead of "VOIP".

Jonathan Ernst (jonathan.ernst) wrote :

and it's VoIP not VOIP by the way

Fabián Rodríguez (magicfab) wrote :

"It uses Telepathy and Nokia's Mission Control, and reuses Gossip's UI." also assumes the reader would know about those. Either link to an extended description / resources or remove that.

VoIP assumes the reader knows the acronym, I'd agree Audio/Video should be mentioned, making it clear what protocols are supported for those.

Unless that protocols list is complete and permanent, I'd also add " and others" to it. I'd also remove IRC and SIP until they are in the interface.

I am also confused by "Salut". Is that Bonjour renamed because of trademark issues ?

On Wed, Nov 26, 2008 at 2:20 PM, Fabián Rodríguez <email address hidden> wrote:

>
> I am also confused by "Salut". Is that Bonjour renamed because of
> trademark issues ?
>

Yep, this is a link-local protocol from what I understand for chatting
with people on your LAN, so no need to have a server setup.
I'm sure a developer will provide you more information :)

--
Baptiste Mille-Mathias
Les gens heureux ne sont pas pressés

summary: - empathy package description is near-useless to end users
+ Package description not suitable for end-users
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Evan R. Murphy (evanrmurphy) wrote :

Proposed description, drawing from previous comments, Danny Piccirillo's draft in Bug #332371 [1] and Empathy documentation:

  Empathy Instant Messenger
  IM with your friends

  Instant messaging program supporting text, voice, video, file transfers and inter-application communication over many different protocols, including: AIM, MSN, Google Talk (Jabber/XMPP), Facebook, Yahoo!, Salut, Gadu Gadu, Groupwise, ICQ and QQ.

  Homepage: http://live.gnome.org/Empathy

[1] https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/332371

Guillaume Desmottes (cassidy) wrote :

We just update the presentation of Empathy on http://live.gnome.org/Empathy:

"Empathy is a messaging program which supports text, voice, and video chat and file transfers over many different protocols. Empathy uses Telepathy for protocol support and has an user interface based on Gossip. Empathy is the default chat client in current versions of GNOME, making it easier for other GNOME applications to integrate collaboration functionality using Telepathy."

We now use this description on the bugzilla too so that could probably be used for the pkg description as well.

Sumana Harihareswara (sumanah) wrote :

mpt objected, originally, to mentions of Telepathy. How about:

Empathy is a chat program which supports text, voice, and video chat and file transfers via many different services, including: AIM, MSN, Google Talk (Jabber/XMPP), Facebook, Yahoo!, Salut, Gadu Gadu, Groupwise, ICQ and QQ. (Supported protocols depend on installed components.) You can tell it about your accounts on all those services and do all your chatting within one application.

  Homepage: http://live.gnome.org/Empathy

Laurent Bigonville (bigon) wrote :

Well the long description has already been changed on debian and ubuntu to:

 Instant messaging program supporting text, voice, video, file transfers
 and inter-application communication over many different protocols,
 including: AIM, MSN, Google Talk (Jabber/XMPP), Facebook, Yahoo!, Salut,
 Gadu-Gadu, Groupwise, ICQ and QQ.

Changed in empathy (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers