Use geoclue-2.0

Bug #1389336 reported by Michael Terry on 2014-11-04
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Low
Unassigned
gnome-settings-daemon (Ubuntu)
Medium
Unassigned
libunity-webapps (Ubuntu)
Medium
Unassigned
qtlocation-opensource-src (Debian)
Fix Released
Unknown
qtlocation-opensource-src (Ubuntu)
Medium
Timo Jyrinki
ubuntu-geoip (Ubuntu)
Medium
Unassigned
webkit2gtk (Ubuntu)
Medium
Unassigned
webkitgtk (Ubuntu)
Low
Unassigned

Bug Description

Geoclue2 (source package geoclue-2.0) is a separate, parallel-installable version of geoclue1 (source package geoclue). We will likely shortly have both in main (see MIR bug 1388294) and it would be great to be able to demote geoclue1 to universe and only support one version of the service.

The packages associated with this bug all have a reverse depends on geoclue1 in some form or patches to remove support for geoclue-2.0 because it wasn't in main yet (e.g. gnome-settings-daemon).

Porting from geoclue-1.0 to 2.0 apparently isn't terribly trivial. But we have at least six months to do it.

Sebastien Bacher (seb128) wrote :

Hey Michael, I though one of the issue is that the new version doesn't support plugins the same way, which means that if we port code we can't use our ubuntu geoip provider anymore. Did we decide it's fine to stop using that backend?

Tim Lunn (darkxst) wrote :

Seb, That is correct its no longer possible to provide custom providers, so it would either require teaching the ubuntu GeoIP server the Geolocate API or merging ubuntu-geoip directly into geoclue as a location source.

There was a one point a geoip client in geoclue-2.0 but it got dropped when GNOME switched to using Mozilla Location Service. It should be possible to do something similar for ubuntu-geoip support
http://cgit.freedesktop.org/geoclue/commit/?id=b6563179f55b44b9b566c11c8c4bc0870d50879f

Michael Terry (mterry) wrote :

Seb, this bug is about finding some solution for the geoclue-2.0 world, such as patching geoclue-2.0 directly or some such. I had assumed we didn't plan on staying with geoclue-1.0 forever?

Jackson Doak (noskcaj) on 2015-01-29
Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Released
Amr Ibrahim (amribrahim1987) wrote :

Any progress on this? It's better to finish all porting before 15.10 is released.

tags: added: wily
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Changed in libunity-webapps (Ubuntu):
status: New → Confirmed
Changed in qtlocation-opensource-src (Ubuntu):
status: New → Confirmed
Changed in ubuntu-geoip (Ubuntu):
status: New → Confirmed
Changed in webkitgtk (Ubuntu):
status: New → Confirmed
tags: added: xenial
Laurent Bigonville (bigon) wrote :

Empathy already supports geoclue 2.0 but there is a patch reverting this. Fixing this for empathy is as easy as dropping the patch and readding the (build)-dependencies

Changed in qtlocation-opensource-src (Debian):
status: Unknown → New
Changed in empathy (Ubuntu):
importance: Undecided → Medium
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → High
importance: High → Medium
Changed in empathy (Ubuntu):
importance: Medium → Low
Changed in libunity-webapps (Ubuntu):
importance: Undecided → Medium
Changed in qtlocation-opensource-src (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-geoip (Ubuntu):
importance: Undecided → Medium
Changed in webkitgtk (Ubuntu):
importance: Undecided → Low
Changed in qtlocation-opensource-src (Debian):
status: New → Fix Released
Amr Ibrahim (amribrahim1987) wrote :

What is the latest development for this?

geoclue-2.0 is now in main.

Changed in qtlocation-opensource-src (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 3.12.11-0ubuntu4

---------------
empathy (3.12.11-0ubuntu4) yakkety; urgency=medium

  * Drop Revert-geoclue-2.0.patch and switch to geoclue-2.0 (LP: #1389336)
  * Enable geoclue and map support now that empathy is in universe
  * Drop 47_git_activate_with_platform_data.patch,
    git_correct_display_messages.patch and git_no_nautilus_sendto.patch:
    This has been merged upstream some times ago.
  * Remove empathy-dbg package and rely on automatic dbgsym package

 -- Laurent Bigonville <email address hidden> Thu, 19 May 2016 18:29:12 +0200

Changed in empathy (Ubuntu):
status: Confirmed → Fix Released
Changed in webkit2gtk (Ubuntu):
importance: Undecided → Medium
Changed in webkit2gtk (Ubuntu):
status: New → In Progress
Robert Ancell (robert-ancell) wrote :

I've proposed a change to geoip.ubuntu.com to provide a Google/Mozilla Location Service compatible API. This means we can configure Geoclue 2.0 to use this service.

Then I propose we drop geoclue (1.0) and ubuntu-geoip from the archive.

Changed in webkit2gtk (Ubuntu):
status: In Progress → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

The switch in Qt will happen with Qt 5.6 that aims to land to yakkety before Feature Freeze in August.

Changed in qtlocation-opensource-src (Ubuntu):
status: Triaged → In Progress
Robert Ancell (robert-ancell) wrote :

You can switch to using the Ubuntu service in geoclue by seting:

[wifi]
url=http://geoip.ubuntu.com/v1/geolocate

in /etc/geoclue/geoclue.conf

Jeremy Bicha (jbicha) wrote :

webkitgtk built with geoclue 2 is in yakkety-proposed.

Changed in webkitgtk (Ubuntu):
status: Confirmed → Fix Committed
Robert Ancell (robert-ancell) wrote :

I had a look at what is required for libunity-webapps and it just appears to be using geoclue to work out what country you are in to show the appropriate Amazon store. Since Geoclue 2.0 doesn't provide this (it just gives a co-ordinate) the easiest solution is to make libunity-webapps contact http://geoip.ubuntu.com/lookup directly to get the country.

Changed in webkitgtk (Ubuntu):
status: Fix Committed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Humm, the qtlocation 5.6 did land to yakkety so marking this as fixed.

Changed in qtlocation-opensource-src (Ubuntu):
status: In Progress → Fix Released
Jeremy Bicha (jbicha) wrote :

libunity-webapps was removed from Ubuntu 17.10 so I'm closing that task.

The remaining bug here, ubuntu-geoip (a Recommends of indicator-datetime) is a problem. geoclue was removed from Debian 2 years ago. geoclue build-depends on libnm-glib-dev and libnm-util-dev which Debian is removing now. Maybe it's time to remove ubuntu-geoip.

Changed in libunity-webapps (Ubuntu):
status: Confirmed → Won't Fix
Jeremy Bicha (jbicha) wrote :

I filed LP: #1770674 for indicator-datetime's recommends on ubuntu-geoip.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.