Remove chat support from Windows Live provider

Bug #1301401 reported by Eduar Arley Cardona on 2014-04-02
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
empathy (Ubuntu)
Medium
Unassigned
gnome-online-accounts (Ubuntu)
Medium
Unassigned

Bug Description

From upstream bug report:

Microsoft has had been planning to drop Windows Live Messenger in favour of
Skype for quite some time now. See:
 - http://www.bbc.com/news/technology-20222998
 -
http://arstechnica.com/information-technology/2013/01/microsoft-messenger-service-not-going-anywhere-just-yet/

------------------------------------------------------------------------------------------

eduar@envy4:~$ lsb_release -rd
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04

eduar@envy4:~$ apt-cache policy empathy
empathy:
  Instalados: 3.8.6-0ubuntu7
  Candidato: 3.8.6-0ubuntu7
  Tabla de versión:
 *** 3.8.6-0ubuntu7 0
        500 http://co.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

eduar@envy4:~$ apt-cache policy telepathy-gabble
telepathy-gabble:
  Instalados: 0.18.2-1
  Candidato: 0.18.2-1
  Tabla de versión:
 *** 0.18.2-1 0
        500 http://co.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

Hello all. I'm trying to setup my Windows Live account (@outlook.com) in Empathy. It used to work OK on Ubuntu 12.04.4 64 bits. However, in 14.04 it doesn't works. When I add an account, it asks me for my username and password, I give it permissions to access my data, and the account is shown OK on the "Online accounts" window. However, when I go Online, Empathy shows a wheel in the middle, just turning around, but nothing else happens. After a while, it gives me a red error message "<email address hidden> Network error"

I have the debug in pastebin: http://pastebin.com/8vQdM4Pg

Thanks!

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: empathy 3.8.6-0ubuntu7
ProcVersionSignature: Ubuntu 3.13.0-21.43-generic 3.13.8
Uname: Linux 3.13.0-21-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Apr 2 08:41:58 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-03-30 (2 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
ProcEnviron:
 LANGUAGE=es_CO:es
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
SourcePackage: empathy
UpgradeStatus: No upgrade log present (probably fresh install)

Eduar Arley Cardona (eduar47) wrote :

Are you still seeing this issue in 14.04?

Changed in empathy (Ubuntu):
status: New → Incomplete
Eduar Arley Cardona (eduar47) wrote :

Hello Walter.

I've just reinstalled Ubuntu 14.04 final relase, and bug is still present. Empathy just shows a screen with a wheel going round, but nothing else.

Thanks!

Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Changed in empathy (Ubuntu):
status: Incomplete → New
Changed in empathy:
importance: Medium → Unknown
status: New → Unknown
Changed in empathy:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
shaneonabike (shanebill) wrote :

For me it connects to Hotmail and requires me to accept that Gnome access Hotmail. But after this has been done Hotmail cannot connect through Empathy. It continually reports a network error :/

Bruno Nova (brunonova) wrote :

Messenger also doesn't work for me in Empathy.
It works in Pidgin, though. So the servers are still working.

The linked "gnome bugs" bug is to "Remove chat support from Windows Live provider", so it's quite different from this one.

Bruno Nova (brunonova) wrote :

... And that bug was reported against gnome-online-accounts, not against Empathy.

summary: - Windows Live account doesn't login on Ubuntu 14.04 beta
+ Remove chat support from Windows Live provider
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-online-accounts (Ubuntu):
status: New → Confirmed

Seems to be an old bug.
Will it ever be fixed? I doubt it :-(

Changed in empathy (Ubuntu):
importance: Undecided → Medium
Changed in gnome-online-accounts (Ubuntu):
importance: Undecided → Medium
Bruno Nova (brunonova) wrote :

OK, it seems that the last MSN servers are finally being shutdown.
MSN stopped working for me in Pidgin today.

So I guess it's time to remove Windows Live from Pidgin, Empathy and Online Accounts.
Unless there's a way to make it work again (through Skype servers or something, but it's probably not possible and not worth the effort).

Bruno Nova (brunonova) wrote :

I think this bug is fixed now, at least for Ubuntu Online Accounts and Empathy.
Check Bug #1432613.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.