Ubuntu

empathy-accounts crashes on launch

Reported by Kane DAAAA on 2013-05-18
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
empathy (Debian)
Fix Released
Unknown
empathy (Ubuntu)
High
Unassigned

Bug Description

Bringing up the accounts windows just causes it to crash, no account management can be performed. There is a popup about "Ubuntu just stopped working..."

The title of the crash report is "empathy-accounts crashed with SIGABRT in raise()"

StacktraceTop has the offending line "raise() from /lib/x86_64-linux-gnu/libc.so.6"

Ubuntu release:
$ lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10

package version:
empathy:
  Installed: 3.6.0.3-0ubuntu1
  Candidate: 3.6.0.3-0ubuntu1
  Version table:
 *** 3.6.0.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

Expectation: the "Online Accounts" window would open normally, and allow me to create/remove accounts

Actual outcome: The window crashed as soon as it opened. Invoking 'empath-accounts' directly from the command line results in:
$ empathy-accounts
**
ERROR:empathy-user-info.c:252:fill_contact_info_grid: assertion failed: (spec != NULL)
Aborted (core dumped)

For some reason, my Google self vcard has an "url" field and gabble claims it is not supported (missing from SupportedFields property).

Ok, this is because gabble hardcodes the fields supported by google in gabble_vcard_manager_can_use_vcard_field() and now google decided to add 'url'.

There's a comment right above the condition which stops being true as of this patch.

Yep, fixed that and amended the commit, it's just a matter of cgit being slow to refresh... ;-)

Ship it.

In future, if you only have a single commit, linking to the commit (including its SHA1) will mean you don't have to worry about whether cgit still has old cached data.

ok merged in master.

Kane DAAAA (annonm) wrote :

I think this may have been a problem with Ubuntu itself, and not Empathy...

I just finished upgrading to 13.04, and now I'm able to manage accounts via Users > Online Accounts

Kane DAAAA (annonm) wrote :

Spoke too soon! The problem persists, and only happens when the Online Accounts window is opened from Empathy.

Malachi de AElfweald (malachid) wrote :

The other day, Google notified me that my password needed to be reset. I did so. Empathy couldn't connect, so I was going to change the password. I started having the same problem you are reporting on two different machines both running 13.04.

From the command line, I was able to launch empathy-accounts once and delete what I believed to be the offending account, but it still isn't working. Now I can't launch it from the command line either.

The only remaining account is one that has the 2-factor authentication turned on. Maybe that's where it's falling down? It used to work, but...

Malachi de AElfweald (malachid) wrote :

I rebooted and was able to launch empathy-accounts again. Both accounts were still there. I tried to delete what I thought was the offending account, and it crashed:
malachi@beast:~$ empathy-accounts

(empathy-accounts:2917): GLib-GObject-WARNING **: instance with invalid (NULL) class pointer

(empathy-accounts:2917): GLib-GObject-CRITICAL **: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
**
ERROR:empathy-user-info.c:252:fill_contact_info_grid: assertion failed: (spec != NULL)
Aborted (core dumped)

Now, I'm back into the situation of the original reporter again.

Malachi de AElfweald (malachid) wrote :

Went into the gnome-keyring UI and deleted all the Ubuntu Web Accounts.

malachi@beast:~/bin$ empathy-accounts
**
ERROR:empathy-user-info.c:252:fill_contact_info_grid: assertion failed: (spec != NULL)
Aborted (core dumped)

Does not appear to have made a different to Empathy.

Malachi de AElfweald (malachid) wrote :

malachi@beast:~$ sudo apt-cache policy empathy
empathy:
  Installed: 3.6.4-0ubuntu4
  Candidate: 3.6.4-0ubuntu4
  Version table:
 *** 3.6.4-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

Malachi de AElfweald (malachid) wrote :

Preferences - told it to not autostart on boot
Managed to click the "disable account" switch
rebooted
empathy-accounts

I clicked on the other entry (I was going to disable it too) and got the same error:
malachi@beast:~$ empathy-accounts
**
ERROR:empathy-user-info.c:252:fill_contact_info_grid: assertion failed: (spec != NULL)
Aborted (core dumped)

Malachi de AElfweald (malachid) wrote :

sudo apt-get purchase empathy
rm -rf ~/.config/Empathy
reboot
sudo apt-get install empathy
launch empathy
delete the two accounts still there

starting over. seems stable so far.

Malachi de AElfweald (malachid) wrote :

rebooted - everything is working fine now

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Miklos Juhasz (mjuhasz) wrote :

This is caused by Google adding support for the <URL> vCard
field, which telepathy-gabble doesn't think is supported or exists.

I attached the links to the freedesktop and debian bug.

This is fixed in telepathy itself by this commit: http://cgit.collabora.com/git/user/xclaesse/telepathy-gabble.git/commit/?id=57e62a7871be3209fca3046aaf99cdd055fef59d

Someone will have to backport this.

Changed in empathy (Debian):
status: Unknown → Fix Released
Changed in empathy:
importance: Unknown → Medium
status: Unknown → Fix Released

Today, it was doing the failing again. I saw the update here and apt-get upgraded. It's working again. I think that confirms the fix.

Ihor Kaharlichenko (madkinder) wrote :

Well, if it's working on 12.10 then it should be fixed in 12.04 as well, it is an LTS afterall...

aldobelus (aldobelus) wrote :

Forgiveness if awkward... does this mean that I have to add backports to my repositories? I have Trisquel (based on Ubuntu 12.04) and do not accept those things very well. Is it necessary to do this to fix the bug, please? Because I have updated like usually (safe-ugrade too) and continues the same situation...Thank you

Will it be fixed in 12.04 anytime? It affects me too -,-

Daniel Que (daniel2que) wrote :

This is still a problem for me as well. I tried updating with apt-get but got "empathy is already the newest version." Will this be fixed soon? Thanks.

Sebastien Bacher (seb128) wrote :
Changed in empathy (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.