empathy isn't activating indicator when a message is received

Bug #1177580 reported by Adar Dembo on 2013-05-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Undecided
Unassigned

Bug Description

The on message receipt notification behavior in empathy is semi-broken. Just how broken depends on whether I have an open chat window with the sender.

If the chat window is open:
1. I get a little notification bubble in the top-right corner containing the name of the sender and the message.
2. The tiny triangle to the left of the empathy icon on the dock switches color from white to blue.
3. The status icon in the entry for the sender in the empathy contact list rapidly switches state back and forth.

Missing from all this is the message envelope indicator thing in the top panel. It no longer turns blue, and the name of the sender no longer appears as an entry in the indicator's menu.

If there was no chat window (or I've since closed it), all I get is #3 from the above list. This has caused me to miss a number of messages.

This is a regression: empathy was not broken like this in 12.10. It's happened to me with both of my Google accounts; I haven't tested any other accounts with it.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: empathy 3.6.4-0ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-19.30-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Tue May 7 15:06:52 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-02-25 (70 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: empathy
UpgradeStatus: Upgraded to raring on 2013-05-06 (1 days ago)

Adar Dembo (adembo) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Adar Dembo (adembo) wrote :

After restarting my Ubuntu VM, notifications appear to be working properly. Well, at least I get a notification bubble, and a blue message envelope, though I'm not seeing the change in the dock's "tiny triangle" (item #2 from the list in the bug description).

I noticed that I had a 'telepathy-indicator' process running. When I killed it and asked someone to IM me, I got the behavior I described in the bug description. Then when I started it up again, notifications were working properly.

So perhaps telepathy-indicator was crashing?

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in empathy (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for empathy (Ubuntu) because there has been no activity for 60 days.]

Changed in empathy (Ubuntu):
status: Incomplete → Expired
CB (cbrchrt) wrote :

This is still happening to me in 14.04.3 LTS

Changed in empathy (Ubuntu):
status: Expired → New
CB (cbrchrt) on 2015-10-08
Changed in empathy (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers