Google Talk account in empathy refuses to sign in

Bug #1164939 reported by Tom Simnett on 2013-04-05
162
This bug affects 36 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Undecided
Unassigned

Bug Description

I've got 3 Google accounts in my online accounts. Empathy refuses to sign in with them citing "Google Talk account requires authorisation" for all three. However, on clicking the button that opens Online Accounts, nothing abnormal shows. Switching the account off, then back on has no impact. There is no option to reauth the accounts, which sometimes appears - when it does, I get the google login screen and then it works, usually until the next reboot.

http://pastebin.com/RNHDKfSx is the pastebin of the Auth log from empathy-debugger

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Mike (0x656b694d) wrote :

Try going to Google Account settings (https://accounts.google.com/b/0/IssuedAuthSubTokens) and revoking the access for any Ubuntu thing (I had 3 similar: twice Ubuntu and one Ubuntu desktop).
After reboot grant access to Google account via Online Accounts.
This worked for me.

I only have one per account I want to use (3 total accounts).

I would do this, but right now Online Accounts refuses to load up and dumps its core, which puts me in a worse position than I'm already in.

Also, accounts intermittently sign in (right now two of the accounts - I'm not sure which because OA won't open - won't sign in, and the other has), so this seems to me to be something else. Is the fact that I have more than one Google account in OA causing problems?

Andrea Pivetta (vanpivix) wrote :

#2 this worked for me too. Thanks

Jon Wilson (j85wilson) wrote :

About every two weeks, both of my google accounts are no longer signed into Empathy, and Empathy presents the usual message "Google Talk account requires authorisation" along with a button that opens the online accounts settings manager. Neither of the Google accounts provides any way to grant authorisation. The only thing I've found that works is to delete the account and create a new Google account to replace it. That account will then function properly for about two weeks, at which point the cycle begins again.

This has been going on for ages. This bug report has been open for 10 months with no apparent progress towards a fix. Please fix it.

Felix Haller (felixhaller) wrote :

@ubuntudevelopers: Why are you introducing new features (e.g. "Online Sources") and switch over all the services (Empathy, worked fine before) and once a bug (like this) appears, it is ignored?
Innovation is fine and desirable, but latest Ubuntu versions (even trusty - a LTS!) are some kind of patchwork. There are several bugs that need to be fixed or (more important) features that have to be considered for reverting.

I am now using pidgin, because I can't get empathy going. There is NO chance.

And that's what I'm talking about. Bugs like these are real blockers!

Think about that: Who will buy an Ubuntu phone if Ubuntu is a name that is connected to a buggy desktop system?

Christoph Buchner (bilderbuchi) wrote :

After upgrading to 14.04, I also started experiencing this problem (no way to grant authorization). It worked fine before that, on 13.10.
Maybe this should be reported against the online-accounts package?

Phasmus (phasmus) wrote :
Austin (afuori) wrote :

#2 worked for me, thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers