[raring] History dialog does not decode UTF-8 (displays за symbols)

Bug #1103394 reported by Roman Yepishev
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
High
empathy (Fedora)
Fix Released
Undecided
empathy (Ubuntu)
Low
Unassigned

Bug Description

STR:

1. Send e.g. "Привет" ("Hello" in Russian)
2. Open Previous conversations

Expected results:
Last entry will be "Привет"

Actual results:
The last entry is "Привет" - UTF-8 bytes as if the encoding was latin1

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: empathy 3.6.3-0ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-1.5-generic 3.8.0-rc4
Uname: Linux 3.8.0-1-generic x86_64
ApportVersion: 2.8-0ubuntu2
Architecture: amd64
Date: Wed Jan 23 11:54:54 2013
InstallationDate: Installed on 2013-01-04 (18 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130104)
MarkForUpload: True
SourcePackage: empathy
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Roman Yepishev (rye) wrote :
Revision history for this message
Bilal Shahid (s9iper1) wrote :

thanks for taking time in filing the bug to make ubuntu better
can you reproduce it ?
please attach the screenshot of the bug ?

Changed in empathy (Ubuntu):
status: New → Incomplete
Revision history for this message
Roman Yepishev (rye) wrote :

Hi, sure, here's the screenshot of such history entries (selected the least worded conversation though).

Changed in empathy (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → New
Revision history for this message
Bilal Shahid (s9iper1) wrote :

found a bug in upstream attaching it.

Changed in empathy (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Changed in empathy:
importance: Medium → High
status: New → Confirmed
Revision history for this message
In , Igor (igor-redhat-bugs) wrote :

Description of problem:
history uses wrong encoding to show utf8 logs.

Version-Release number of selected component (if applicable):
since 3.6.3
empathy-3.8.1-2.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Send e.g. "Привет" ("Hello" in Russian)
2. Open Previous conversations

Actual results:
The last entry is "Привет"

Expected results:
Last entry will be "Привет"

Additional info:
I have checked that my logs in ~/.local/share/TpLogger/ are in utf8. Then I
downgrade empathy up to 3.6.2 and restart gnome-session. This is fixed my
problem. I have checked several times and can confirm that with empathy 3.6.2
the bug is not reproducible, but reproducible since 3.6.3.

The problem here is that g_strescape changed its specifications over time -
from the UTF-8-compatible "double every backslash" to ASCII-only "escape
everything except 0x20 through 0x7E". Would it be right to invent a new
backslash-doubling function for empathy-log-window.c specifically? Not pretty,
but passing a 128-character exception string to g_strescape is even less so.

This commit created this bug: https://git.gnome.org/browse/empathy/commit/?h=gnome-3-6&id=1e7449f5a14e2f031389808206c9991f65d3ade7

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

empathy-3.8.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/empathy-3.8.3-1.fc19

Changed in empathy:
status: Confirmed → Fix Released
Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

Package empathy-3.8.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing empathy-3.8.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9093/empathy-3.8.3-1.fc19
then log in and leave karma (feedback).

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

empathy-3.8.3-1.fc19 has been pushed to the Fedora 19 stable repository. If problems still persist, please make note of it in this bug report.

Revision history for this message
In , Igor (igor-redhat-bugs) wrote :

Add patch as downstream (there will be no new releases in 3.8 branch)
https://git.gnome.org/browse/empathy/commit/?id=6bace22f3ffb9695870267e2a59858b3feeaa83e

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

empathy-3.8.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/empathy-3.8.3-2.fc19

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

Package empathy-3.8.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing empathy-3.8.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14109/empathy-3.8.3-2.fc19
then log in and leave karma (feedback).

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

empathy-3.8.3-2.fc19 has been pushed to the Fedora 19 stable repository. If problems still persist, please make note of it in this bug report.

Revision history for this message
Leonid Evdokimov (darkk) wrote :

What package fixes the issue?
I still observe the bug in the logs and I have folowing '*pathy*' packages installed

$ dpkg -l | grep pathy | grep ^ii | awk '{printf "%s=%s ", $2, $3}'
empathy=3.6.4-0ubuntu4.1 empathy-common=3.6.4-0ubuntu4.1 libfolks-telepathy22=0.4.2-0ubuntu1 libfolks-telepathy25=0.8.0-1 libmission-control-plugins0=1:5.14.0-0ubuntu2 libtelepathy-farstream3:amd64=0.6.0-1 libtelepathy-glib0:amd64=0.20.2-0ubuntu1 libtelepathy-logger3:amd64=0.8.0-0ubuntu1 nautilus-sendto-empathy=3.6.4-0ubuntu4.1 python-telepathy=0.15.19-2.1build1 telepathy-gabble=0.16.5-0ubuntu1.1 telepathy-haze=0.6.0-1 telepathy-idle=0.1.14-1ubuntu0.1 telepathy-indicator=0.3.1daily13.03.01-0ubuntu1 telepathy-logger=0.8.0-0ubuntu1 telepathy-mission-control-5=1:5.14.0-0ubuntu2 telepathy-rakia=0.7.4-1ubuntu1 telepathy-salut=0.8.1-1 telepathy-sofiasip=0.7.4-1ubuntu1

Revision history for this message
Oleg "Nightwing" Lomakin (nightwing666) wrote :

Bug still here. Please backport fix!

Changed in empathy (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.