Empathy doesn't detect online accounts

Bug #1083497 reported by Romuald on 2012-11-27
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Undecided
Unassigned

Bug Description

My professionnal PC was first installed with Ubuntu 12.04 64. Then, I setup the system to connect my active directory server. Done.

In this configuration, I've had some issues with Empathy, each time I rebooted the PC, I had to setup all my IM account (Google & MSN). It was boring, but it worked.

Some days ago, I upgraded the PC to 12.10. The upgrade worked smoothly, and didn't degrade the AD integration.

I entered my online accounts in the dedicated applet. But now, Empathy doesn't work at all. The Empathy window shows "You need to setup an account to see contacts here" with the "Account settings" button.

If I click this button, I see all the accounts I previously setup. For each IM account, beside the account Empathy section, I see an "Options" button, if I click it, I get an empty window with just 2 buttons "Cancel" & "Done".

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: empathy 3.6.0.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Tue Nov 27 10:40:57 2012
InstallationDate: Installed on 2012-07-02 (147 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: empathy
UpgradeStatus: Upgraded to quantal on 2012-11-20 (6 days ago)

Romuald (romu70) wrote :
Bilal Shahid (s9iper1) wrote :

thanks for the bug report
please attach the empathy debugger log file ?

Changed in empathy (Ubuntu):
status: New → Incomplete
Romuald (romu70) wrote :

Hi Bilal,
Where can I find this file?

Bilal Shahid (s9iper1) wrote :

in terminal run this command you will get the debugger window get it from there
"empathy-debugger"

Romuald (romu70) wrote :

Ok, I run "empathy-debugger" and then run empathy. Played a bit with Online Accounts applet and finally closed Empathy.
Here is the log file.

Bilal Shahid (s9iper1) wrote :

is that the full debug log ?
i dont see any thing which is not working or causing that bug ?

Romuald (romu70) wrote :

I guess, the empathy-debugger switch was on "All", and I post the full log. As I wrote, I get absolutely no error from Empathy, everything is fine...except it doesn't detec the online accounts.

Romuald (romu70) wrote :

I think this was first cause with 12.04 as I had to re-create empathy accounts each time I restarted it. And it was the same, no error at all, just the accounts were not present. Now Empathy relies on the Online Accounts applet, the situation is worse as I can't use the application at all.

Launchpad Janitor (janitor) wrote :

[Expired for empathy (Ubuntu) because there has been no activity for 60 days.]

Changed in empathy (Ubuntu):
status: Incomplete → Expired
Romuald (romu70) wrote :

I understand it's difficult to help as there is no error found by Empathy, but it still doesn't detect any online accounts, and I have to work with Pidgin.

Bilal Shahid (s9iper1) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1029289, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Changed in empathy (Ubuntu):
status: Expired → Invalid
Romuald (romu70) wrote :

I'm sorry Bilal, but no, this is not the same bug. I'm also facing the bug 1029289 on my personal computer.

But on my professionnal PC, this is not the same problem at all. Here, Empathy just doesn't see any online account, please, read again the description.

Bilal Shahid (s9iper1) wrote :

for this situation you need to install 12.10 again. most of the time something got missed with this type of upgrade.
firstly remove empathy and than reboot and reinstall it see if it works. else u ned to fresh install it i am marking it as incomplete.

Changed in empathy (Ubuntu):
status: Invalid → Incomplete
Romuald (romu70) wrote :

I made some additionnal testing. First I removed Empathy by running "sudo apt-get purge empathy*", then, I removed all hidden folder called "empathy" in my home, and I restarted the PC.

Reinstalled Empathy with the software center, run it, reconfigured the online accounts and the result is the same, empathy doesn't see anything.

I attached the debugger output and the terminal Empathy trace. What is interesting is the last debugger message:
"empathyDispatcher-DEBUG: 02/04/2013 09:02:57.321650: empathy_status_icon_new: Not started with session, showing contact list" which shows, I guess, that Empathy doesn't work with an Active Directory session.

Romuald (romu70) wrote :

The Empathy output.

Romuald (romu70) wrote :

Last test: on the same PC, I started a local session (not an Active Directory one), and the problem remains the same.

Launchpad Janitor (janitor) wrote :

[Expired for empathy (Ubuntu) because there has been no activity for 60 days.]

Changed in empathy (Ubuntu):
status: Incomplete → Expired
Evan Langlois (uudruid74) wrote :

I have the same problem! A whole year later

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers