can't connect to google apps gchat account "account requires authorisation"

Bug #1064113 reported by Joe Barnett on 2012-10-08
104
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Empathy
New
Medium
empathy (Ubuntu)
Low
Unassigned
gnome-control-center-signon (Ubuntu)
Undecided
Unassigned

Bug Description

I have a google apps gtalk jabber account configured in empathy that refuses to connect after upgrading to quantal. Error message "account requires authorisation" appears in the contact list.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: empathy 3.6.0.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
Date: Mon Oct 8 16:02:38 2012
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: empathy
UpgradeStatus: Upgraded to quantal on 2012-10-05 (3 days ago)

Joe Barnett (thejoe) wrote :
Bilal Shahid (s9iper1) wrote :

thanks for the bug report
can you reproduce it ?
please attach the empathy log file with the bug report ?
you can get the empathy debugger while typing empathy-debugger in terminal

Changed in empathy (Ubuntu):
status: New → Incomplete
Joe Barnett (thejoe) wrote :

yes i can reproduce it.

logs at http://pastebin.com/J7WdFUhk

Joe Barnett (thejoe) wrote :

hmm, send to pastebin look incomplete, here is full log:

http://pastebin.com/a9DdS4Pn

Joe Barnett (thejoe) on 2012-10-09
Changed in empathy (Ubuntu):
status: Incomplete → Opinion
status: Opinion → New
Bilal Shahid (s9iper1) wrote :

ok here is a problem i am sending your bug to upstream please subscribe to that bug

Changed in empathy (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Joe Barnett (thejoe) wrote :

I'm thinking this is related to ubuntu-online-accounts, which I can't get to authenticate to my google apps account. If i try to add through control center -> ubuntu online accounts, i get "An error occured while loading the authentication page" but can't figure out more details. what package provieds the ubuntu online accounts control panel? should i link it to this bug?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center-signon (Ubuntu):
status: New → Confirmed

this is very annoying. Ubuntu's patched Empathy tries to outsmart the user by wanting to do Google auth, but that fails for some reason:

session_process_cb: Error processing the session: GDBus.Error:com.google.code.AccountsSSO.SingleSignOn.Error.UserInteraction: userActionFinished error: 10
g_variant_unref: assertion `value != NULL' failed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.