Ubuntu

empathy crashed with SIGSEGV in _tpf_persona_contact_weak_notify_cb()

Reported by Martin Pitt on 2012-07-13
140
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Critical
empathy (Ubuntu)
Medium
Unassigned

Bug Description

I did not do anything with the empathy client at the time of the crash.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: empathy 3.5.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-4.4-generic 3.5.0-rc6
Uname: Linux 3.5.0-4-generic x86_64
ApportVersion: 2.3-0ubuntu4
Architecture: amd64
Date: Fri Jul 13 07:49:11 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120627)
ProcCmdline: empathy
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f5974432c6c: movq $0x0,0x88(%rax)
 PC (0x7f5974432c6c) ok
 source "$0x0" ok
 destination "0x88(%rax)" (0xaaaaaaaaaaaaab32) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: empathy
StacktraceTop:
 ?? () from /usr/lib/libfolks-telepathy.so.25
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_unref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_ptr_array_foreach () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: empathy crashed with SIGSEGV in g_object_unref()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Martin Pitt (pitti) wrote :

StacktraceTop:
 _tpf_persona_contact_weak_notify_cb (obj=<optimized out>, self=0x1708480) at tpf-persona.c:1736
 __tpf_persona_contact_weak_notify_cb_gweak_notify (self=0x1708480, object=<optimized out>) at tpf-persona.c:526
 weak_refs_notify (data=0x1446bb0) at /build/buildd/glib2.0-2.33.3/./gobject/gobject.c:2469
 g_object_unref (_object=0x13e3630) at /build/buildd/glib2.0-2.33.3/./gobject/gobject.c:2986
 g_ptr_array_foreach (array=array@entry=0x17a83a0, func=0x439850 <g_object_unref@plt>, user_data=user_data@entry=0x0) at /build/buildd/glib2.0-2.33.3/./glib/garray.c:1434

Changed in empathy (Ubuntu):
importance: Undecided → Medium
summary: - empathy crashed with SIGSEGV in g_object_unref()
+ empathy crashed with SIGSEGV in _tpf_persona_contact_weak_notify_cb()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Bilal Shahid (s9iper1) on 2012-07-23
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Changed in empathy:
importance: Unknown → Critical
status: Unknown → Incomplete
tags: added: bugpattern-needed
Changed in empathy:
status: Incomplete → Confirmed
Changed in empathy:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.