[FFe] Please upload emesene 2.0 (git)

Bug #728469 reported by Devid Antonio Filoni on 2011-03-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
emesene (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: emesene

This is a Feature Freeze exception request to upload emesene 2.0 (not-yet-released). emesene 1.6 is not maintained anymore by upstream and it has a lot of bugs. emesene 2.0 is not based on old emesene code and uses papyon as MSNP library so possible bugs in MSN can be fixed fixing only papyon (you already know how many SRUs due to MSN changes are done in each release), it supports python-xmpp and it's better integrated in Ubuntu. As said by upstream emesene 2.0 is also more stable than emesene 1.6 although some emesene 1.6 features are still missing in 2.0. Upstream would like this version in natty in order to avoid reports on unmaintained 1.6 version and to proper start 2.0 period.

-------------------- INSTALL LOG (ITALIAN): --------------------
dfiloni@dfiloni-N82JQ:~$ sudo dpkg -i emesene_2.0~git20110303-0ubuntu1_all.deb
Selezionato il pacchetto emesene.
(Lettura del database... 128791 file e directory attualmente installati.)
Estrazione di emesene (da emesene_2.0~git20110303-0ubuntu1_all.deb)...
Configurazione di emesene (2.0~git20110303-0ubuntu1)...
Elaborazione dei trigger per man-db...
Elaborazione dei trigger per hicolor-icon-theme...
Elaborazione dei trigger per bamfdaemon...
Rebuilding /usr/share/applications/bamf.index...
Elaborazione dei trigger per desktop-file-utils...
Elaborazione dei trigger per python-gmenu...
Rebuilding /usr/share/applications/desktop.it_IT.utf8.cache...
Elaborazione dei trigger per python-support...
dfiloni@dfiloni-N82JQ:~$

-------------------- BUILD LOG: --------------------
attached

-------------------- GIT REPOSITORY (changes list): --------------------
https://github.com/emesene/emesene/commits/master

-------------------- SCREENSHOT: --------------------
attached

-------------------- DEBIAN CHANGELOG: --------------------
emesene (2.0~git20110303-0ubuntu1) natty; urgency=low

  * New upstream git revision.
  * Remove debian/watch, debian/emesene.xpm, debian/install and
    debian/README.source files.
  * Remove 21_svn2451_fix_avatar and 20_dont_build_own_libmimic patches.
  * debian/control: modify python to python (>= 2.5) in Build-Depends field.
  * debian/control: remove python-libmimic from Recommends field.
  * debian/control: modify python-gtk2 (>= 2.10) to python-gtk2 (>= 2.12) in
    Depends field.
  * debian/control: add python-appindicator and python-xmpp to Recommends
    field.
  * debian/control: add python-papyon (>= 0.5.4) and python-webkit to Depends
    field.
  * debian/control: update Description field.
  * debian/control: add python-setuptools to Build-Depends field.
  * debian/control: move python-dbus and python-notify to Depends field.
  * Update debian/copyright file.
  * Update debian/links file.
  * debian/menu: update description field.
  * Bump Standards-Version to 3.9.1.

 -- Devid Antonio Filoni <email address hidden> Thu, 03 Mar 2011 14:49:13 +0100

Related branches

Devid Antonio Filoni (d.filoni) wrote :
Devid Antonio Filoni (d.filoni) wrote :
Devid Antonio Filoni (d.filoni) wrote :

Attaching also the built Debian package (natty).

Riccardo 'c10ud' (c10ud) wrote :

Hello

i am the current mantainer of emesene and i fully support Devid. We worked together in order to make a Debian/Ubuntu package available for the next cycle of both distros. emesene version 1 is unmantained, with a self-poorly-written library and all the culprits of 5 years of wild development.

emesene-2 is a fresh start. it's not complete, it has its bugs but it's surely a better start for the future. we don't get lots of contributions mostly because potential devs are fine with the bugged 1.6-x serie. We want to invert that trend providing a solid base where developers can get easily into. Here's why the tight ubuntu-integration and the use of external libraries for protocols.

Since the package will be in universe (and natty is certainly not a LTS) i don't think it will be a problem shipping an "unstable" version for everyone to test out and improve.

Regards
Riccardo (c10ud)

Scott Kitterman (kitterman) wrote :

Seems reasonable. Please go ahead.

Changed in emesene (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package emesene - 2.0~git20110303-0ubuntu1

---------------
emesene (2.0~git20110303-0ubuntu1) natty; urgency=low

  * New upstream git revision (LP: #728469).
  * Remove debian/watch, debian/emesene.xpm, debian/install and
    debian/README.source files.
  * Remove 21_svn2451_fix_avatar and 20_dont_build_own_libmimic patches.
  * debian/control: modify python to python (>= 2.5) in Build-Depends field.
  * debian/control: remove python-libmimic from Recommends field.
  * debian/control: modify python-gtk2 (>= 2.10) to python-gtk2 (>= 2.12) in
    Depends field.
  * debian/control: add python-appindicator and python-xmpp to Recommends
    field.
  * debian/control: add python-papyon (>= 0.5.4) and python-webkit to Depends
    field.
  * debian/control: update Description field.
  * debian/control: add python-setuptools to Build-Depends field.
  * debian/control: move python-dbus and python-notify to Depends field.
  * Update debian/copyright file.
  * Update debian/links file.
  * debian/menu: update description field.
  * Bump Standards-Version to 3.9.1.
 -- Devid Antonio Filoni <email address hidden> Thu, 03 Mar 2011 14:49:13 +0100

Changed in emesene (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers