emesene crashed with SIGSEGV in tupledealloc.24592()

Bug #1050358 reported by Stefano Pisano on 2012-09-13
210
This bug affects 42 people
Affects Status Importance Assigned to Milestone
emesene (Ubuntu)
Critical
eduardo
pygobject (Ubuntu)
High
roopa
pygobject-2 (Ubuntu)
High
eduardo

Bug Description

When I try to connect to my msn account emesene crash

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: emesene 2.12.5+dfsg-1ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-14.16-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
CrashCounter: 1
Date: Thu Sep 13 13:12:08 2012
ExecutablePath: /usr/share/emesene/emesene/emesene
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: python /usr/bin/emesene -s
SegvAnalysis:
 Segfault happened at: 0x4b6058: mov 0x98(%r13),%eax
 PC (0x004b6058) ok
 source "0x98(%r13)" (0x00000098) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: emesene
StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /usr/lib/python2.7/dist-packages/glib/_glib.so
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: emesene crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: Upgraded to quantal on 2012-04-26 (139 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Stefano Pisano (s-pisano91) wrote :

StacktraceTop:
 tupledealloc.24592 (op=0x41f8950) at ../Objects/tupleobject.c:218
 func_dealloc.15338 (op=0x3dd5ed8) at ../Objects/funcobject.c:461
 pyg_iowatch_data_free (data=0x3ee9120) at /build/buildd/pygobject-2-2.28.6/glib/pygiochannel.c:409
 g_source_callback_unref (cb_data=0x3f6c370) at /build/buildd/glib2.0-2.33.12/./glib/gmain.c:1457
 g_source_callback_unref (cb_data=0x3f6c370) at /build/buildd/glib2.0-2.33.12/./glib/gmain.c:1449

Changed in emesene (Ubuntu):
importance: Undecided → Medium
summary: - emesene crashed with SIGSEGV in g_main_context_dispatch()
+ emesene crashed with SIGSEGV in tupledealloc.24592()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in emesene (Ubuntu):
status: New → Confirmed
Sven Baars (sbte) on 2012-10-13
visibility: private → public
Sven Baars (sbte) on 2012-10-13
Changed in pygobject (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Martin Pitt (pitti) wrote :

This uses the old static (and unmaintained) pygobject bindings, reassigning.

affects: pygobject (Ubuntu) → pygobject-2 (Ubuntu)
Changed in pygobject-2 (Ubuntu):
importance: Critical → High
Sven Baars (sbte) wrote :

Martin, it also seems to happen when I start emesene in Gtk3 mode.

Sven Baars (sbte) wrote :

Here's a backtrace of that happening:

#0 0x00000000004b5c78 in tupledealloc.24592 (op=0x29ed690)
    at ../Objects/tupleobject.c:218
#1 0x000000000048a56a in func_dealloc.15338 (op=0x29ec6e0)
    at ../Objects/funcobject.c:461
#2 0x00007ffff498b0fa in pyg_iowatch_data_free (data=0x2b9fe00)
    at /build/buildd/pygobject-3.4.0/gi/_glib/pygiochannel.c:411
#3 0x00007ffff5dc1108 in g_source_callback_unref (cb_data=0x2b62e50)
    at /build/buildd/glib2.0-2.34.0/./glib/gmain.c:1457
#4 g_source_callback_unref (cb_data=0x2b62e50)
    at /build/buildd/glib2.0-2.34.0/./glib/gmain.c:1449

Sven Baars (sbte) on 2012-10-15
Changed in pygobject (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in emesene (Ubuntu):
importance: Medium → Critical

ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
DistroRelease: Ubuntu 12.10
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
Package: pygobject-2
PackageArchitecture: all
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Tags: quantal running-unity
Uname: Linux 3.5.0-17-generic i686
UpgradeStatus: Upgraded to quantal on 2012-10-20 (2 days ago)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo

tags: added: apport-collected

apport information

apport information

Gustavo A. Díaz (gdiaz) wrote :

This is also affecting me. Upgraded today Kubuntu 12.10.

Also affecting me, but in the form of bug #1051490 (SIGSEGV in g_main_context_dispatch())

Stephen Cradock (s-cradock) wrote :

I reported a related crash in bug#1069163. Checking today I find the same behavior reported there; no mention of tupledealloc in the stacktrace.

What is new is a stacktrace reported when I start emesene from a terminal, which I didn't see before it crashed originally. Now it says:

~$ emesene
Exception in thread Thread-3:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
    self.run()
  File "/usr/share/emesene/emesene/e3/base/Logger.py", line 881, in run
    self.logger = Logger(self.path, self.db_name)
  File "/usr/share/emesene/emesene/e3/base/Logger.py", line 363, in __init__
    self._load_events()
  File "/usr/share/emesene/emesene/e3/base/Logger.py", line 395, in _load_events
    self.execute(Logger.SELECT_EVENTS)
  File "/usr/share/emesene/emesene/e3/base/Logger.py", line 597, in execute
    self.cursor.execute(query, args)
OperationalError: no such table: d_event

Segmentation fault (core dumped)

Hope that helps, if only to establish that the two reports are or are not related!

Tiago Neiva (tneiva) wrote :

this bug is being tracked here: https://github.com/emesene/emesene/issues/1537

tags: added: raring

Since this bug:

- Is valid.
- Is well described.
- Is reported in the upstream project.
- Is ready to be worked on by a developer.

It's already triaged.

Changed in emesene (Ubuntu):
status: Confirmed → Triaged
Changed in pygobject-2 (Ubuntu):
status: Confirmed → Triaged
Changed in pygobject (Ubuntu):
status: Confirmed → Triaged
eduardo (lalo7america) on 2014-02-10
Changed in emesene (Ubuntu):
assignee: nobody → eduardo (lalo7america)
Changed in pygobject-2 (Ubuntu):
assignee: nobody → eduardo (lalo7america)
Anders (eddiedog988) on 2014-03-13
Changed in emesene (Ubuntu):
status: Triaged → Confirmed
Changed in pygobject-2 (Ubuntu):
status: Triaged → Confirmed
Changed in pygobject (Ubuntu):
status: Triaged → Confirmed
assignee: nobody → Anders (eddiedog988)
Martin Pitt (pitti) on 2014-03-13
Changed in emesene (Ubuntu):
status: Confirmed → Triaged
Changed in pygobject-2 (Ubuntu):
status: Confirmed → Triaged
Changed in pygobject (Ubuntu):
status: Confirmed → Triaged
assignee: Anders (eddiedog988) → nobody
roopa (roopat85) on 2017-04-25
Changed in pygobject (Ubuntu):
assignee: nobody → roopa (roopat85)
Christoph Reiter (lazka) wrote :

This crash seems to be limited to Ubuntu 12.10 and 13.04 (looking at the duplicates and the linked upstream bug report). And that's no longer supported.

Also the affected program is unmaintained for some years now.

Changed in pygobject (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers