[natty, SRU] emerald segfault on launch

Bug #733393 reported by drink on 2011-03-11
234
This bug affects 50 people
Affects Status Importance Assigned to Milestone
emerald (Ubuntu)
High
Unassigned
Natty
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Binary package hint: emerald

here is the end of an strace

poll([{fd=3, events=POLLIN}], 1, -1) = 1 ([{fd=3, revents=POLLIN}])
read(3, "\1\0\230\2\0\0\0\0\246\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 4096) = 32
read(3, 0xb7dfc4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
read(3, 0xb7dfc4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\20\0\t\0\33\0`\3_COMPIZ_WINDOW_DECOR_ACT"..., 36}, {NULL, 0}, {"", 0}], 3) = 36
poll([{fd=3, events=POLLIN}], 1, -1) = 1 ([{fd=3, revents=POLLIN}])
read(3, "\1\0\231\2\0\0\0\0\247\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 4096) = 32
read(3, 0xb7dfc4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
read(3, 0xb7dfc4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV (core dumped) +++
Segmentation fault (core dumped)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: emerald 0.7.2-0ubuntu6
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Mar 11 09:09:40 2011
ProcEnviron:
 LANGUAGE=C:en
 LANG=C
 SHELL=/bin/bash
SourcePackage: emerald
UpgradeStatus: No upgrade log present (probably fresh install)

TEST CASE:
- Run under Compiz as the window manager.
- Install emerald.
- From the console, type emerald --replace. The result will be a segmentation fault.

Revision history for this message
drink (martin-espinoza) wrote :
Revision history for this message
BigK (ocau) wrote :

Running Kubuntu, it also affects me when doing 'emerald --replace'

Revision history for this message
Pete Dunipace (peted) wrote :

This bug affects me too. Any solutions?

Revision history for this message
Jmadero (jmadero) wrote :

This is a unity problem, not sure if they plan on fixing it or not. Not sure if there's enough of a demand

Revision history for this message
Ubi Newbie (85-suraj) wrote :

I am facing the same problem...Really wanted to try the cool emerald themes :(...can ny1 suggest an alternative? R compiz themes just as good?

Revision history for this message
s0undt3ch (ufs) wrote :

I'm on kubuntu, so, not using unity, so, this shouldn't be a unity problem.

Revision history for this message
s0undt3ch (ufs) wrote :

Here's my strace output. Need to get this fixed fast...

Revision history for this message
Sasquatch (sasquatch) wrote :

Final release has the same problem. It is NOT a unity issue, because XUbuntu does not have Unity (and I certainly didn't install it when upgrading from 10.10). This error prevents me from using Compiz, because on Xfce, you either have your own Window Decorator like Emerald if you use Compiz, or it uses it's own when using xfwm4.
I think I'll grab and install the Maverick version of Emerald to see if that fixes things.

Revision history for this message
Sasquatch (sasquatch) wrote :

Of course, the Maverick version doesn't change a thing because they're the exact same build :(.

Revision history for this message
Sasquatch (sasquatch) wrote :

Found this as possible solution, which is updating Emerald with the latest version from upstream:
http://demonic.cc/?p=50

Revision history for this message
TragicWarrior (bryan-christ) wrote :

I have run into this problem too. I'm a little hesitant to recompile emerald. Is there package or ppa where I can fetch a newer version from?

Revision history for this message
Sasquatch (sasquatch) wrote :

I really wonder why Canonical provide such an old version of Emerald with Ubuntu. Version 0.7.2 was released in 2009, 2 years ago. Just recently, there was version 0.8.8 released. How come they update only some software and keep the rest out-dated which cause problems like these? They have only two minor builds of Emerald since Hardy, which is IMO more like a compile against newer libraries Emerald depends on.

Please Canonical, update Emerald from upstream to fix this problem.

Revision history for this message
drink (martin-espinoza) wrote : Re: [Bug 733393] Re: emerald segfault on launch

If you want emerald updated even though Canonical doesn't care, you can
download the old package, download the new source, work on making a new
package, and upload it to a PPA which Canonical will give you for free. I
did this to Micropolis and shortly thereafter it appeared in the repos as if
by coincidence. I propose that you do the same instead of complaining.

Revision history for this message
Sasquatch (sasquatch) wrote : Re: emerald segfault on launch

I'm no package maintainer, nor a developer. It would take me 100 times more time to learn how to create packages and add them to a ppa than for the current maintainer to get the latest upstream version and build that.
I know this is the strength of open source, but you can't ask every single user to know how to build packages and such.

Revision history for this message
Sasquatch (sasquatch) wrote :

I found a pre-compiled version of Emerald for Debian SID. Version 0.8.4. Here is the 64 bit version:
http://frickelplatz.de/debian/dists/sid/main/binary-amd64/x11/
This is the 32 bit one:
http://frickelplatz.de/debian/dists/sid/main/binary-i386/x11/

Don't forget the libraries in the libs folder. Unfortunately, this one also segfaults. Seems like we really need 0.8.8. Still looking for it.

Revision history for this message
Sasquatch (sasquatch) wrote :

I want to give David Foerster a big thanks for his PPA. You helped out a lot. Here is his PPA:
https://launchpad.net/~malteworld/+archive/compiz

Revision history for this message
TragicWarrior (bryan-christ) wrote :

I agree. Thank you David!

Revision history for this message
Zach Morgan (oldirty84) wrote :

This is confirmed working in XUbuntu 11.04 x64 as of May 5.
Many thanks, David.

Revision history for this message
drink (martin-espinoza) wrote : Re: [Bug 733393] Re: emerald segfault on launch

Tried it on my natty x64 yesterday and emerald works but my unity menu bar
disappeared.

Revision history for this message
TragicWarrior (bryan-christ) wrote : Re: emerald segfault on launch

Confirmed working on Lubuntu 64-bit.

Revision history for this message
Alejandro Mery (amery) wrote :

Hi, as for others default emerald was segfaulting on by xubuntu 11.04/64, now usig malteworld's PPA runs. BUT after "alt-tab"ing the windows don't react until I minimize and open again. anyone else experiencing the same? should I file a bug against the ppa??

Revision history for this message
Sasquatch (sasquatch) wrote :

Alejandro,
That's a separate bug, not caused by Emerald. There are other issues where windows don't respond when they have been minimized. You have to shade them to the titlebar and restore them to fix window mapping for it.
See https://bugs.launchpad.net/ubuntu/+source/unity/+bug/754065 for it. Might be related to what you have.

Revision history for this message
Maia Everett (linneris) wrote :

I'll see about uploading 0.8.8 to Oneiric, and if it works, backporting it to Natty.

Changed in emerald (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in emerald (Ubuntu Natty):
status: New → Triaged
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package emerald - 0.8.8-0ubuntu1

---------------
emerald (0.8.8-0ubuntu1) oneiric; urgency=low

  * New upstream release. (LP: #442479)
    - Fixes segfault on start. (LP: #733393)
  * Migrate to 3.0 (quilt) source format.
  * Bump to debhelper 7 (no CDBS) and Standards-Version 3.9.2.
  * Bump compiz-dev dependency.
  * Use dh-autoreconf, build-depend on intltool.
  * Expand extended descriptions in debian/control.
  * Remove 01_upstream_pixmap-crashes-window-switcher.patch, applied upstream.
  * Refresh 02_improve_desktop_file.patch.
  * Remove 03_oldgtk.patch, applied upstream.
  * Add 06_adjust_to_new_compiz.patch, by David Foerster <email address hidden>:
    port to the new compiz API.
  * Add 07_potfiles_skip.patch: ignore .pc for autoreconf.
 -- Maia Kozheva <email address hidden> Sat, 04 Jun 2011 13:58:53 +0700

Changed in emerald (Ubuntu Oneiric):
status: Triaged → Fix Released
Maia Everett (linneris) on 2011-06-04
summary: - emerald segfault on launch
+ [natty, SRU] emerald segfault on launch
Revision history for this message
Maia Everett (linneris) wrote :

As it turned out, David Foerster's PPA patch also applies to version 0.7.2 in Natty and fixes the crash there (tested on a clean Natty install). So I've uploaded that to natty-proposed.

Steps to reproduce for the SRU team:
- Run under Compiz as the window manager.
- Install emerald.
- From the console, type emerald --replace. The result will be a segmentation fault.
- Install emerald 0.7.2-0ubuntu6.1 from -proposed.
- Run emerald --replace. Emerald should now start normally.

Changed in emerald (Ubuntu Natty):
status: Triaged → Confirmed
description: updated
Revision history for this message
Maia Everett (linneris) wrote :

Attaching interdiff for reference.

Revision history for this message
David F. (malteworld) wrote :

Łukasz Czuja built emerald from an upstream git branch that works with compiz 0.9.4 (see https://bugs.launchpad.net/ubuntu/+source/emerald/+bug/726229/comments/26 ff.).

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted emerald into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in emerald (Ubuntu Natty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Revision history for this message
ticket (tickettothemoon2004) wrote :

I can confirm the fix at:

http://abz89.wordpress.com/2011/05/02/how-to-fix-emerald-in-ubuntu-11-04

works fine.

I found I had to use the emerald theme manager, under the 'Frame/Shadows' tab, to nudge the values of the shadow radius (to get rid of bright white borders) and the size of the left & right frame borders (to reclaim the left/right window resize handles).

Other than that, the above fix is working good here.
Using a nVidia GT250 card, and Ubuntu Classic.

Revision history for this message
ticket (tickettothemoon2004) wrote :

Oops, one wrinkle remaining for the fix at:

http://abz89.wordpress.com/2011/05/02/how-to-fix-emerald-in-ubuntu-11-04

The fix to restore left/right resize handles fails to work for subsequently opened windows. So the fix doesn't 'stick'. Even if the adjusted theme is saved, and you reboot or re-login.

Revision history for this message
Display Name (user340562791542-deactivatedaccount) wrote :

Martin, the version 0.7.2-0ubuntu6.1 in proposed is buggy, I can't see the right window border.

The 0.8.8 package from https://launchpad.net/~malteworld/+archive/compiz works fine.

I think proposed needs that package rather.

Martin Pitt (pitti) on 2011-07-18
tags: added: verification-failed
removed: verification-needed
Revision history for this message
Sasquatch (sasquatch) wrote :

That 0.8.8 is required is in the changelog of that package. It clearly notes changes that are essential for working with Compiz 0.9.4. It's the only version that is said to work with that compiz version (the one Ubuntu uses in Natty).

Revision history for this message
Display Name (user340562791542-deactivatedaccount) wrote :

Weird, there are two branches for emerald source:
http://cgit.compiz.org/fusion/decorators/emerald/log/
http://cgit.compiz.org/fusion/decorators/emerald/log/?h=compiz%2b%2b

They started to differ at 2009-10-14, I'm not sure on the purpose of compiz++ branch, since afaik compiz++ was an old compiz branch which was abandoned (http://en.wikipedia.org/wiki/Compiz#Merge_of_the_Compiz_branches).

The latest commit in the non-master compiz++ branch bumps version from 0.8.5 to 0.9.4 (http://cgit.compiz.org/fusion/decorators/emerald/commit/?h=compiz%2b%2b&id=2f5649c6d57c1b38c9b1aca9c6e9987f66828bf5). But0.9.4 is somewhat the compiz version used in Natty (https://launchpad.net/ubuntu/+source/compiz). However even Oneiric uses emerald 0.8.8.

Revision history for this message
dino99 (9d9) wrote :
Changed in emerald (Ubuntu Natty):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers