xapt fails to install armel packages in i386 Precise

Bug #992503 reported by Jean-Luc Aufranc on 2012-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
emdebian-crush (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu 12.04, xapt fails to install armel/armhf libs:

sudo xapt -a armel -M http://ports.ubuntu.com -S precise libbz2-dev

....

Use of qw(...) as parentheses is deprecated at /usr/bin/dpkg-cross line 1053.
dpkg-cross: Skipping Multi-Arch package 'libbz2-1.0_1.0.6-1_armel.deb'.
Use of qw(...) as parentheses is deprecated at /usr/bin/dpkg-cross line 1053.
dpkg-cross: Skipping Multi-Arch package 'libc6_2.15-0ubuntu10_armel.deb'.

....

Unpacking replacement debconf-armel-cross ...
dpkg: error processing /var/lib/xapt/output/dpkg_1.16.1.2ubuntu7_armel.deb (--install):
package architecture (armel) does not match system (i386)
Preparing to replace dpkg-armel-cross 1.16.1.2ubuntu7 (using .../dpkg-armel-cross_1.16.1.2ubuntu7_all.deb) ...
Unpacking replacement dpkg-armel-cross ...

If I add -m, it won't skip the package, but still fail to install the lib.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers