[MIR] Main inclusion request for embryo

Bug #490304 reported by Jamie Bennett on 2009-11-30
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
embryo (Ubuntu)
Undecided
Unassigned

Bug Description

This package is needed by the mobile team to make the 2D non-accelerated netbook launcher environment available to ARM architectures.

Report:
    https://wiki.ubuntu.com/MainInclusionReportEmbryo

affects: ubuntu → embryo (Ubuntu)
Martin Pitt (pitti) on 2009-12-10
Changed in embryo (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Revision history for this message
Martin Pitt (pitti) wrote :

Where is this used exactly? In code that we write, or in an existing projects? We already have lua in main, which has a very similar purpose and is much more widespread.

Changed in embryo (Ubuntu):
status: New → Incomplete
Revision history for this message
Jamie Bennett (jamiebennett) wrote :

As outlined in the original description, this package is a dependency of netbook-launcher-efl which is part of a high priority blueprint for this cycle. This launcher is a replacement for the clutter-based launcher used in the normal flavour of UNE to be used on ARM (but not restricted to ARM) based devices that do not have 3D acceleration available.

Revision history for this message
Martin Pitt (pitti) wrote : Re: [Bug 490304] Re: [MIR] Main inclusion request for embryo

Jamie Bennett [2009-12-21 9:31 -0000]:
> This launcher is a replacement for the clutter-based launcher used
> in the normal flavour of UNE

And that is written in this embryo language? Is that written by
Canonical?

Revision history for this message
Martin Pitt (pitti) wrote :

Right now this looks pretty suspicious to me, to be honest. We already have like 20 virtual machines in main, this is a rather obscure one, and does not even have a test suite. With neither an explicit Ubuntu maintainer nor even a test suite I wouldn't like to see this in main.

Revision history for this message
Jamie Bennett (jamiebennett) wrote :

Looks like this dependency is no longer needed for the project.

Changed in embryo (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Jamie Bennett (jamiebennett) wrote :

Actually it is for the elementary package so reopening.

Changed in embryo (Ubuntu):
status: Invalid → New
Revision history for this message
Jamie Bennett (jamiebennett) wrote :

Sorry that should of read,

Actually it is for the edje package so reopening.

Revision history for this message
Loïc Minier (lool) wrote :

As discussed on IRC, here are some things I noted while reviewing:
* No code warning/errors during build, good!
* --disable-rpath should be dropped from rules
* Someone needs to subscribe to bug mail; perhaps the Debian maintainer is interested?

I agree the lack of testsuite is quite an issue here, also I think it would need at least a security review too.

Let's check with upstream whether we can avoid that one.

Revision history for this message
Loïc Minier (lool) wrote :
Revision history for this message
Loïc Minier (lool) wrote :

Sorry that's another project

Revision history for this message
Jamie Bennett (jamiebennett) wrote :

According to upstream this is absolutely essential for edje, no embryo, no edje.

It was mentioned that embryo is small and is really only designed for edje and as such should be treated as just a part of edje.

Revision history for this message
Jamie Bennett (jamiebennett) wrote :

Also there is no plan's for a testsuite for embryo.

Revision history for this message
Albin Tonnerre (lutin) wrote :

Hi there,

I'm now subscribed to the bugmail for this package - I inadvertently forgot to subscribe to it.
As Jamie pointed out, embryo is *required* currently for edje and elementary, and you do want them in main, so I'm not really sure you have a choice here.

Regards,
Albin

Revision history for this message
Jamie Bennett (jamiebennett) wrote :

Martin,

I've discuss with quite a few of upstream now and it seems if we want edje (and its required for this cycle) then we need embryo. What can we do to push this one through?

Revision history for this message
Martin Pitt (pitti) wrote :

Jamie Bennett [2010-01-05 12:44 -0000]:
> I've discuss with quite a few of upstream now and it seems if we want
> edje (and its required for this cycle) then we need embryo. What can we
> do to push this one through?

Well, if we need it for an important blueprint, or have a business
commitment to it, then it's not so much a question of "if" in the
first place.

As I already said, this looks like a rather obscure and hard to
maintain piece of code -- a VM without formal tests is a disaster
waiting to happen if you ever need to fix anything in it. If it's only
used in the cotext of edje, then it might be much better to just
integrate embryo into edje instead of offering it as a separate public
API. Does edje, and the applications above that have any test suite
or test plan which would allow at least a shallow testing of embryo?

If the mobile team wants to commit to maintaining this, it's fine, but
I would like to see a firm and explicit statement about that. If you
rely on something like this, then you might not get away with "Minimal
maintenance needed" and "Debian responsible for bugs", but we should
have someone who has at least a basic understanding of how this works,
and check whether these pieces are at least documented somewhere.

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Revision history for this message
Jamie Bennett (jamiebennett) wrote :

Upstream are unwilling to combine embryo with the edje code base so if this is the desired course of action we need to carry the change ourselves in Ubuntu which may be worse than the initial problem.

Revision history for this message
Alexander Sack (asac) wrote :

I update MIR wiki page to reflect increased support commitment:

 * Ubuntu Mobile Team takes responsibility for package
 * Ubuntu Mobile Team will explicitly keep track of bugs on embryo and netbook-launcher-efl (where embryo regressions would most likely manifest)

Revision history for this message
Alexander Sack (asac) wrote :

filed bug 506335 to keep track of upstream poking about unittests regularly.

Revision history for this message
Martin Pitt (pitti) wrote :

So, since it's not a question of "if", I think the discussion covered everything.

It really seems like a very badly done NIH case here, but if you are willing to commit the resources to it, approved.

Changed in embryo (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
status: New → Fix Committed
Revision history for this message
Alexander Sack (asac) wrote :

... also to highlight the context: this is needed for our 2d launcher, which is an essential blueprint this cycle as we want to move to a UNE approach for armel, but can't without this launcher.

Revision history for this message
Steve Kowalik (stevenk) wrote :

Promoted to main.

Changed in embryo (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers