FTBFS due to conflict boost 1.49 with 1.53 in Build-Depends

Bug #1224617 reported by Artur Rona on 2013-09-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ember (Debian)
Fix Released
Unknown
ember (Ubuntu)
High
Dimitri John Ledkov

Bug Description

ember got in Build-Depends libboost-thread-dev (1.53) and libogre-dev which depends on boost 1.49. It causes Build-Depends conflict.

Checking for source dependency conflicts...
  /usr/bin/sudo /usr/bin/apt-get --purge $CHROOT_OPTIONS -q -y install debhelper dh-autoreconf libalut-dev libatlas-cpp-0.6-dev libboost-thread-dev libcegui-mk2-dev liberis-1.3-dev liblua5.1-0-dev libmercator-0.3-dev libogre-dev libopenal-dev libpcre3-dev libsdl1.2-dev libsigc++-2.0-dev libtinyxml-dev libtolua++5.1-dev libvarconf-dev libwfut-0.2-dev pkg-config
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libogre-dev : Depends: libboost-date-time1.49-dev but it is not going to be installed
               Depends: libboost-thread1.49-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
apt-get failed.
Package installation failed
Trying to reinstall removed packages:
Trying to uninstall newly installed packages:
Source-dependencies not satisfied; skipping ember
******************************************************************************
Finished at 20130827-2126
Build needed 00:00:00, 0k disk space

Artur Rona (ari-tczew) on 2013-09-12
Changed in ember (Ubuntu):
assignee: nobody → Artur Rona (ari-tczew)
status: New → In Progress
Artur Rona (ari-tczew) on 2013-09-12
tags: added: ftbfs saucy
Stephen M. Webb (bregma) wrote :

This should be resolved by Debian bug #704786, which is pending on the resolution of packaging problems in the ember stack.

Artur Rona (ari-tczew) wrote :

You're right. Maintainer of ember should to upgrade the package to new upstream version and bump depends on ogra-1.8. For saucy, I'd like to upload a workaround.

Artur Rona (ari-tczew) on 2013-09-13
Changed in ember (Ubuntu):
assignee: Artur Rona (ari-tczew) → nobody
status: In Progress → New
Stephen M. Webb (bregma) on 2013-09-13
Changed in ember (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in ember (Debian):
status: Unknown → Fix Committed
Dimitri John Ledkov (xnox) wrote :

I've tried to update ogre to 1.8.1 with boost1.5x support, but that didn't work out (ember still fails to build from source).
It's ok for us to ship multiple boost versions in universe for saucy. Can we simply live with this FTBFS and wait for OGRE/boost transition to happen in Debian & revisit this bug for T?

Changed in ember (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Artur Rona (ari-tczew) wrote :

Well, there are 2 possibilities ways to fix this one:

1) You just upload my debdiff with small changes and it fixes FTBFS -> builds fine with boost 1.49.

2) Leave this one and we are waiting to get them fixed in Debian. Our FTBFS concerns to rebuild, so there will be no difference for users.

I'm leaving decision for you as you're a sponsor. Otherwise please unsubscribe ubuntu-sponsors.

On 16 September 2013 17:11, Artur Rona <email address hidden> wrote:
> Well, there are 2 possibilities ways to fix this one:
>
> 1) You just upload my debdiff with small changes and it fixes FTBFS ->
> builds fine with boost 1.49.
>

I see what you mean now, ember needs whichever boost-thread is used by
ogre and not just any/default boost-thread.
I'll upload your patch. I misunderstood your patch initially.

Regards,

Dmitrijs.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ember - 0.6.2+dfsg-2ubuntu1

---------------
ember (0.6.2+dfsg-2ubuntu1) saucy; urgency=low

  * debian/control: Drop libboost-thread-dev from Build-Depends
    due to conflict Boost 1.53 with 1.49 which libogre-dev
    depends on, fixes FTBFS. (LP: #1224617)
 -- Artur Rona <email address hidden> Thu, 12 Sep 2013 18:55:07 +0200

Changed in ember (Ubuntu):
status: Confirmed → Fix Released
Changed in ember (Debian):
status: Fix Committed → New
Changed in ember (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.