should be "Multi-Arch: foreign" to satisfy deps when installing a foreign architecture pkg

Bug #1096623 reported by Ivan Zakharyaschev on 2013-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
emacsen-common (Ubuntu)
Undecided
Unassigned

Bug Description

I wanted to install coq:armel on Ubuntu 12.04 armhf system (https://answers.launchpad.net/ac100/+question/218291 ), but emacsen-common was an obstacle:

# apt-get install coq:armel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 coq:armel : Depends: coq-theories:armel (= 8.3.pl4+dfsg-1) but it is not installable
             Depends: emacsen-common:armel but it is not installable
             Depends: libcoq-ocaml-vx397:armel
             Recommends: coqide:armel but it is not going to be installed or
                         proofgeneral:armel but it is not installable
E: Unable to correct problems, you have held broken packages.

Can't the emacsen-common package be labelled "Multi-Arch: foreign" to satisfy deps when installing a foreign architecture pkg?

After I edited /var/lib/dpkg/{status,available} and /var/lib/apt/Packages*, this obstacle was gone -- http://unix.stackexchange.com/a/60287/4319 .

Ivan Zakharyaschev (imz) on 2013-01-06
tags: added: 12.04
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers