Ubuntu

Emacs doesn't use Unity global app menu

Reported by Luke Hoersten on 2011-11-10
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
emacs23 (Ubuntu)
Undecided
Unassigned

Bug Description

Emacs doesn't use Unity global app menu in Ubuntu 11.10.

Related AskUbuntu question:
http://askubuntu.com/questions/69331/emacs-unity-global-app-menu-integration-stopped-working-in-11-10

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: emacs 23.3+1-1ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Thu Nov 10 13:10:55 2011
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
PackageArchitecture: all
SourcePackage: emacs23
UpgradeStatus: Upgraded to oneiric on 2011-10-18 (23 days ago)

Luke Hoersten (lukehoersten) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in emacs23 (Ubuntu):
status: New → Confirmed
Gargoulf (pasquiernoterdaeme) wrote :

Same for acrobat reader

Luke Hoersten (lukehoersten) wrote :

I'd like to know if there's a plan to get apps like Emacs, Eclipse, Acrobat, etc, using the global app menu.

Alex Murray (alexmurray) wrote :

Emacs is specifically blacklisted from using appmenu-gtk and hence the global menus since appmenu doesn't cope with Emac's dynamic menus where changing say major modes adds / removes entries from the menu - more info on this bug report https://bugs.launchpad.net/ubuntu/+source/appmenu-gtk/+bug/673302

Changed in emacs23 (Ubuntu):
status: Confirmed → Invalid
anthropornis (anthropornis) wrote :

Alex, is this bug marked as invalid because it is considered to be a duplicate bug?

Changed in emacs23 (Ubuntu):
status: Invalid → Confirmed
Cson (theceason) wrote :

same as emacs 24 snapshot

Marius B. Kotsbak (mariusko) wrote :

It is not using the global menu on purpose, thus marking as duplicate of bug #673302.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers