flyspell broken on maverick

Bug #658025 reported by Roger Binns on 2010-10-11
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
emacs23 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: emacs23

After upgrading to Maverick trying to enable flyspell always results in this error:

   Enabling flyspell mode gave an error

And yes really, they do not provide any further information anywhere. I do not have any flyspell (or other spelling) customisations in my .emacs. aspell (and dictionaries) was installed but ispell (and dictionaries) was not. I installed ispell and iamerican as well and restarted but still got the error.

Googling indicates that the usual causes of problems are not having the dictionaries installed but I do, or having other copies of flyspell installed. I do not have any of my own - they all came from Ubuntu packages. Everything was working fine in Lucid on two different machines but see also bug 619015.

$ locate flyspell
/usr/share/emacs/23.1/lisp/textmodes/flyspell.elc
/usr/share/emacs/site-lisp/dictionaries-common/flyspell.el
/usr/share/emacs23/site-lisp/dictionaries-common/flyspell.el
/usr/share/emacs23/site-lisp/dictionaries-common/flyspell.elc

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: emacs23-common 23.1+1-4ubuntu7
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Oct 10 17:46:04 2010
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: emacs23

Roger Binns (ubuntu-rogerbinns) wrote :
Ted (tedks) on 2010-10-11
Changed in emacs23 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers