org and tbl menus are missing in org-mode

Bug #640504 reported by Pratik on 2010-09-16
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
emacs23 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: emacs23

The org menu and tbl menu is missing in the org-mode when switching from text mode. When I switch from the lisp interaction mode when I click the org menu I get the contents of the lisp interaction menu, but tbl menu is still missing.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: emacs 23.1+1-4ubuntu7
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
Date: Thu Sep 16 08:28:48 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: emacs23

Pratik (pkpatel88) wrote :
Pratik (pkpatel88) wrote :

I can get to the menus, org and tbl, from M-`

Thomas Krennwallner (tkren) wrote :

I can confirm this, I'm unable to access any "new menu entry" with the mouse in an emacs window. When I'm in vc-dir mode, I cannot click on the VC-dir menu, similarly to org-mode menu entries Org, Tbl, and Agenda.

Dietmar Winkler (dietmarw) wrote :

I can also confirm this for the LaTeX mode (in addition to the ones named above). It looks somehow any major mode with its own menus does not work properly.

Changed in emacs23 (Ubuntu):
status: New → Confirmed
Dietmar Winkler (dietmarw) wrote :

I forgot: ECB mode the same

Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package emacs23 - 23.2+1-4ubuntu1

---------------
emacs23 (23.2+1-4ubuntu1) natty; urgency=low

  [ Michael W. Olson (GNU address) ]
  * Resync with Debian. Remaining changes:
  * debian/control.in:
    - Change Maintainer to Ubuntu Core Developers, per Ubuntu policy.
    - Conflict and Replace emacs23-common-non-dfsg, since we provide
      all of its features.
    - Do not suggest emacs23-common-non-dfsg.
    - Replace use of Source-Version with source:Version.
    - Require autotools-dev (>= 20100122.1) in Build-Depends, since
      the version in Karmic will fail due to a missing Perl module.
  * debian/control: Regenerate.
  * debian/copyright.in:
    - Remove text about removed files.
  * debian/copyright: Regenerate.
  * debian/emacsVER-common.postinst:
    - Don't install info files to info/dir. This happens
      automatically now.
  * debian/emacsVER-common.prerm:
    - Don't remove info files from info/dir. This happens
      automatically now.
  * debian/patches:
    - handle-dfsg-split.diff: Remove.
    - ubuntu-restore-nondfsg-files.diff: New patch that reintroduces
      the non-DFSG files, with the exception of .elc files and info
      files, which use special characters and thus can't be easily
      represented in patch form. These will be regenerated at build
      time.
  * debian/rules:
    - Do not install replacements for non-DFSG files.
    - Install all info files, not just efaq.
    - Avoid uselessly building info files a 2nd time.

  [ Reinhard Tartler ]
  * Reintegrate ubuntu history in debian/changelog
  * verified that debian/patches/fix-movemail-race.diff can be dropped,
    it is integrated in the new upstream version.
  * Rebuild against new debhelper to get trigger support: LP: #449729
  * New upstream version (LP: #588203) solves:
    - huge font sizes. LP: #445402
    - scroll bar in emacs highlights/selects text, LP: #581486
    - org and tbl menus are no longer missing in org-mode, LP: #640504
  * Add patch fix-ftbfs-xft-fontconfig.diff to avoid FTBFS.

emacs23 (23.2+1-4) unstable; urgency=low

  * Disable parallel builds (via DEB_BUILD_OPTIONS=parallel) until an
    upstream race condition is fixed. Thanks to Sven Joachim
    <email address hidden> for the report. (closes: #592992)

emacs23 (23.2+1-3) unstable; urgency=low

  * Don't try to "mkdir $(infodir)" in doc/*/Makefile.in. Thanks to
    Stéphane Glondu <email address hidden> for the 23.2+1-2.1 NMU.

  * Use -O1 rather than -O2 on ia64. Fixes a build failure (looks
    like a broken byte compiler) with newer versions of gcc
    (c.f. #207580). Thanks to Sven Joachim <email address hidden> for the
    report and thanks to Stéphane Glondu <email address hidden> for the
    23.2+1-2.1 NMU. (closes: #582439)

  * Remove deprecated Encoding field from emacsVER.desktop. Thanks to
    Stéphane Glondu <email address hidden> for the 23.2+1-2.1
    NMU.

  * Use "set -e" rather than "/bin/sh -e" in emacsVER-common.postinst
    and emacsVER-bin-common.postinst. Thanks to Stéphane Glondu
    <email address hidden> for the 23.2+1-2.1 NMU.

  * Add a Homepage field to debian/control.in. Thanks to Stéphane
    Glondu <email address hidden> for the ...

Read more...

Changed in emacs23 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers