[FFe] Please merge emacs23 23.2+1-4 (main) from Debian unstable (main)

Bug #588203 reported by David Leal on 2010-06-01
160
This bug affects 28 people
Affects Status Importance Assigned to Milestone
emacs23 (Debian)
Fix Released
Unknown
emacs23 (Ubuntu)
Undecided
Michael Olson

Bug Description

Binary package hint: emacs23

Emacs 23.2 is already on Debian Sid, can we get it for Ubuntu?

Thanks. :)

 emacs23 (23.2+1-4) unstable; urgency=low

   * Disable parallel builds (via DEB_BUILD_OPTIONS=parallel) until an
     upstream race condition is fixed. Thanks to Sven Joachim
     <email address hidden> for the report. (closes: #592992)

 -- Rob Browning <email address hidden> Sat, 14 Aug 2010 16:34:11 -0500

emacs23 (23.2+1-3) unstable; urgency=low

   * Don't try to "mkdir $(infodir)" in doc/*/Makefile.in. Thanks to
     Stéphane Glondu <email address hidden> for the 23.2+1-2.1 NMU.

   * Use -O1 rather than -O2 on ia64. Fixes a build failure (looks
     like a broken byte compiler) with newer versions of gcc
     (c.f. #207580). Thanks to Sven Joachim <email address hidden> for the
     report and thanks to Stéphane Glondu <email address hidden> for the
     23.2+1-2.1 NMU. (closes: #582439)

   * Remove deprecated Encoding field from emacsVER.desktop. Thanks to
     Stéphane Glondu <email address hidden> for the 23.2+1-2.1
     NMU.

   * Use "set -e" rather than "/bin/sh -e" in emacsVER-common.postinst
     and emacsVER-bin-common.postinst. Thanks to Stéphane Glondu
     <email address hidden> for the 23.2+1-2.1 NMU.

   * Add a Homepage field to debian/control.in. Thanks to Stéphane
     Glondu <email address hidden> for the 23.2+1-2.1 NMU.

   * Remove redundant Section and Priority fields from binary packages
     in debian/control.in. Thanks to Stéphane Glondu
     <email address hidden> for the 23.2+1-2.1 NMU.

   * Change quilt Build-Depends from (>= 0.42-1) to (>= 0.42). Thanks
     to Stéphane Glondu <email address hidden> for the 23.2+1-2.1 NMU.

   * Change debhelper Build-Depends from (>=4) to (>= 7.0.50~) to
     support rules overrides. Thanks to Sven Joachim
     <email address hidden>, and thanks to Stéphane Glondu
     <email address hidden> for the 23.2+1-2.1 NMU.

   * Add ${misc:Depends} to debian/control for debhelper. Thanks to
     Stéphane Glondu <email address hidden> for the 23.2+1-2.1 NMU.

   * Fix startup hang on GNU/kFreeBSD (fix-kfreebsd-startup.diff).
     Thanks to antoine beaupre <email address hidden> for the report
     and Petr Salinger <email address hidden> for the patch.
     (closes: #559392)

 -- Rob Browning <email address hidden> Sat, 14 Aug 2010 11:57:17 -0500

emacs23 (23.2+1-2) unstable; urgency=low

   * Respect DESTDIR in doc/misc/Makefile.in. (closes: #581642)

 -- Rob Browning <email address hidden> Fri, 14 May 2010 21:56:27 -0700

emacs23 (23.2+1-1) unstable; urgency=low

   * New emacs23 packages.

   * Update debian/dfsg-splitter.

   * Add dependency on libgconf2-dev and use --without-gconf for
     emacsFLAVOR-nox and emacsFLAVOR-lucid builds.

   * Remove patches:
       patches/fix-dynamic-menus.diff
       patches/fix-gtk-scroll-bar-events.diff
       patches/fix-rmail-capitalized-month-names.diff
       patches/use-zwj-and-zwnj-for-indic-scripts.diff

   * Refresh remaining patches.

 -- Rob Browning <email address hidden> Thu, 13 May 2010 19:21:32 -0700

emacs23 (23.1+1-9) unstable; urgency=low

   * Fix binary-only builds (dpkg-buildpackage -B) and conditionalize
     all packages in dh_auto_install. (closes: #580067)

 -- Rob Browning <email address hidden> Thu, 06 May 2010 22:59:26 -0700

emacs23 (23.1+1-8) unstable; urgency=low

   * Add automake to Build-Depends. (closes: #580006)

 -- Rob Browning <email address hidden> Sun, 02 May 2010 19:53:36 -0700

emacs23 (23.1+1-7) unstable; urgency=low

   * Remove Jerome from debian/control Uploaders since he has
     retired. (closes: #573442)

   * Support DEB_BUILD_OPTIONS parallel=N.

   * Follow current autotools-dev recommendations - build-depend on
     autoconf, remove the automatically generated files in clean, and
     regenerate them before building.

   * Update debian/compat from 4 to 7.

   * Switch to Debian 3.0 (quilt) source format and drop debian/rules
     "protected_files" handling since we don't build in $(CURDIR) and
     haven't for a while.

   * Fix ctags manpage rewriting so that ctags.FLAVOR.1 actually refers
     to man1/etags.FLAVOR.1 as intended.

   * Change debian/rules to use "dh $@" approach.

   * Update emacsFLAVOR-common dpkg dependency to require "dpkg (>=
     1.15.4) | install-info" for proper info page handling (Debian
     Policy 12.2), and remove install-info dependency from packages
     without info files.

   * Don't define unix when building emacs
     (add-unix-to-cpp-undefs.diff).

 -- Rob Browning <email address hidden> Sun, 02 May 2010 10:56:09 -0700

emacs23 (23.1+1-6) unstable; urgency=low

   * Apply an upstream patch to fix a problem with GTK+ scroll
     bars. Thanks to Eugen Dedu <email address hidden> for
     the report and Sven Joachim <email address hidden> for tracking down
     the patch. (closes: #560573)

   * Apply an upstream patch to include ZWJs and ZWNJs for all Indic
     scripts. Thanks to Praveen A <email address hidden> for the
     report. (closes: #559292)

   * Fix update-alternatives call for emacs manpage. Thanks to
     Jörg-Volker Peetz <email address hidden> and Sven Joachim
     <email address hidden> for the report. (closes: #552565)

 -- Rob Browning <email address hidden> Tue, 26 Jan 2010 22:51:54 -0800

emacs23 (23.1+1-5) unstable; urgency=low

   * Apply upstream patch to fix problem with GTK and dynamically
     generated menus (which could be unexpectedly empty). Thanks to
     Baylis Shanks <email address hidden> for the report.
     (closes: 550541)

 -- Rob Browning <email address hidden> Sun, 01 Nov 2009 10:00:58 -0800

It seems that the toolchain must be upgraded to build from sources the debian package.
A PPA would be great.

Thanks

Changed in emacs23 (Debian):
status: Unknown → New
Eli Osherovich (eli-osherovich) wrote :

I built it in my Lucid box. So, it seems you do not have any new tools.

Reuben Thomas (rrt) wrote :

To build the Debian package, at least a newer autotools-dev is needed. To build from upstream sources, newer tools are not needed.

Danil Pismenny (danil-orionet) wrote :

How to build it in Ubuntu Lucid?

nimai.e@gmail.com (nimai-e) wrote :

Any progress on this??

Alex Murray (alexmurray) wrote :

Looks like 23.2 is now available from Debian Unstable - http://packages.debian.org/search?keywords=emacs23 - any chance this could be sync'd over for Maverick?

era (era) on 2010-08-24
summary: - Emacs 23.2 is available
+ Please merge emacs23 23.2+1-4 (main) from Debian unstable (main)
description: updated

I'm working on this update, which I'd like to get into Maverick. It will be at least another day, because I'm going to provision a Maverick VM to deal with the autotools-dev change that Debian made. So far, patches have been reviewed, diff restoring non-DFSG files has been generated, and various merge conflicts have been resolved.

Changed in emacs23 (Ubuntu):
assignee: nobody → Michael Olson (mwolson)
status: New → In Progress
Michael Olson (mwolson) wrote :

I've uploaded a candidate to the ubuntu-elisp PPA (https://launchpad.net/~ubuntu-elisp/+archive/ppa), and it should finish building shortly. Change log follows:

emacs23 (23.2+1-4ubuntu1~ppa1) maverick; urgency=low

 * Resync with Debian. Remaining changes:
 * debian/control.in:
   - Change Maintainer to Ubuntu Core Developers, per Ubuntu policy.
   - Conflict and Replace emacs23-common-non-dfsg, since we provide
     all of its features.
   - Do not suggest emacs23-common-non-dfsg.
   - Replace use of Source-Version with source:Version.
   - Require autotools-dev (>= 20100122.1) in Build-Depends, since
     the version in Karmic will fail due to a missing Perl module.
 * debian/control: Regenerate.
 * debian/copyright.in:
   - Remove text about removed files.
 * debian/copyright: Regenerate.
 * debian/emacsVER-common.postinst:
   - Don't install info files to info/dir. This happens
     automatically now.
 * debian/emacsVER-common.prerm:
   - Don't remove info files from info/dir. This happens
     automatically now.
 * debian/patches:
   - handle-dfsg-split.diff: Remove.
   - ubuntu-restore-nondfsg-files.diff: New patch that reintroduces
     the non-DFSG files, with the exception of .elc files and info
     files, which use special characters and thus can't be easily
     represented in patch form. These will be regenerated at build
     time.
 * debian/rules:
   - Do not install replacements for non-DFSG files.
   - Install all info files, not just efaq.
   - Avoid uselessly building info files a 2nd time.

Michael Olson (mwolson) wrote :

Fixed a problem with the PPA build, and it's now ready. I may try backporting this to karmic and lucid also.

emacs23 (23.2+1-4ubuntu1~ppa2) maverick; urgency=low

  * debian/control.in:
    - Use bsd-mailx in Build-Depends so that buildd does not fail.
  * debian/control: Regenerate.

Changed in emacs23 (Ubuntu):
status: In Progress → Fix Committed
Michael Olson (mwolson) wrote :

Please grant an FFe for emacs23 (23.2+1-4ubuntu1) so it can get into Maverick.

It brings us up-to-date with Debian's packaging of emacs23, updates use of install-info according to new standards, and provides the features of the newest release of Emacs (see attached NEWS file). I've built it on my own machine and the ubuntu-elisp ppa, and tested daemon mode editing and upgrade from the previous emacs23 package. It should be a fairly low-risk upgrade in terms of dependencies, since I made an effort to preserve the changes to debian/control in 23.1+1-4ubuntu7, and generally prefer to make the least possible amount of change to Debian's packaging.

David Leal (dgleal) wrote :

Michael, many thanks. I'm already using it and it's working fine.

Michael Olson (mwolson) wrote :

Anders Kaseorg found a regression in the upstream release, and I've uploaded a new PPA build to address.

emacs23 (23.2+1-4ubuntu1~ppa3) maverick; urgency=low

 * debian/patches:
   - fix-decimal-point-in-font-size.diff: Fix failure to start when
     decimal point is present in font size.

summary: - Please merge emacs23 23.2+1-4 (main) from Debian unstable (main)
+ [FFe] Please merge emacs23 23.2+1-4 (main) from Debian unstable (main)
Michael Olson (mwolson) wrote :
Michael Olson (mwolson) wrote :

Additional backported packages uploaded to ppa:ubuntu-elisp for lucid, karmic, jaunty. These don't need to go out into Ubuntu main.

David Leal (dgleal) wrote :

There seems to be a problem with the latest builds: I can't run aptitude from inside eshell. It complains about not finding ldconfig, start-stop-daemon, etc:

17:25 :: ~ $ apti bzr-fastimport
The following NEW packages will be installed:
  bzr-fastimport
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/99.0kB of archives. After unpacking 610kB will be used.
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
dpkg: warning: 'ldconfig' not found in PATH or not executable.
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable.
dpkg: 2 expected program(s) not found in PATH or not executable.
NB: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.
E: Sub-process /usr/bin/dpkg returned an error code (2)
A package failed to install. Trying to recover:
dpkg: warning: 'ldconfig' not found in PATH or not executable.
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable.
dpkg: 2 expected program(s) not found in PATH or not executable.
NB: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.

I used to get the same error when I was using the emacs cvs snapshot versions for Debian by Romain Francoise.

Anders Kaseorg (andersk) wrote :

David: Did this problem occur with emacs 23.1? If so, it’s not a regression and you should open a separate bug.

David Leal (dgleal) wrote :

Anders,

nope, this didn't happen with 23.1, in fact, I believe (though I'm not positive on this) it didn't happen with earlier builds from Michael.

Anders Kaseorg (andersk) wrote :

Ah: that’s probably related to this feature mentioned in
http://www.gnu.org/software/emacs/NEWS.23.2 :

*** The new eshell built-in commands `su' and `sudo' support Tramp.
Thus, they change `default-directory' to reflect the new user id, and
let commands run under that user's permissions. This works even when
`default-directory' is already remote. Calling the external commands
is possible via `*su' or `*sudo', respectively.

The path that it uses is controlled by the tramp-remote-path variable; see http://www.gnu.org/software/tramp/#Remote-Programs . Its default value is
  '(tramp-default-remote-path "/usr/sbin" "/usr/local/bin"
    "/local/bin" "/local/freeware/bin" "/local/gnu/bin"
    "/usr/freeware/bin" "/usr/pkg/bin" "/usr/contrib/bin")
where tramp-default-remote-path is `getconf PATH` = /bin:/usr/bin. So /sbin is missing.

I suspect you can work around this either by changing your ‘apti’ alias to use the real sudo (*sudo), or by adding /sbin or 'tramp-own-remote-path to tramp-remote-path.

gero (gerod) wrote :

Bug #581486 is not really a duplicate of this bug but fixing this one would probably also fix the other one.

It's about two very annoying bugs in the Emacs version currently shipping with Lucid (23.1.1):
* Moving the scroll bar is marking text.
* When letting go of the scroll bar it often snaps back to its previous position (and with it the displayed section of the file) instead of staying where it is.

I gather that these problems stem from bugs in the interaction with GTK and X. Apparently they have been fixed in later versions, including Emacs 23.2.

As these are rather severe usability problems, is there any chance to get Lucid upgraded to Emacs 23.2?

era (era) wrote :

mwolson: could you include a pointer to bug #581496 in the Changelog as one of the bugs fixed by the upgrade. There are probably a few more. I guess maybe bug #445402, bug #558691, and bug #596423 could be fixed as well. (The upstream bug tracker doesn't correlate closed bug reports with releases, so it's a bit hard to tell.)

Barry Warsaw (barry) wrote :

I'm not able to sbuild the package in a maverick chroot. apt-get in the chroot barfs on installing the mailx dependency. Still looking...

Barry Warsaw (barry) wrote :

Have you looked at the (build-)rdepends to see what if anything could break? I've tried, but I'm having some system problems at the moment.

Barry Warsaw (barry) wrote :

I'm not able to check build-rdepends, but afaict, the rdepends install just fine against the 23.2 ppa mentioned above (modulo mutually exclusive alternatives, which I did not get a chance to check either).

era (era) wrote :

I've seen the mailx problem elsewhere, too. I believe vaguely that the fix is to change Build-Depends: mailx to Build-Depends: bsd-mailx

Ah, yes: http://bugs.debian.org/595840

Barry Warsaw (barry) wrote :

Yep that should be fixed. I also don't understand why it succeeds on the buildds but fails in local sbuilds. My only other concern is that with the release of 10.10 just a few weeks away, and the importance of emacs to the community, this could be a risky change. Emacs has a habit of making incompatible and hard to detect changes to behavior between minor releases, so 23.1 -> 23.2 is a bit disconcerting. As much as I'd like to see an updated emacs package in Maverick, would it not be safer to wait until they Natty sync?

era (era) wrote :

You're probably right. Then on the other hand, there are some ugly bugs which should probably be backported to Maverick (or even Lucid) but maybe it's better to fix one thing at a time.

Barry Warsaw (barry) wrote :

@era: Emacs always has bugs :) Which ones in particular do you think should be backported?

I see this was marked Fix Committed in Ubuntu, but no milestone target. It's not clear to me what version of Ubuntu we'll see Emacs 23.2 in then?

era (era) wrote :

At the very least Debian's patches/fix-dynamic-menus.diff (bug #581486) but I guess also the ones I mention in comment #22 would at least be worth considering.

Oops, the link in comment #22 should be to bug #581486, not ...96

Michael Olson: what's the status of the FFe, is the package you built being considered even though it had some regressions?

PazO (pazoman) wrote :

Sorry if I spam this list unnecessarily but I discovered that I had to "apt-get remove sudo auctex" before I could do a apt-get dist-upgrade with this ppa added.

This was the output.

Setting up emacs23 (23.2+1-4ubuntu1~ppa3~lucid1) ...
emacs-install emacs23
install/auctex: Setting up for emacs23 (log file: /usr/share/emacs23/site-lisp/auctex//CompilationLog)... emacs-install: /usr/lib/emacsen-common/packages/install/auctex emacs23 failed at /usr/lib/emacsen-common/emacs-install line 28, <TSORT> line 15.
dpkg: error processing emacs23 (--configure):
 subprocess installed post-installation script returned error exit status 123
dpkg: dependency problems prevent configuration of emacs:
 emacs depends on emacs23 | emacs23-lucid | emacs23-nox; however:
  Package emacs23 is not configured yet.
  Package emacs23-lucid is not installed.
  Package emacs23-nox is not installed.
dpkg: error processing emacs (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 emacs23
 emacs
E: Sub-process /usr/bin/dpkg returned an error code (1)

Apart from that everything works like a charm. Thank you very much guys!

Scott Kitterman (kitterman) wrote :

This should be addresses as a normal merge in Natty.

The current version in the PPA (as of 26/10/10) works but something went wrong with fonts.

I use "Consolas" font in my emacs

(set-default-font "Consolas-12")

And it looks very nice in Emacs 23.1. However, in 23.2 it is very very bad.

Fumihito YOSHIDA (hito) wrote :

@billi,

Could you please attach that's "bad" screenshots?
And, by my pure guess,If emacs frame widen by your "bad" behavior, you can resolve the problems by #596423.

Here they are.

The difference is less pronounced in the images (because of blurring?) but for me the new (23.2) version was unusable when I tried to edit some text file.

Note how the world "number" is rendered in the new version the letter u and m are too close to each other. It does not seem to be the same font at all. Do I need a new command?

Thank you.

It seems that changing the font size to 14 (was 12) solves the problem. Now the font looks like in the previous Emacs version.

Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package emacs23 - 23.2+1-4ubuntu1

---------------
emacs23 (23.2+1-4ubuntu1) natty; urgency=low

  [ Michael W. Olson (GNU address) ]
  * Resync with Debian. Remaining changes:
  * debian/control.in:
    - Change Maintainer to Ubuntu Core Developers, per Ubuntu policy.
    - Conflict and Replace emacs23-common-non-dfsg, since we provide
      all of its features.
    - Do not suggest emacs23-common-non-dfsg.
    - Replace use of Source-Version with source:Version.
    - Require autotools-dev (>= 20100122.1) in Build-Depends, since
      the version in Karmic will fail due to a missing Perl module.
  * debian/control: Regenerate.
  * debian/copyright.in:
    - Remove text about removed files.
  * debian/copyright: Regenerate.
  * debian/emacsVER-common.postinst:
    - Don't install info files to info/dir. This happens
      automatically now.
  * debian/emacsVER-common.prerm:
    - Don't remove info files from info/dir. This happens
      automatically now.
  * debian/patches:
    - handle-dfsg-split.diff: Remove.
    - ubuntu-restore-nondfsg-files.diff: New patch that reintroduces
      the non-DFSG files, with the exception of .elc files and info
      files, which use special characters and thus can't be easily
      represented in patch form. These will be regenerated at build
      time.
  * debian/rules:
    - Do not install replacements for non-DFSG files.
    - Install all info files, not just efaq.
    - Avoid uselessly building info files a 2nd time.

  [ Reinhard Tartler ]
  * Reintegrate ubuntu history in debian/changelog
  * verified that debian/patches/fix-movemail-race.diff can be dropped,
    it is integrated in the new upstream version.
  * Rebuild against new debhelper to get trigger support: LP: #449729
  * New upstream version (LP: #588203) solves:
    - huge font sizes. LP: #445402
    - scroll bar in emacs highlights/selects text, LP: #581486
    - org and tbl menus are no longer missing in org-mode, LP: #640504
  * Add patch fix-ftbfs-xft-fontconfig.diff to avoid FTBFS.

emacs23 (23.2+1-4) unstable; urgency=low

  * Disable parallel builds (via DEB_BUILD_OPTIONS=parallel) until an
    upstream race condition is fixed. Thanks to Sven Joachim
    <email address hidden> for the report. (closes: #592992)

emacs23 (23.2+1-3) unstable; urgency=low

  * Don't try to "mkdir $(infodir)" in doc/*/Makefile.in. Thanks to
    Stéphane Glondu <email address hidden> for the 23.2+1-2.1 NMU.

  * Use -O1 rather than -O2 on ia64. Fixes a build failure (looks
    like a broken byte compiler) with newer versions of gcc
    (c.f. #207580). Thanks to Sven Joachim <email address hidden> for the
    report and thanks to Stéphane Glondu <email address hidden> for the
    23.2+1-2.1 NMU. (closes: #582439)

  * Remove deprecated Encoding field from emacsVER.desktop. Thanks to
    Stéphane Glondu <email address hidden> for the 23.2+1-2.1
    NMU.

  * Use "set -e" rather than "/bin/sh -e" in emacsVER-common.postinst
    and emacsVER-bin-common.postinst. Thanks to Stéphane Glondu
    <email address hidden> for the 23.2+1-2.1 NMU.

  * Add a Homepage field to debian/control.in. Thanks to Stéphane
    Glondu <email address hidden> for the ...

Read more...

Changed in emacs23 (Ubuntu):
status: Fix Committed → Fix Released
Changed in emacs23 (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.