emacs default font is huge

Bug #445402 reported by Tuukka Hastrup on 2009-10-07
74
This bug affects 14 people
Affects Status Importance Assigned to Milestone
GNU Emacs
Fix Released
Unknown
emacs23 (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Reinhard Tartler
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: emacs23

Emacs 23.1 does not detect the system font resolution properly, which leads to ridiculously huge fonts when using "smaller" font resolutions.

Steps to reproduce:
 - in System -> Appearance -> Fonts -> Details -> Set resolution to less than 72dpi
 - Start Emacs without config: "emacs -Q"

   In default configuration, Emacs will use "Monospace 12" as text font

 - open a gedit instance and set the font to "Monospace 12" as well.

   At higher resolutions (~92dpi) there won't be nearly no noticable difference. At lower resultions (~72), the emacs font is pretty large compared to the gedit reference.

Alternative steps to reproduce:

 - Start emacs one time with 72dpi and note that the font doesn't change when emacs is started with a resolution of 92dpi.

The fact that emacs doesn't change its font when the system resultion is changed while emacs is running may or may not be a seperate bug.

Original Report follows:
Since the latest emacs upgrade in Karmic, the default font is now huge. The Set Default Font dialog claims the font is DejaVu Sans Mono Book 12, and in the preview, capital letters indeed are 12 pixels high. However, in the editor, capital letters are 14 pixels high and look bold. For comparison, capitals in the menu bar are the normal 10 pixels.

To get a sane editor font, I need to set the size to 8, resulting in 9 pixels - I cannot get the height of 10 pixels, as sizes like 8.5 result in the error "Font not available". xdpyinfo reports 118x119 dots per inch, and Gnome font settings are at font size 10, 96 dpi, subpixels, a little hinting.

ProblemType: Bug
Architecture: i386
Date: Wed Oct 7 15:21:40 2009
DistroRelease: Ubuntu 9.10
Package: emacs 23.1+1-4ubuntu1
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-12.39-generic
SourcePackage: emacs23
Uname: Linux 2.6.31-12-generic i686

> The X-Server packages should depend on any xfnt package, because without
> any X-Font the postinst would fail (X -probeonly fails).

I'd guess that the -probeonly fails if there are either *no* fonts at
all or if there's not "fixed" font (if you have a setup handy where
you can test this, let me know, otherwise I'll try breaking one of the
machines here later...)

Rather than list all the font packages on each server, I think the
right thing to do is probably to create an 'xfnt' or 'xfntfixed'
virtual package (depending which theory above is right), depend on
that from *all* the servers, and provide it from all the font packages
(or if it's really "fixed", from all the font packages that provide a
fixed alias.) Comments?

   _Mark_ <email address hidden>
   The Herd of Kittens
   Debian X Maintainer

ps. I know, there's a seperate issue [#8463] with XF86Setup needing
xfnt75 as well, but ignore that for now...

This is an automated message sent to all bugs older than one year.

This bug is very old. Please take a look at it and see if you can fix it.
If it has already been fixed, please close it.

If you have problems fixing it or if you don't have the time to fix it,
please ask the people on <email address hidden> for help, so that
at least the oldest bugs can be solved before Debian 2.0 is released.

Remco Blaakmeer

merge 4547 15980
merge 16459 16983
severity 16459 important
merge 15356 16137
merge 16917 8463
merge 11322 16997
thanks
--
POPULATION EXPLOSION Unique in human experience, an event which happened
yesterday but which everyone swears won't happen until tomorrow.
- The Hipcrime Vocab by Chad C. Mulligan

retitle 4547 xserver-common: X servers should depend on X fonts
retitle 15980 xserver-common: X servers should recommend X fonts
retitle 37496 xserver-common: X servers should depend on X fonts
reassign 4547 xserver-common
reassign 15980 xserver-common
reassign 37496 xserver-common
severity 4547 normal
severity 15980 normal
severity 37496 normal
merge 4547 15980 37496
thanks

--
G. Branden Robinson |
Debian GNU/Linux | "Bother," said Pooh, as he was
<email address hidden> | assimilated by the Borg.
cartoon.ecn.purdue.edu/~branden/ |

Download full text (5.4 KiB)

retitle 1292 xserver-svga: X server loses track of the keyboard [UPSTREAM]
unmerge 1690
retitle 1690 xdm: dies with protection fault if X server exits with nonzero status [UPSTREAM]
severity 1690 fixed
retitle 1691 xserver-common: X server configuration tools allow an invalid numeric range [UPSTREAM]
severity 1691 fixed
retitle 1819 xserver-common: X server should lock the mouse device [UPSTREAM]
severity 1819 fixed
retitle 1985 xdm: forwards indirect requests from localhost with client IP of 127.0.0.1, which obviously won't come back [UPSTREAM]
retitle 2039 xserver-mach64: font erosion [UPSTREAM]
severity 2039 fixed
retitle 2297 xterm: xterm sometimes gets mouse-paste and RETURN keypress in wrong order [UPSTREAM]
retitle 3750 xserver-s3: X server waits too long to accept client connections [UPSTREAM]
retitle 4056 xserver-s3: mouse cursor appears offset from where it "actually" is [UPSTREAM]
severity 4056
retitle 4066 xserver-s3: display is wrapped around [UPSTREAM]
retitle 4494 xserver-svga: Xlib's XForceScreenSaver() causes display to flash [UPSTREAM]
retitle 4546 xdm: X -query fails when no network is present
severity 4546 fixed
retitle 4547 xdm: XDMCP problem with multihomes X servers (design error?) [UPSTREAM]
retitle 5212 xdm: allows login without valid shell [UPSTREAM]
retitle 5475 xdm: postinst starts xdm without asking
severity 5475 fixed
unmerge 5635
retitle 5635 xdm: cycles X server endlessly [UPSTREAM]
severity 5635 fixed
retitle 5734 xserver-common: default keymap was very wrong (GB)
severity 5734 fixed
retitle 5820 xbase-clients: xinit won't let me pass arguments to the server [UPSTREAM]
reassign 5820 xbase-clients
severity 5820 fixed
retitle 5897 xserver-mono: X server does not display text properly on Juko G8 (Hercules clone) card [UPSTREAM]
retitle 6400 xfs: coredumps when shut down due to xbase upgrade [UPSTREAM]
severity 6400 fixed
retitle 6405 xserver-common: default keymap was very wrong (DE)
severity 6405 fixed
merge 5734 6405
retitle 6468 xserver-common: X server goes crazy when switching back to its VC [UPSTREAM]
reassign 6468 xserver-common
retitle 6682 xbase-clients: sessreg should use glibc 2.1 utmp functions [UPSTREAM]
retitle 6734 xserver-common: hostname change causes X to refuse incoming connections [UPSTREAM]
retitle 6769 xserver-svga: X server goes bezerk at unpredictable times [UPSTREAM]
retitle 7058 xf86setup: XF86Setup can create unusable XF86Config [UPSTREAM]
retitle 7112 xterm: xterm is setuid root
retitle 7354 xlib6g-dev: xmkmf can generate bad Makefiles WRT variable substitution [UPSTREAM]
severity 7354 fixed
retitle 7370 xserver-s3v: X server hangs when using Netscape [UPSTREAM]
retitle 7553 xdm: init.d script doesn't always run
severity 7553 fixed
retitle 7554 xserver-w32: X server comes up with blank screen [UPSTREAM]
retitle 7886 emacs: Emacs doesn't know what to do with ISO_Left_Tab
reassign 7886 emacs
retitle 8931 xbase-clients: xrdb should magically know when whitespace is syntactically insignificant and strip it [UPSTREAM]
severity 8931 wishlist
retitle 9982 xserver-common: X server does not start if any host in font path is unreachable [UPSTREAM]
thanks

Notes to self:
#1690: can be closed, can...

Read more...

retitle 4547 xserver-common: X server should depend on X fonts
retitle 4757 xdm: XDMCP problem with multihomes X servers (design error?) [UPSTREAM]
retitle 8656 xterm: less, xterm, and kernel interact to wedge pty and thus wall [UPSTREAM]
thanks

--
G. Branden Robinson |
Debian GNU/Linux | If God had intended for man to go about
<email address hidden> | naked, we would have been born that way.
cartoon.ecn.purdue.edu/~branden/ |

retitle 10002 xbase-clients: sessreg doesn't set host entry in utmp [UPSTREAM] [PATCH]
retitle 10053 xserver-vga16: attempted to call XF86Setup before xlib6 was configured [FIXED]
severity 10053 fixed
retitle 10054 xf86setup: moving mouse while trying to configure it can cause problems [UPSTREAM]
retitle 10058 xf86setup: writes Clocks line to XF86Config for Cirrus Logic GD 5436 which the X server rejects [UPSTREAM]
retitle 10119 xserver-s3v: xtris creates artifacts in 16bpp mode [UPSTREAM]
retitle 10181 xterm: drops core with floating point exception [UPSTREAM]
retitle 10252 xf86setup: XF86Setup configured keyboard so that neither Alt is Meta [UPSTREAM]
retitle 10297 xserver-common: X servers can be configured without ever creating /etc/X11/Xsession [FIXED]
severity 10297 fixed
retitle 10440 xdm: upgrade kills running xdm [FIXED]
severity 10440 fixed
retitle 10445 xterm: using -e with -ls fails to open a login shell [UPSTREAM]
retitle 10469 xf86setup: tries to write configuration file in wrong place [FIXED]
severity 10469 fixed
retitle 10470 xserver-common: xf86config does not update /etc/X11/Xserver [FIXED]
severity 10470 fixed
retitle 10471 xserver-common: SecurityPolicy file not installed in right place [FIXED]
severity 10471 fixed
retitle 10487 xbase-clients: XFree86 3.2 mkfontdir doesn't understand gzipped font files [FIXED]
severity 10487 fixed
retitle 10507 xf86setup: XF86Setup looks for installed 75dpi font files [FIXED]
severity 10507 fixed
retitle 10548 xserver-common: X server should depend on X fonts
severity 10548 normal
merge 4547 10548
retitle 10550 xbase-clients: old mkfontdir corrupted fonts.dir files [FIXED]
severity 10550 fixed
merge 10487 10550
retitle 10688 xserver-common: XF86Config creation tools should edit /etc/X11/Xserver [FIXED]
reassign 10688 xserver-common
severity 10688 fixed
merge 10470 10688
retitle 10752 xserver-common: X server should put its lock file in /var/lock, not /tmp
merge 6013 10923
retitle 10964 xfs: restarting xfs with an X server connected causes the daemon to eat 100% of the CPU [UPSTREAM]
thanks

--
G. Branden Robinson | I've made up my mind. Don't try to
Debian GNU/Linux | confuse me with the facts.
<email address hidden> | -- Indiana Senator Earl Landgrebe
cartoon.ecn.purdue.edu/~branden/ |

There are lots of open "bugs" about this, so this is my final word on the
issue:

No, X servers should not depend on any font packages.

This is because any X server can be configured to use font services on a
remote host.

Please read the package descriptions of the xfonts-* packages and
xserver-common.

--
G. Branden Robinson |
Debian GNU/Linux | Mob rule isn't any prettier just because
<email address hidden> | you call your mob a government.
cartoon.ecn.purdue.edu/~branden/ |

Tuukka Hastrup (tuukkah) wrote :

Binary package hint: emacs23

Since the latest emacs upgrade in Karmic, the default font is now huge. The Set Default Font dialog claims the font is DejaVu Sans Mono Book 12, and in the preview, capital letters indeed are 12 pixels high. However, in the editor, capital letters are 14 pixels high and look bold. For comparison, capitals in the menu bar are the normal 10 pixels.

To get a sane editor font, I need to set the size to 8, resulting in 9 pixels - I cannot get the height of 10 pixels, as sizes like 8.5 result in the error "Font not available". xdpyinfo reports 118x119 dots per inch, and Gnome font settings are at font size 10, 96 dpi, subpixels, a little hinting.

ProblemType: Bug
Architecture: i386
Date: Wed Oct 7 15:21:40 2009
DistroRelease: Ubuntu 9.10
Package: emacs 23.1+1-4ubuntu1
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-12.39-generic
SourcePackage: emacs23
Uname: Linux 2.6.31-12-generic i686

Tuukka Hastrup (tuukkah) wrote :
Akkana Peck (akkzilla) wrote :

I saw this too; and in the same update, emacs also lost the ability to see this X font specifiers in xrdb:
Emacs*font: -misc-fixed-bold-r-normal-*-*-130-*-*-c-*-iso8859-15

I was able to get that font back by switching to this syntax:
Emacs.font: fixed-10:bold

Steve Magoun (smagoun) wrote :

This is apparently a problem w/ screen DPI.

More info here:
https://bugzilla.redhat.com/show_bug.cgi?id=517272

Patch here (backport from emacs git):
https://bugzilla.redhat.com/attachment.cgi?id=381561&action=diff

Changed in emacs23 (Ubuntu):
status: New → Confirmed
era (era) wrote :

The upstream bug report is at http://debbugs.gnu.org/cgi/bugreport.cgi?bug=4547

I can't seem to add it as a bug task; "Launchpad does not recognize the bug tracker at this URL."

Changed in emacs:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package emacs23 - 23.2+1-4ubuntu1

---------------
emacs23 (23.2+1-4ubuntu1) natty; urgency=low

  [ Michael W. Olson (GNU address) ]
  * Resync with Debian. Remaining changes:
  * debian/control.in:
    - Change Maintainer to Ubuntu Core Developers, per Ubuntu policy.
    - Conflict and Replace emacs23-common-non-dfsg, since we provide
      all of its features.
    - Do not suggest emacs23-common-non-dfsg.
    - Replace use of Source-Version with source:Version.
    - Require autotools-dev (>= 20100122.1) in Build-Depends, since
      the version in Karmic will fail due to a missing Perl module.
  * debian/control: Regenerate.
  * debian/copyright.in:
    - Remove text about removed files.
  * debian/copyright: Regenerate.
  * debian/emacsVER-common.postinst:
    - Don't install info files to info/dir. This happens
      automatically now.
  * debian/emacsVER-common.prerm:
    - Don't remove info files from info/dir. This happens
      automatically now.
  * debian/patches:
    - handle-dfsg-split.diff: Remove.
    - ubuntu-restore-nondfsg-files.diff: New patch that reintroduces
      the non-DFSG files, with the exception of .elc files and info
      files, which use special characters and thus can't be easily
      represented in patch form. These will be regenerated at build
      time.
  * debian/rules:
    - Do not install replacements for non-DFSG files.
    - Install all info files, not just efaq.
    - Avoid uselessly building info files a 2nd time.

  [ Reinhard Tartler ]
  * Reintegrate ubuntu history in debian/changelog
  * verified that debian/patches/fix-movemail-race.diff can be dropped,
    it is integrated in the new upstream version.
  * Rebuild against new debhelper to get trigger support: LP: #449729
  * New upstream version (LP: #588203) solves:
    - huge font sizes. LP: #445402
    - scroll bar in emacs highlights/selects text, LP: #581486
    - org and tbl menus are no longer missing in org-mode, LP: #640504
  * Add patch fix-ftbfs-xft-fontconfig.diff to avoid FTBFS.

emacs23 (23.2+1-4) unstable; urgency=low

  * Disable parallel builds (via DEB_BUILD_OPTIONS=parallel) until an
    upstream race condition is fixed. Thanks to Sven Joachim
    <email address hidden> for the report. (closes: #592992)

emacs23 (23.2+1-3) unstable; urgency=low

  * Don't try to "mkdir $(infodir)" in doc/*/Makefile.in. Thanks to
    Stéphane Glondu <email address hidden> for the 23.2+1-2.1 NMU.

  * Use -O1 rather than -O2 on ia64. Fixes a build failure (looks
    like a broken byte compiler) with newer versions of gcc
    (c.f. #207580). Thanks to Sven Joachim <email address hidden> for the
    report and thanks to Stéphane Glondu <email address hidden> for the
    23.2+1-2.1 NMU. (closes: #582439)

  * Remove deprecated Encoding field from emacsVER.desktop. Thanks to
    Stéphane Glondu <email address hidden> for the 23.2+1-2.1
    NMU.

  * Use "set -e" rather than "/bin/sh -e" in emacsVER-common.postinst
    and emacsVER-bin-common.postinst. Thanks to Stéphane Glondu
    <email address hidden> for the 23.2+1-2.1 NMU.

  * Add a Homepage field to debian/control.in. Thanks to Stéphane
    Glondu <email address hidden> for the ...

Read more...

Changed in emacs23 (Ubuntu):
status: Confirmed → Fix Released
Reinhard Tartler (siretart) wrote :

Is this something worth SRU'ing for maverick and lucid?

description: updated
Changed in emacs23 (Ubuntu Lucid):
assignee: nobody → Reinhard Tartler (siretart)

Accepted emacs23 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in emacs23 (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Rolf Leggewie (r0lf) wrote :

confirmed the problem in the lucid package and the fix in lucid-proposed

tags: added: verification-done
removed: verification-needed
Reinhard Tartler (siretart) wrote :

Archive admins, when accepting this SRU, please copy the source and binaries from lucid-proposed to maverick-proposed.

the emacs23 package wasn't touched during the maverick cycle and contains the lucid binary. This means that the lucid-proposed binary should work "as-is" in maverick-updates as well.

Changed in emacs23 (Ubuntu Maverick):
status: New → Triaged
Martin Pitt (pitti) wrote :

@Reinhard: sorry, I tried that, but soyuz won't let me because of a weird error message:

$ copy-package.py -bs lucid-proposed --to-suite maverick-proposed emacs23
[...]
2010-11-25 16:38:07 ERROR emacs23 23.1+1-4ubuntu7.1 in lucid (same version already building in the destination archive for Lucid)

I'm afraid this requires a proper upload.

Martin Pitt (pitti) wrote :

Accepted emacs23 into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in emacs23 (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Reinhard Tartler (siretart) wrote :

Martin, the package was verified successfully for both bugs for lucid. Can you please accept it for lucid-updates?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package emacs23 - 23.1+1-4ubuntu7.1

---------------
emacs23 (23.1+1-4ubuntu7.1) lucid-proposed; urgency=low

  * Read DPI from Xft and XSETTINGS to avoid displaying huge fonts.
    Patch backported from upstream by Redhat. LP: #445402
  * Don't install and remove info files into info/dir. This happens
    automatically now. Avoids confusing warning messages in packages
    that install elisp code and info files. Patch backported from
    natty. Fixes LP: #449729
 -- Reinhard Tartler <email address hidden> Fri, 19 Nov 2010 15:47:13 +0100

Changed in emacs23 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Releasing for lucid. Package hasn't been tested in maverick yet, so keeping v-needed.

Martin Pitt (pitti) wrote :

Any testers of the maverick-proposed package? As this has been in -proposed for a long time already, I'll remove the proposed package soon if there is no feedback. Thank you!

On Tue, Jan 25, 2011 at 10:29:43 (CET), Martin Pitt wrote:

> Any testers of the maverick-proposed package? As this has been in
> -proposed for a long time already, I'll remove the proposed package soon
> if there is no feedback. Thank you!

the package in the -release pocket is unchanged from lucid. I suggested
to just copy the package from lucid-proposed to maverick-proposed, but
this seems to be impossible for limitations in launchpad. AFAIUI the
lucid-proposed package was accepted and has no source changes to the
maverick-proposed package.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Fabri Velas (fabrivelas) wrote :

The maverick-proposed package seems to work here, I did not notice any regressions.

Martin Pitt (pitti) on 2011-02-08
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package emacs23 - 23.1+1-4ubuntu7.1+maverick1

---------------
emacs23 (23.1+1-4ubuntu7.1+maverick1) maverick-proposed; urgency=low

  * No-change upload to maverick.

emacs23 (23.1+1-4ubuntu7.1) lucid-proposed; urgency=low

  * Read DPI from Xft and XSETTINGS to avoid displaying huge fonts.
    Patch backported from upstream by Redhat. LP: #445402
  * Don't install and remove info files into info/dir. This happens
    automatically now. Avoids confusing warning messages in packages
    that install elisp code and info files. Patch backported from
    natty. Fixes LP: #449729
 -- Reinhard Tartler <email address hidden> Thu, 25 Nov 2010 18:07:20 +0100

Changed in emacs23 (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.