Merge emacs23 23.1+1-4 (universe) from Debian unstable (main).

Bug #408085 reported by Anders Kaseorg on 2009-08-02
54
This bug affects 4 people
Affects Status Importance Assigned to Milestone
emacs23 (Ubuntu)
Wishlist
Michael Olson

Bug Description

Please sync emacs23 23.1+1-3 (universe) from Debian unstable (main).

emacs23 is not in karmic yet. Changelog since emacs22:

emacs23 (23.1+1-3) unstable; urgency=low
 .
  * Fix overlooked manpage rename in emacsVER.postinst. Thanks to
    Sven Joachim <email address hidden>. (closes: #539926)
 .
  * Change emacsVER to be the GTK+ version to match the upstream
    default, and add an emacsVER-lucid package for those who still
    want the non-GTK+ version. Thanks to Romain Francoise
    <email address hidden> and others for the report.
    (closes: #539800)
 .
  * Don't build-depend on libgmp-dev on hurd or kfreebsd. Thanks to
    Cyril Brulebois <email address hidden>. (closes: #541353)
 .
  * Fix emacsVER.desktop to refer to SVG file instead of incorrect
    PNG, remove emacs22.png files from unversioned /usr/share/icons
    directory, and change emacs*.png and emacs*.svg files to
    emacsVER*.png and emacsVER*.svg. Also use update-alternatives to
    manage the unversioned names for these files. Thanks to Atsuhito
    KOHDA <email address hidden> for the initial
    report. (closes: #539851)
 .
  * Fix Rmail to handle capitalized month names in Date lines,
    i.e. "Date: Thu, 06 Aug 2009 18:33:32 +0100". Thanks to Jeroen
    Nijhof <email address hidden> for the report and Sven Joachim
    <email address hidden> for the fix. (closes: #540234)

emacs23 (23.1+1-2) unstable; urgency=low

  * Add dependencies on install-info to primary binary packages and
    remove install-info from meta package provides. Thanks to Norbert
    Preining <email address hidden>. (See emacs21 bugs #532600, #532599,
    #532597, and #532602.)

  * Add libpm-dev and libdbus-1-dev build dependencies. Thanks to
    Sven Joachim <email address hidden> for reporting this and most of the
    following additional issues.

  * Fix a spelling error, fix a menu section error, add a version to
    the GPL file referred to by debian/copyright, and add a number of
    debian/emacsVER*.lintian-overrides to quiet long-standing
    warnings.

  * Fix update-alternatives to reflect the fact that all the binaries
    have manpages now. Rename manpages from NAME.1FLAVOR to
    NAME.FLAVOR.1.

  * Remove obsolete dependencies and conflicts (w3-el, emacs22
    packages, etc.).

  * Remove explicit install-info calls. Rely on triggers now.

  * Set debian-emacs-flavor to 'emacs23. Somehow that change didn't
    make it in to the initial package and it was still set to emacs22.

  * Search /usr/share/info/emacs-23 rather than
    /usr/share/info/emacs-22.

 -- Rob Browning <email address hidden> Sun, 02 Aug 2009 19:55:15 -0700

emacs23 (23.1+1-1) unstable; urgency=low

  * New emacs23 packages.

  * The debian/dfsg-splitter has been updated.

  * Patches have been removed or adjusted.

 -- Rob Browning <email address hidden> Sat, 18 Jul 2009 18:41:25 -0700

Anders Kaseorg (andersk) wrote :

I don’t know whether this is how the Ubuntu maintainers want to handle this, but I didn’t see any open bugs about emacs23, and a sync from Debian seems like a reasonable starting point. There’s a test build of the Debian package in my PPA for Karmic, and it works fine as far as I can tell:
<https://launchpad.net/~anders-kaseorg/+archive/ppa>

Changed in ubuntu:
importance: Undecided → Wishlist
Stefan Lesicnik (stefanlsd) wrote :

Seems like a good step for now. The package builds in my karmic pbuilder.

Sync ack from me.

This builds a package in main (emacs), so requires a main sponsor.

Reinhard Tartler (siretart) wrote :

discussion from the ubuntu-elisp team:

http://<email address hidden>/msg00013.html

Reinhard Tartler (siretart) wrote :

best would probably be not a plain sync, but a hard dependency on the non-dfsg-free docs (they are fsf-free)

Martin Pitt (pitti) wrote :

> best would probably be not a plain sync, but a hard dependency on the non-dfsg-free docs (they are fsf-free)

OK, please upload a merge instead then.

Anyway, this would essentially mean to switch emacs in karmic from 22 to 23, since it builds the new metapackage, no? This means a Feature freeze exception now.

Updated from duplicate; sorry I didn't notice before that the other bug was for a newer version.

description: updated
summary: - Sync emacs23 23.1+1-1 (universe) from Debian unstable (main).
+ Sync emacs23 23.1+1-2 (universe) from Debian unstable (main).
Daniel Holbach (dholbach) wrote :

I'll unsubscribe the sponsors team for now. Please follow https://wiki.ubuntu.com/FreezeExceptionProcess and prepare the merge, then resubscribe.

era (era) on 2009-09-04
description: updated
summary: - Sync emacs23 23.1+1-2 (universe) from Debian unstable (main).
+ Sync emacs23 23.1+1-3 (universe) from Debian unstable (main).

I'm going to attempt to modify the 23.1+1-4 package so that it does not remove non-DFSG files, for my own personal use, and see where that gets me. I can't promise a particular deadline for this.

Michael Olson (mwolson) wrote :

I've got a proof-of-concept uploaded to the ubuntu-elisp ppa for jaunty. It's not quite ready for inclusion yet. I still need to build for karmic and review the patches in emacs22. The good news about this emacs23 build is that it is based off of the Debian packaging for emacs23, so it should be easier to maintain.

https://launchpad.net/~ubuntu-elisp/+archive/ppa

Changed in ubuntu:
assignee: nobody → Michael Olson (mwolson)
status: New → In Progress
Michael Olson (mwolson) wrote :

A new PPA version 2 package is available for emacs23 which contains the result of the patch review for emacs22. All that's needed now is a text file in debian/ explaining the steps to take for new upstream versions.

If anyone subscribed to the bug is interested in trying out the PPA version and reporting any issues they come across, now would be a good time.

summary: - Sync emacs23 23.1+1-3 (universe) from Debian unstable (main).
+ Merge emacs23 23.1+1-4 (universe) from Debian unstable (main).
Alex Murray (alexmurray) wrote :

Have only done minor testing of emacs23 ppa version (karmic) but seems good so far, no issues encountered so far.

Smeuuh (smeuuh) wrote :

Same here, great to see we'll have emacs23 in karmic. Auctex and possibly other packages only depend on emacs21|22|snapshot though, should they be changed ?

Alex Murray (alexmurray) wrote :

Hmm, yep trying to install auctex wants to install emacs22-bin-common and emacs-snapshot amongst others even with emacs (23) installed from elisp ppa. This is a shame indeed.

Michael Olson (mwolson) wrote :

List any misbehaving packages (like Auctex) that you come across and I'll upload fixed versions to the PPA.

Smeuuh (smeuuh) wrote :

apt-cache showpkg emacs22, which lists reverse dependencies on emacs22, gives a pretty long list (nearly 30 entries). Some of them (yasnippet, ) depend on emacs22|emacsen. Maybe you could provide a package emacsen, or whatever the apt way of doing things is. It doesn't seem reuploading all the packages is the correct way to solve this.

Auctex needs at least these files fixed:
/usr/lib/emacsen-common/packages/install/auctex
/usr/lib/emacsen-common/packages/remove/auctex
(look for line: case "${FLAVOR}" in)

/usr/sbin/update-auctex-install
/usr/sbin/update-auctex-elisp
(look for line: FLAVORS=)

Also
/etc/emacs23/site-start.d/50auctex.el
is missing (while /etc/emacs{21,22,-snapshot}/site-start.d/50auctex.el is
present)

I've looked at its source package, but debian directory is quite a mess (at
least I would expect that there is a single place which lists all supported
emacs flavors...)

Michael Olson (mwolson) wrote :

Reuploading dependent Emacs Lisp packages is about the only option available to us. A lot of times they will want to express a dependency like: install this particular set of files in Emacs 22, and a slightly different set in Emacs 23, since Emacs 23 now includes such and such files, and we don't want to supersede the Emacs 23 versions. So it really is case-by-case. Debian does this as well.

ilia (ilia) wrote :

psgml package needs update too. At least
/usr/lib/emacsen-common/packages/{install,remove}/psgml files (the same
"case $FLAVOUR in" blocks).

doclist (dclist) wrote :

I'm having various problems with ido. I guess there is conflict with the old version provided with emacs-goodies-el

Dan Ports (drkp) wrote :

I've also run into the auctex package's incompatibility with emacs23. Fortunately, auctex 11.85-1 from Debian unstable builds and appears to work fine with the emacs23 packages from the PPA.

Anders Kaseorg (andersk) wrote :

emacs23 23.1+1-4ubuntu1 is in Karmic now.

affects: ubuntu → emacs23 (Ubuntu)
Changed in emacs23 (Ubuntu):
status: In Progress → Fix Released
David Ayers (ayers) wrote :

Version: 23.1+1-4ubuntu1

If I use update-alternatives --config editor to set emacs as my editor I get:
update-alternatives: warning: skip creation of /usr/share/man/man1/editor.1.gz because associated file /usr/share/man/man1/emacs.1emacs23.1.gz (of link group editor) doesn't exist.

and indeed the file is currently named:
/usr/share/man/man1/emacs.emacs23.1.gz

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers