Emacs 'Ediff' Window Shrinks Horizontally To One Column Wide

Bug #1059633 reported by Craig on 2012-10-01
112
This bug affects 24 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Raring
Undecided
Unassigned
emacs23 (Ubuntu)
Low
Unassigned
Precise
Medium
Unassigned
Raring
Low
Unassigned
emacs24 (Ubuntu)
Low
Unassigned
Precise
Undecided
Unassigned
Raring
Low
Unassigned

Bug Description

[Impact]
Emacs users can't access the help screen for the ediff tool.

[Test case]
(For non emacsy people)

Run emacs in a graphical environment
Menu option: Tools->Compare->Two Buffers
ENTER and ENTER to the two questions prompted

A new window, 'Ediff', opens and contains the text "Type ? for help"
In the 'Ediff' window, type the character '?', This is supposed to display helpful info on the ediff commands

If broken:
  Ediff window will expand, then shrink horizontally to one character wide
  Grabbing the frame and resizing will cause the shrinking behavior to repeat
If fixed:
  Ediff window will expand and show the contents of the help

[Regression potential]
It could be that some other graphical environment relies on the bug being present, working around it in a way that if it's not present anymore, the window resizing will break there. The current patch is tested for Unity and Cinnamon, and has been taken from the fix already applied upstream.

[Original description]
Unlike previously reported bug #941790, this bug involves a horizontal shrinkage to one column wide (multiple rows), and is still present in GNU Emacs 23.3.1. Resizing the window isn't a work-around, as the window immediately shrinks again. The behavior is observed as follows:

Run ediff-buffers
A new window, 'Ediff', opens and contains the text "Type ? for hlep"
In the 'Ediff' window, type the character '?', This is supposed to display helpful info on the ediff commands
Ediff window will expand, then shrink horizontally to one character wide
Grabbing the frame and reszing will cause the shrinking behavior to repeat

Releveant packages / versions:
Ubuntu 12.04.1 LTS
GNU Emacs 23.3.1
Unity 5.16.0-0ubuntu1

Craig (craig-st) on 2012-10-01
affects: unity (Ubuntu) → emacs23 (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in emacs23 (Ubuntu):
status: New → Confirmed
Edward Donovan (edward.donovan) wrote :

I've also seen this Ediff window problem, under Emacs 24, on Quantal.

tags: added: precise quantal
Changed in emacs24 (Ubuntu):
status: New → Confirmed
Edward Donovan (edward.donovan) wrote :

And it may be that this is compiz's bug, not emacs'. I don't really know, yet, but I guess I'm going to add compiz to the bug. Thanks.

summary: - Emacs Window Shrinks Horizontally To One Column Wide
+ Emacs 'Ediff' Window Shrinks Horizontally To One Column Wide
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Ian Hutchinson (hutch) wrote :

Happens to me too. Is there any work around that folks have found? It's horrible to have ediff broken.

Ian Hutchinson (hutch) wrote :

Only way I've found to run ediff is to run a text emacs: $ emacs -nw and Meta-x ediff from that.

JonHurst (jon-a-hursts) wrote :

Bug apparent in standard Unity environment, but not in Gnome Classic or Unity 2D environments.

Øyvind Stegard (oyvinst) wrote :

Confirmed for Emacs 24.2 (compiled from vanilla source, using GTK3), Ubuntu 12.10, Unity.

This bug is likely related to bug 941790, but that bug is about rows shrinking instead of cols, like in this case.

Emacs emits the following GTK-warning when ediff window pops up:
(emacs:8955): Gtk-WARNING **: gtk_window_parse_geometry() called on a window with no visible children; the window should be set up before gtk_window_parse_geometry() is called.

Øyvind Stegard (oyvinst) wrote :

The patch applied for bug 941790 needs to be extended for columns/width as well. That should fix this bug. See upstream patch at http://lists.gnu.org/archive/html/emacs-diffs/2012-08/msg00522.html which does exactly that.

Workaround I use:
after starting ediff-buffers, or ediff-files, for example:
1) ctrl-alt-num pad 5 -- this maximizes the small ediff window to whole screen; it contains text 'type ? for help'
2) type ? -- this brings up the help text; this window still fills up whole screen
3) type ? -- this minimizes ediff window; on my system, this little ediff window is not visible at all now
4) proceed w/ ediff session -- ediff responds as though commands were typed into little ediff window even though it is not visible. Typing ? again brings up help text in a window that fills whole screen, then type ? again to make it go away.
*Note* if, in the middle of ediff session, user switches to different window, by using alt-tab for instance, then comes back to emacs, the focus will no longer be in the small ediff window, but in the emacs frame itself.

Using:
GNU Emacs 23.3.1 (i686-pc-linux-gnu, GTK+ Version 2.24.10)
Ubuntu 12.04 LTS
unity 5.18.0-0ubuntu2

Margarita Manterola (marga-9) wrote :

Hi,

I have taken the patch pointed at in http://lists.gnu.org/archive/html/emacs-diffs/2012-08/msg00522.html and adapted it to Precise's emacs23 version. I have tested this build and it correctly fixes the issue.

The attachment "Debdiff of the fixed package for precise" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Changed in emacs23 (Ubuntu):
importance: Undecided → Medium
Changed in emacs24 (Ubuntu):
importance: Undecided → Low
Changed in emacs24 (Ubuntu Precise):
status: New → Invalid
Changed in emacs23 (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Medium
Changed in emacs23 (Ubuntu Raring):
importance: Medium → Low
Changed in compiz (Ubuntu Precise):
status: New → Invalid
Dimitri John Ledkov (xnox) wrote :

emacs24/raring uploaded.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package emacs24 - 24.2+1-2ubuntu2

---------------
emacs24 (24.2+1-2ubuntu2) raring; urgency=low

  * Fix 'Ediff' window shrinks horizontally to one column wide (LP:
    #1059633) Thanks marga-9 for the patch.
 -- Dmitrijs Ledkovs <email address hidden> Tue, 09 Apr 2013 10:32:32 +0100

Changed in emacs24 (Ubuntu Raring):
status: Confirmed → Fix Released
Margarita Manterola (marga-9) wrote :

HI Dimitijs,

Thanks for your work for raring. Do you think this is worth an SRU or not? I'd like to see this fixed in precise, but I'm unsure if others think it's worth it.

Cheers!

Sebastien Bacher (seb128) wrote :

@Marga: that seems a fix worth a SRU for the LTS, there are quite some hackers using emacs and several who found that bug report.

I will sponsor your precise diff, could you add the SRU infos to the bug? (impact, test case, regression potential)?

Should we fix emacs23 in raring as well?

Changed in emacs23 (Ubuntu Precise):
status: Confirmed → In Progress
Dimitri John Ledkov (xnox) wrote :

@seb128 thanks for the precise sponsoring. Ideally we should be fixing emacs23 in quantal/raring. I am anticipating that emacs24 will be default early in s-cycle, hence I started the fix from there.

Usually I do not upload packages into unapproved-queue, if SRU info is missing, because it's a waste of SRU team's time, they just reject packages that don't have SRU info filled out on the bug report.

Brian Murray (brian-murray) wrote :

The test case from seems pretty straight forward from the description but a regression potential statement would be helpful.

Margarita Manterola (marga-9) wrote :

Hi,

I have updated the testcase since not being an emacs user myself, it wasn't straight forward to me. I have also given some thought to the regression potential part. Given that the change is about how the window size is calculated, the only regression I can think of is some other desktop environment relying on this bug for their calculations (i.e. special casing emacs somehow), but I find this very unlikely.

I'd be glad if this could be pushed to Precise.

--
Regards,
Marga

description: updated

Hello Craig, or anyone else affected,

Accepted emacs23 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/emacs23/23.3+1-1ubuntu9.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in emacs23 (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
J.Pasat (justxux) wrote :

I installed package without -proposed and the issue appears but after installing the same thing with -proposed updates it works fine issue disappeared, thanks a lot! ( Ubuntu 12.04.2, Unity )

Changed in emacs23 (Ubuntu Precise):
assignee: nobody → Skini151 (skini151)
assignee: Skini151 (skini151) → nobody
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package emacs23 - 23.3+1-1ubuntu9.2

---------------
emacs23 (23.3+1-1ubuntu9.2) precise; urgency=low

  * Apply patch to fix column shrinkage in ediff, taken from:
    http://lists.gnu.org/archive/html/emacs-diffs/2012-08/msg00522.html
    (LP: #1059633)
 -- Margarita Manterola <email address hidden> Fri, 05 Apr 2013 16:07:00 +0200

Changed in emacs23 (Ubuntu Precise):
status: Fix Committed → Fix Released
Jan-Åke Larsson (jalar) wrote :

Bug is still present in 23.4+1-4ubuntu1 in raring ringtail. Please release fix for that too.

Kasim Tasdemir (kasimtasdemir) wrote :

The problem still persists for me. I use Ubuntu 14.04 (development branch) + emacs 23 . More precisely:
GNU Emacs 23.4.1 (i686-pc-linux-gnu, GTK+ Version 2.24.21) of 2013-10-25 on akateko, modified by Debian

On Dec 18, 2013, at 10:07 AM, Kasim Tasdemir wrote:

>The problem still persists for me. I use Ubuntu 14.04 (development branch) +
>emacs 23 . More precisely: GNU Emacs 23.4.1 (i686-pc-linux-gnu, GTK+ Version
>2.24.21) of 2013-10-25 on akateko, modified by Debian

You might consider upgrading to Emacs 24.3.

Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in emacs23 (Ubuntu Raring):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers