FFe for emacs23

Bug #433397 reported by Matthias Klose on 2009-09-20
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
emacs22 (Ubuntu)
High
Steve Langasek
Karmic
High
Steve Langasek
emacs23 (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: dpkg

please consider syncing emacs23 for karmic (unstable -> universe). emacs22 is two minor versions old, and at this point of the release cycle it might be easier to introduce a new package in universe than updating the emacs22 package.

Matthias Klose (doko) on 2009-09-20
affects: dpkg (Ubuntu) → emacs22 (Ubuntu)
StefanPotyra (sistpoty) wrote :

Hm... then we'd end up with a 3rd version of emacs in universe, as there's also emacs-snaphost. Romain, what's your opinion?

StefanPotyra (sistpoty) wrote :

(subscribing siretart as another source for information).

Just to make it clear, I'm not opposing to get a newer emacs in in general (even though I'm a vi user :P). What's the state of emacs-snapshot right now? Is emacs23 newer? Should we drop emacs-snapshot (and rdepends) in favour of emacs23 or should we go the other way round and update emacs-snapshot to emacs23? Or does it make sense to have 3 versions around for karmic?

StefanPotyra <email address hidden> writes:

> (subscribing siretart as another source for information).
>
> Just to make it clear, I'm not opposing to get a newer emacs in in
> general (even though I'm a vi user :P). What's the state of emacs-
> snapshot right now? Is emacs23 newer? Should we drop emacs-snapshot (and
> rdepends) in favour of emacs23 or should we go the other way round and
> update emacs-snapshot to emacs23? Or does it make sense to have 3
> versions around for karmic?

emacs-snapshot remains to track the HEAD branch and is updated every 2-3
weeks in Romains repository. He updates it in his private debian repo,
and also uploads to the ubuntu-elisp PPA. We can argue that we should
provide emacs-snapshot only from the ~elisp PPA, though.

As for the released versions of emacs, I really think we should go with
emacs22 and emacs23. Having emacs-snapshot wouldn't hurt IMO. We do the
same with gcc-snapshot after all.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

StefanPotyra (sistpoty) wrote :

Ok, thanks, fair enough, +1 from me to get emacs23 in.

Nonetheless, the last upload of emacs-snapshot to ubuntu proper was during jaunty. I guess we should either update this from Romains repository or remove it. Do you agree?

Scott Kitterman (kitterman) wrote :

Ack from me too. Approved.

Changed in emacs22 (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Jamie Strandboge (jdstrand) wrote :
Changed in emacs22 (Ubuntu):
status: Confirmed → Fix Released
Reuben Thomas (rrt) wrote :

Thanks very much for this, folks.

Steve Langasek (vorlon) wrote :

This merge has stolen the 'emacs' binary package from emacs22, and now emacs depends on emacs23 and is uninstallable in main. This needs to be fixed.

Changed in emacs22 (Ubuntu):
importance: Wishlist → High
status: Fix Released → Triaged
Steve Langasek (vorlon) wrote :

fixing emacs22 now. emacs23 also needs reuploaded to stop building emacs.

Changed in emacs23 (Ubuntu Karmic):
importance: Undecided → High
status: New → Triaged
Changed in emacs22 (Ubuntu Karmic):
status: Triaged → In Progress
assignee: nobody → Steve Langasek (vorlon)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package emacs22 - 22.2-0ubuntu5

---------------
emacs22 (22.2-0ubuntu5) karmic; urgency=low

  * Claim back the 'emacs' binary package, which was incorrectly moved to
    emacs23 in a post-beta merge. LP: #433397.

 -- Steve Langasek <email address hidden> Sun, 11 Oct 2009 19:40:32 +0000

Changed in emacs22 (Ubuntu Karmic):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package emacs23 - 23.1+1-4ubuntu2

---------------
emacs23 (23.1+1-4ubuntu2) karmic; urgency=low

  * Stop shipping emacs binary so emacs22 in main doesn't get hijacked
    (LP: #433397)
    - Comment out the binary in debian/control

 -- Scott Kitterman <email address hidden> Sun, 11 Oct 2009 23:22:39 -0400

Changed in emacs23 (Ubuntu Karmic):
status: Triaged → Fix Released
Jamie Lokier (jamie-shareable) wrote :

Ouch, that was a surprise.

I've been using Karmic with the "emacs" package and therefore emacs23 for a few weeks, without significant problems (just Emacs quirks which I hope will be tidied up in time).

Today, update-manager tried to install emacs22, which I didn't want.

I appreciate that emacs23 isn't in main, and emacs of course must be. (Since I include universe I hadn't noticed any problems, and just assumed emacs23 was the version to be used in Karmic.)

Nonetheless, the surprise installation of emacs22 was undesired.

Is it possible to have the "emacs" package depend on emacs22 OR emacs23, and prefer emacs22 if neither is installed already, to avoid this?

Steve Langasek (vorlon) wrote :

On Thu, Oct 15, 2009 at 06:02:08PM -0000, Jamie Lokier wrote:
> Is it possible to have the "emacs" package depend on emacs22 OR emacs23,
> and prefer emacs22 if neither is installed already, to avoid this?

No, that's contrary to the purpose of the 'emacs' package. If you want
emacs23 and not emacs22, then uninstall the 'emacs' package.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

era (era) wrote :

Pardon a stupid question, but what would it take to get emacs23 in main? Installing the old version is likely to seem like overtly cautious in the eyes of some users.

Reinhard Tartler (siretart) wrote :

era <email address hidden> writes:

> Pardon a stupid question, but what would it take to get emacs23 in main?
> Installing the old version is likely to seem like overtly cautious in
> the eyes of some users.

17:23 <siretart`> @ftpmasters: will emacs23 be semi-"automatically"
                  be promoted to main and emacs22 demoted to universe
                  during the usual archive cleanups, or is a full MIR
                  report required for this?
17:23 <pitti> siretart`: no full MIR necessary, it's by and large
              just a new version
17:23 <pitti> if we can promote/demote at the same time, it will
              pretty much "just happen"

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers