xorg.conf has wrong font paths, resulting in failure to find some fonts

Bug #57803 reported by Prashanth on 2006-08-26
14
Affects Status Importance Assigned to Milestone
vino
Invalid
Undecided
Unassigned
emacs21 (Ubuntu)
Undecided
Unassigned
xfontsel (Ubuntu)
Undecided
Unassigned
xorg (Ubuntu)
Low
Unassigned
xpdf (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: emacs

I just dist-upgraded from dapper to edgy. Now when i start emacs in X mode, It does not display fonts. It only shows boxes.

Emacs runs fine when i start with the `-nw' switch.

It gives me this error when i run emacs
~$ emacs
Warning: Cannot convert string "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Cannot convert string "-*-helvetica-medium-r-*--*-120-*-*-*-*-iso8859-1" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Unable to load any usable ISO8859 font

I have also tried removing my ~/.emacs file. The problem still persists.

Nicholas Tollervey (ntoll) wrote :

Happens with the default Xubuntu install.

Robin Sonefors (ozamosi) wrote :

I have this as well. Including a screen shot. It does not happen with XEmacs.

I resolved this changing font path in xorg.conf in agreement to real font path:

old version

Section "Files"
        # paths to defoma fonts
        FontPath "/usr/share/X11/fonts/misc"
        FontPath "/usr/share/X11/fonts/cyrillic"
        FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath "/usr/share/X11/fonts/Type1"
        FontPath "/usr/share/X11/fonts/CID"
        FontPath "/usr/share/X11/fonts/100dpi"
        FontPath "/usr/share/X11/fonts/75dpi"
        FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

corrected version

Section "Files"
        # paths to defoma fonts
        FontPath "/usr/share/fonts/X11/misc"
        FontPath "/usr/share/fonts/X11/cyrillic"
        FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath "/usr/share/fonts/X11/Type1"
        FontPath "/usr/share/fonts/X11/CID"
        FontPath "/usr/share/fonts/X11/100dpi"
        FontPath "/usr/share/fonts/X11/75dpi"
        FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

sorry for my bad english

Robin Sonefors (ozamosi) wrote :

I have the same thing in my xorg.conf, but it does not fix it for me.

Prashanth (prashmohan) wrote :

It fixed it for me. I also happened to run update-fonts-alias, update-fonts-dir and update-fonts-scale and then restarted X.

It *did not* resolve until i restarted X.

However this font path updating should be made automatic (this is only a temporary work around). Hence not closing the Bug

Martin Emrich (emme) wrote :

Fixing the font paths solved it for me, too. I did not have to do anything else (update-fonts-* or so), just fix the paths and restart X.

I agree that this should either be fixed in a postinst script, or the user should be notified how to fix it if the configuration was customized.

Ciao

Martin

sardion (ubuntu-sardion) wrote :

FWIW, after fixing the FontPath stuff, I ran dpkg-reconfigure -phigh xserver-xorg (to attempt to keep that file updating) and it reverted to broken paths.

sardion (ubuntu-sardion) wrote :

Marked this as affecting xorg.

The same error results when running e.g. xpdf, xnview and probably a lot more.

Snark (julien-puydt) wrote :

Same problem here. I came here to report, and I'm pretty happy to see it is already there :-)

I'm quite surprised the bug is still marked "unconfirmed", though.

Snark (julien-puydt) wrote :

After today's update, emacs in X works again!

Thanks!

Rob Wilco (rob.wilco) wrote :

Emacs works OK with the standard police but you cannot choose Bistream Vera or Dejavu police. xlsfonts does not see them either.

I did the "X11/fonts" - "fonts/X11" dance with the /etc/X11/xorg.conf though, and restarted X but xlsfonts and emacs can't still load the dejavu police.

Seems that this persists still with up to date Dapper to Edgy upgrade. I had to revert paths to get this fixed.

Thomas Schwinge (tschwinge) wrote :

I've also been bitten by this. My Emacs, however, didn't show boxes instead of fonts, but showed ugly, unreadable non-anti-aliased micro fonts.

I also changed the paths in `/etc/X11/xorg.conf' by hand and can also confirm that reconfiguring via ``dpkg-reconfigure -phigh xserver-xorg'' will rewrite the file with the erroneous paths.

Kieran Hogg (xerosis) wrote :

Still affected in Feisty.

Jonh Wendell (wendell) wrote :

Why is vino here?

Changed in vino:
status: Unconfirmed → Rejected

for me a
  sudo apt-get install xfonts-100dpi
fixed the problem.

Micah Cowan (micahcowan) wrote :

Closing the bug against emacs, as despite the fact that the bug's symptoms are visible in emacs, it does not appear to be an emacs bug per se.

Changed in emacs21:
status: Unconfirmed → Rejected
Micah Cowan (micahcowan) wrote :

Please don't just assign this bug to every package that happens to exhibit the problem: that doesn't mean that the bug can be fixed in that package.
The problem is with xorg, or with font packages.

Changed in xpdf:
status: Unconfirmed → Rejected
Changed in xfontsel:
status: Unconfirmed → Rejected
Micah Cowan (micahcowan) wrote :

For those of you having issues with this: do you have the gsfonts package installed?

Also, Leonardo's "old version/corrected version" examples look identical to me. Can someone correct that, so we can see what's going wrong there?

Changed in xorg:
assignee: nobody → micahcowan
importance: Undecided → Low
status: Unconfirmed → Needs Info
Robert McWilliam (rmcw) wrote :

The path to the fonts was wrong: old version had "...X11/fonts..." New version "...fonts/X11..."

Micah Cowan (micahcowan) wrote :

Oddly, my xorg.conf does indeed have that (they are empty); and yet the correct fonts are still being seen.

Micah Cowan (micahcowan) on 2007-06-20
Changed in xorg:
assignee: micahcowan → nobody
status: Needs Info → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers