(21.4a-6ubuntu1): Unexpected crash when closing a text buffer

Bug #56782 reported by David Marín on 2006-08-18
6
Affects Status Importance Assigned to Milestone
emacs21 (Ubuntu)
High
Tollef Fog Heen

Bug Description

I was about to close a buffer and... crash!

David Marín (davefx) wrote :
Ondřej Surý (ondrej) wrote :

I can confirm that, adding another crash report, emacs crashes with signal 11 on exit (^x^c).

Tollef Fog Heen (tfheen) wrote :

We need this fixed for edgy and I can reproduce it.

Changed in emacs21:
assignee: nobody → tfheen
importance: Untriaged → High
status: Unconfirmed → Confirmed
Tollef Fog Heen (tfheen) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 15 Sep 2006 09:56:31 +0200
Source: emacs21
Binary: emacs21-el emacs21-common emacs21-nox emacs21-bin-common emacs21
Architecture: source
Version: 21.4a-6ubuntu2
Distribution: edgy
Urgency: low
Maintainer: Rob Browning <email address hidden>
Changed-By: Tollef Fog Heen <email address hidden>
Description:
 emacs21 - The GNU Emacs editor
 emacs21-bin-common - The GNU Emacs editor's shared, architecture dependent files
 emacs21-common - The GNU Emacs editor's shared, architecture independent infrastru
 emacs21-el - GNU Emacs LISP (.el) files
 emacs21-nox - The GNU Emacs editor (without X support)
Changes:
 emacs21 (21.4a-6ubuntu2) edgy; urgency=low
 .
   * Add -fno-stack-protector to CFLAGS to stop crashing so much.
     Malone: #56782
Files:
 21ec5eaa278137c482348920f5bea3f3 992 editors optional emacs21_21.4a-6ubuntu2.dsc
 633750f936d5c4c101147de49d6afc1b 150527 editors optional emacs21_21.4a-6ubuntu2.diff.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iQCVAwUBRQpc1scmO3YsB1PjAQITVAQAhKBjiQbM9vdSuyAp7xkAM5Q9xs7UqPDB
7n17Zj68X2PM+iKSjLaKFUwtd9qOya3Nf5Hr6kUEAzDosapW46nMMd0Ix3wLWBm9
zIqur+onKWb3E29pMciJ8Tp0nZVQe2v+VBgh9/8ZXva2wCqtcCYQTz8qTITHa2wQ
+TfyvfC96EY=
=222Y
-----END PGP SIGNATURE-----

Changed in emacs21:
status: Confirmed → Fix Released
Dave Love (fx-gnu) wrote :

I've just started seeing continual crashes of Emacs,
but 21.4a-6ubuntu2 doesn't fix them. I'm building
a debug version now to try to fix it, but can you
tell me what this undocumented -fno-stack-protector flag does, and what you think
the problem is? Is it due to a kernel change
like the Redhat stuff that was never adequately
explained? I ask because I'm probably as expert
as anyone on Emacs dumping and allocation and
I need to restore a working Emacs quickly, so
I'll work on sorting it out.

I'm not seeing the same problem on my edgy
laptop as I am on a very similar system on my
desktop. Also, Emacs is unusable under X in edgy
anyway without fixing the font paths per my
patch under #63408, sigh...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers