Wishlist: Xft/Freetype support

Bug #68461 reported by Rthaduthd Anthnhkrc on 2006-10-26
32
Affects Status Importance Assigned to Milestone
emacs-snapshot (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: emacs-snapshot-gtk

OK, I've got this brand new Edgy installed today - everything is looking great; but starting Emacs ruins the whole thing.

The fonts sucks guys -- this is 2006 -- this is Edgy; and Emacs is a great editor feature-wise but it looks like crap without fonts.

I do not know how to create .deb-packages or update `emacs-snapshot-gtk' - but I've compiled Emacs from a CVS-branch and got the thing running. It looks great!

This is what I did (after removing any previously installed Emacs):

sudo aptitude install libxt-dev libgtk2.0-dev texinfo build-essential
..
cvs -z3 -d:pserver:<email address hidden>:/cvsroot/emacs co emacs
cd emacs
cvs up -Pd -r XFT_JHD_BRANCH
./configure --with-x-toolkit=gtk --with-xft=yes
make bootstrap && make
make install

..this installs the thing into /usr/local

however; trying to install things like `dictem' using `aptitude' will not work correctly now of course.

I guess this is more of a request-for-feature than a bug. :)

H m - the emacs-wiki mentions that the `emacs-unicode-2'-branch .. maybe this branch is in some way newer/better than the one I've used above?

http://www.emacswiki.org/cgi-bin/wiki/XftGnuEmacs

Ok,
Tried the never branch/patch `emacs-unicode-2':

cvs -z3 -d:pserver:<email address hidden>:/cvsroot/emacs co -r
emacs-unicode-2 emacs
cd emacs
./configure --enable-font-backend --with-xft --with-freetype --with-gtk
make bootstrap && make
sudo make install

Much better result; here is a screenshot:
http://nostdal.org/~lars/emacs-gtk-xft.png

oh - and here's how I start emacs:

emacs --enable-font-backend --font "Bitstream Vera Sans Mono-10"

(there doesn't seem to be a way to select these fonts while in Emacs yet)

 importance wishlist

Changed in emacs-snapshot:
importance: Undecided → Wishlist
Patrick J. LoPresti (lopresti) wrote :

A kind Ubuntu hacker in India has made Xft versions of emacs-snapshot packages available via apt:

http://g33k.wordpress.com/2006/11/06/gnu-emacs-with-xft-goodness/

The difference in fonts is like night and day.

I agree with Hans. You can label this "importance wishlist"... But seriously, every time I start Emacs I have to double-check the calendar to remind myself what year it is. And it can be fixed just by rebuilding emacs-snapshot with Xft support enabled. Pretty please?

Romain Francoise (rfrancoise) wrote :

You are preaching to the choir... but emacs-snapshot will support
Xft/Freetype when the emacs-unicode branch is merged in mainline,
not before.

Sorry.

Patrick J. LoPresti (lopresti) wrote :

This may be a stupid question but... Why?

I mean, the only reason I tried installing an obscure package called "emacs-snapshot" was to see if the font rendering had progressed beyond 1995. What other purpose could "emacs-snapshot" possibly have? :-)

More seriously, with a name ending in "-snapshot", what difference does it make whether it is built from the trunk or from a branch? Anybody who installs such a package is trying to trade stability for features anyway, right? Otherwise, they can just use the "emacs" package.

If this is the choir, to whom should I be preaching?

(Sorry if I am being obnoxious, but I upgraded to Feisty and now my Emacs looks like crap again. Annoying.)

Yang Zhao (zhyang11) wrote :

Now that emacs 22 has been released, should emacs-snapshot track the unicode branch? It will become emacs 23 in the future.

Reinhard Tartler (siretart) wrote :

I just checked the buildlog for current emacs-snapshot package: https://launchpad.net/ubuntu/+source/emacs-snapshot/1:20070805-1ubuntu1/+build/374110
According to the buildlog, emacs-snapshot detects the presence of libxft2-dev and uses that.

Changed in emacs-snapshot:
status: New → Fix Released
pliz (pliz) wrote :

How do I enable it? I have emacs-snapshot 20070805 installed and when I run:
emacs-snapshot-gtk
I get:
No fonts match `Monospace-10'

Previously before this package has overwritten my antialias-working version from http://peadrop.com/blog/2007/01/06/pretty-emacs
Everything worked fine.

So I assume the current snapshot still does not support antialiasing :(

Reinhard Tartler (siretart) wrote :

sorry, mwolson cleared this with romain:

From: Romain Francoise <email address hidden>
Subject: Re: [Will Farrington] [Bug 131206] emacs-snapshot should be compiled with xfont support enabled
Michael Olson <email address hidden> writes:

> Romain, is it true that emacs-snapshot used to be build with Xft
> support? (I assume that's what the reporter means when he says
> "antialiasing".) I'm pretty sure that isn't the case, but I
> thought I'd double-check before replying.

Nope, it's not true; the Xft code is not and has never been in
mainline. Some third-party 'emacs-snapshot' packages taken from the
XFT_JHD_BRANCH and later from the emacs-unicode-2 branch have
appeared here and there, but Ubuntu's official emacs-snapshot
package has (to the best of my knowledge) always been identical to
mine and thus never supported Xft.

Changed in emacs-snapshot:
status: Fix Released → Confirmed
Patrick J. LoPresti (lopresti) wrote :

> Ubuntu's official emacs-snapshot package has
> (to the best of my knowledge) always been identical to
> mine and thus never supported Xft.

Yes we know, and it kind of sucks. This bug report is a plea for someone to fix it.

Emacs is the only tool on the system that looks like garbage. It would take approximately five minutes to fix. Therefore it will be roughly six years before it actually happens... :-)

Will Farrington (wcfarrington) wrote :

"Yes we know, and it kind of sucks. This bug report is a plea for someone to fix it.

Emacs is the only tool on the system that looks like garbage. It would take approximately five minutes to fix. Therefore it will be roughly six years before it actually happens... :-)"

Exactly. It's kind of sad that this bug report/wishlist is taking this long to fix. It's been around for 21 and a half months. It's not a hugely complicated fix. It shouldn't take this long to address.

Michael Olson (mwolson) wrote :

The reason that emacs-snapshot does not have Xft support yet is because we are waiting for the unicode-2 branch to be merged into mainline Emacs. I see reports of breakage concerning unicode-2 about once a week on the Emacs development list due to it not being in mainline yet -- this is way too much of a risk for the emacs-snapshot package to include it.

One possible solution would be to make a separate emacs-snapshot-<some_name> package that has the unicode-2 branch, but I have yet to think of a good choice for <some_name>. It is hard to predict how soon unicode-2 will be merged ... but given that multi-tty support is not even in yet, it might perhaps be worthwhile for us to make a separate package.

Will Farrington (wcfarrington) wrote :

Emacs-snapshot-unicode2 or Emacs-snapshot-unstable would be adequate, I should hope.

Michael B. Trausch (mtrausch) wrote :

Is there any progress on this? This is something that I've kind of been waiting for for a while now, too. After all, there is only *one* font that looks good in the stock Emacs, and it's not even possible to use that font in the rest of the system without making some configuration changes (Fixed, a.k.a. the xterm font). In any event, just curious to see what the progress is on this; it would make me very happy to see, indeed.

Reinhard Tartler (siretart) wrote :

updated packages for emacs-snapshot are available at https://launchpad.net/~ubuntu-elisp/+archive

I'll update emacs-snapshot there unregularily there because that PPA is not affected by ubuntu gutsy freezes

Gonzhauser (gonzhauser) wrote :

I just installed emacs from
http://ppa.launchpad.net/avassalotti/ubuntu/pool/main/e/emacs-snapshot/
and it is the first emacs that is usable in _years_ (because of its antialiased fonts)!!

g

Hari (harinath) wrote :

Romain Francoise wrote on 2006-12-20: (permalink)

> You are preaching to the choir... but emacs-snapshot will support
> Xft/Freetype when the emacs-unicode branch is merged in mainline,
> not before.

Well, the emacs-unicode branch has finally landed on the emacs mainline. So, it's probably time to spin out a new emacs-snapshot with the latest and the greatest.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package emacs-snapshot - 1:20080126-1ubuntu1

---------------
emacs-snapshot (1:20080126-1ubuntu1) hardy; urgency=low

  * remerge changes from Romain.
  * contains xft support (LP: #68461)

  * Remaining changes:

  * libgif transition: (LP #174252)
    - debian/control{.in}:
      - Replaced libungif4-dev with libgif-dev in build-deps

emacs-snapshot (1:20080126-1) unstable; urgency=low

  * New snapshot.
  * debian/control: Set Standards-Version to 3.7.3, no changes needed.

emacs-snapshot (1:20080120-1) unstable; urgency=low

  * New snapshot.

emacs-snapshot (1:20080106-1) unstable; urgency=low

  * New snapshot.
  * debian/emacs.prerm: Remove alternatives in reverse creation order
    (LP: #162932).
  * debian/patches/debian-inst.diff: New patch, disables installation of
    the upstream desktop file, etc.

emacs-snapshot (1:20080101-1) unstable; urgency=low

  * New snapshot.

emacs-snapshot (1:20071215-1) unstable; urgency=low

  * The "Pocketful of mumbles" release.

  * New snapshot.

  * debian/control.in: Add build-depends on lsb-release.
  * debian/control: Regenerate.

  * debian/patches/debian-emacs-bugmail.diff,
    debian/patches/debian-emacs-bugver.diff: New patches split off from
    debian-emacs-bug.diff.
  * debian/patches/series: Update accordingly.
  * debian/rules: Disable debian-emacs-bugmail.diff if not building on
    Debian (based on lsb_release output).

emacs-snapshot (1:20071209-1) unstable; urgency=low

  * New snapshot.

 -- Reinhard Tartler <email address hidden> Tue, 05 Feb 2008 21:32:57 +0100

Changed in emacs-snapshot:
status: Confirmed → Fix Released
Romain Francoise (rfrancoise) wrote :

Hari <email address hidden> writes:

> Well, the emacs-unicode branch has finally landed on the emacs
> mainline. So, it's probably time to spin out a new emacs-snapshot
> with the latest and the greatest.

Yes, the next snapshot will have Xft support.

Brian Koropoff (bkoropoff) wrote :

This new snapshot does not appear to have XFT support. I get the following error when attempting to run it:

No fonts match `Bitstream Vera Sans Mono-10'

This is with a configuration that has worked in the past with the unicode-2 branch.

Matt Ziegelbaum (mziegelbaum) wrote :

I can confirm what Brian said. Exact same results as of updating last night.

--z

Reinhard Tartler (siretart) wrote :

ok, my bad sorry. Reopening this bug therefore

Changed in emacs-snapshot:
status: Fix Released → Triaged

Reinhard, you need to enable a few build flags to enable the XFT/Freetype code. Simply add to debian/rules:

emacs_confflags += --enable-font-backend
emacs_confflags += --with-xft
emacs_confflags += --with-freetype

Michael B. Trausch (mtrausch) wrote :

Current version in Hardy (1:20080228-1) has XFT support.

It has a bug with the way that it handles XFT fonts at present, see bug 197366 for more information, but this particular bug is now fixed.

Changed in emacs-snapshot:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers