debian-changelog-mode support for non-coreutils systems

Bug #1197870 reported by Pierre Carrier on 2013-07-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
emacs-goodies
Fix Released
Unknown
emacs-goodies-el (Ubuntu)
Undecided
Unassigned

Bug Description

The current debian-changelog-mode shells out to coreutils' date.

To increase portability (some developers work on packages from other architectures), it would be nice to see this clean up get integrated:

https://github.com/pcarrier/debian-changelog-mode/commit/fcf691df

I get this should be reported upstream, but I won't pursue this further. Feel free to report/champion if this is of any interest to you.

description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in emacs-goodies-el (Ubuntu):
status: New → Confirmed
Revision history for this message
era (era) wrote :

I marked this as "affects me too", not because it particularly affects me, but because it is clearly a code improvement -- provided the locale-specific format-time-string parameters are substituted with locale-independent constructs (in particular, %b expands to the locale's abbreviated month name; I don't know if there is a way to override the locale locally [sic] or if you would have to hard-code, say, a vector of English month names).

Revision history for this message
Pierre Carrier (pcarrier) wrote :
Revision history for this message
Pierre Carrier (pcarrier) wrote :

For reference:

(let ((system-time-locale "fr_FR"))
  (format-time-string "%a, %d %b %Y %T %z" nil
                      debian-changelog-date-utc-flag))
"Ven, 05 jul 2013 17:51:39 +0200"

(let ((system-time-locale "C"))
  (format-time-string "%a, %d %b %Y %T %z" nil
                      debian-changelog-date-utc-flag))
"Fri, 05 Jul 2013 17:51:53 +0200"

Changed in emacs-goodies-el:
status: Unknown → New
Changed in emacs-goodies-el:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.