[needs packaging] import python-coherence depends from Debian

Bug #128205 reported by Arnaud Quette on 2007-07-25
10
Affects Status Importance Assigned to Milestone
elisa (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: elisa

coherence is needed for Elisa to support uPnP.

it's only available in Debian experimental for the moment (I'm checking with lool@d.o why, since I don't remember why it hasn't reached Sid):
http://packages.debian.org/cgi-bin/search_packages.pl?keywords=coherence&searchon=names&subword=1&version=all&release=all

still wishlist, but very important.
thanks

Arnaud Quette (aquette) wrote :

coherence 0.2.1 has hit Sid, and is should hit testing by August 6th.
I'll then upload 0.4.0 (only need to remove the python-soappy dependency).

Arnaud Quette (aquette) wrote :

I've uploaded 0.4.0 into Sid...

As this package is important for the Ubuntu Media Center distribution in general, and for Elisa project particularly, does somebody have any news about the integration of this package into gutsy repository ? We hope to have it in time for the future release of Ubuntu Gutsy... ;)

Thanks a lot.

Denis.

Loïc Dardant (loic-dardant) wrote :

The UMC project really need this package in time to have the new elisa version for the development.
Thanks.

Stéphane Loeuillet (leroutier) wrote :

Using the SID one worked like a charm for me as python-louie was added to ubuntu's repo today
http://packages.debian.org/sid/python-coherence

Well, when I say it worked like a charm, I mean it installed. In fact, launching Rhythmbox with UPnP plugin now crashes directly

So, perhaps not as simple to put in in Gusty

WARN coherence sep 20 20:34:50 Coherence UPnP framework version 0.4.0 starting... (coherence/base.py:156)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 47400137277520 (LWP 8084)]
0x00002b1c28c85aab in PyImport_GetModuleDict () from /usr/lib/libpython2.5.so.1.0

Changed in elisa:
status: New → Confirmed
Stéphane Loeuillet (leroutier) wrote :

It crashes like mad on x86-64 for me, but not on x86

Philippe Normand (philn) wrote :

That's actually not a bug in Coherence, but in Rhythmbox. See http://bugzilla.gnome.org/show_bug.cgi?id=469852
We really need python-coherence in Gutsy ASAP, as the other people on that bug are asking... I see no critical bug in Coherence right now which prevents its inclusion in Gutsy.

zegenie (zegenie) wrote :

I agree that it should be added as soon as possible.

Chris Halse Rogers (raof) wrote :

python-coherence 0.5.0-1 is in Hardy.

If you want it in Gutsy (or Feisty or Dapper), you need to follow the backports process: https://help.ubuntu.com/community/UbuntuBackports

Changed in elisa:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.