Elinks no ECMAScript; should depend on either see or spidermonkey

Bug #571070 reported by Edward Lee on 2010-04-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
elinks (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: elinks

Elinks in Ubuntu Lucid does not seem to have ECMAScript support since the removal of libmozjs. It is expected that ELinks will depend on either libmozjs or the alternate supported ECMAScript library, see.

In my PPA there's a fixed version of elinks, along with the requisite libsee library [I did not compile libmozjs since it was removed from ubuntu]....

Thierry Carrez (ttx) wrote :

It fails to build in your PPA due to missing libsee-dev, do you plan to package that as well ?

Changed in elinks (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed

Well, that's fixed now.

Chuck Short (zulcss) wrote :

If you could redifff this for maverick that would be great.

chuck

Sure, alright, but how? At any rate, though, I don't think libsee needs to be rediffed against maverick, as it mostly builds without issues. Elinks I'm not so sure about, but from going over my changes, it seems that it only needs --with-see in ./configure and ecmascript.enable in its configuration file.

0.13-GIT (which I have in my PPA) builds against xulrunner for javascript now, removing the dependency on a foreign package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers