imdb smart url fails to work

Bug #524696 reported by arky on 2010-02-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Server papercuts
Medium
Clint Byrum
elinks
Unknown
Unknown
elinks (Ubuntu)
Low
Thierry Carrez

Bug Description

Binary package hint: elinks

Searching for imdb titles with 'imdb keyword' no longer works.

ProblemType: Bug
Architecture: i386
Date: Sat Feb 20 04:09:19 2010
DistroRelease: Ubuntu 10.04
Package: elinks 0.12~pre5-2ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-6.8-generic
SourcePackage: elinks
Uname: Linux 2.6.32-6-generic i686

arky (arky) wrote :
Chuck Short (zulcss) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

Changed in elinks (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
arky (arky) wrote :

Try to launch elinks and you see it doesn't search the titles anymore, looks like a lot of smart URL's have to be changed.

 elinks "imdb avatar"

Chuck Short (zulcss) wrote :

Still broken on lucid.

Changed in elinks (Ubuntu):
status: Incomplete → Confirmed
Thierry Carrez (ttx) on 2010-06-02
Changed in server-papercuts:
importance: Undecided → Medium
milestone: none → maverick-alpha-2
status: New → Triaged
Changed in server-papercuts:
assignee: nobody → Clint Byrum (clint-fewbar)
Changed in elinks (Ubuntu):
assignee: nobody → Clint Byrum (clint-fewbar)
status: Confirmed → In Progress
Clint Byrum (clint-fewbar) wrote :

It would appear that imdb no longer supports the url scheme http://imdb.com/Find?xxxxx

I was unable to find any published documentation regarding external sites linking to their search, so this may occur again.

The attached patch resolves the issue, and it has been submitted upstream here:

http://bugzilla.elinks.cz/show_bug.cgi?id=1096

Changed in elinks (Ubuntu):
status: In Progress → Confirmed
assignee: Clint Byrum (clint-fewbar) → nobody
Thierry Carrez (ttx) on 2010-06-14
Changed in elinks (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package elinks - 0.12~pre5-2ubuntu2

---------------
elinks (0.12~pre5-2ubuntu2) maverick; urgency=low

  * imdb.com/Find no longer works, fixing imdb url (LP: #524696)
 -- Clint Byrum <email address hidden> Mon, 07 Jun 2010 17:07:46 -0700

Changed in elinks (Ubuntu):
status: In Progress → Fix Released
Thierry Carrez (ttx) on 2010-06-14
Changed in server-papercuts:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.