No SNI support

Bug #1700283 reported by Vasya Pupkin on 2017-06-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
elinks (Debian)
Fix Released
Unknown
elinks (Ubuntu)
Undecided
Unassigned

Bug Description

ELinks fails to load some websites:

$ elinks -verbose 2 -dump https://metrocom-chat.ml/
ELinks: SSL error

Wget, curl and all modern browsers don't report any issues with this website, for example.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: elinks 0.12~pre6-11build2
ProcVersionSignature: Ubuntu 4.10.0-24.28~16.04.1-generic 4.10.15
Uname: Linux 4.10.0-24-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.6
Architecture: amd64
Date: Sat Jun 24 21:55:07 2017
InstallationDate: Installed on 2011-04-14 (2263 days ago)
InstallationMedia: Ubuntu-Server 10.04.2 LTS "Lucid Lynx" - Release amd64 (20110211.1)
SourcePackage: elinks
UpgradeStatus: Upgraded to xenial on 2016-07-30 (329 days ago)

Vasya Pupkin (shadowlmd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

I was able to confirm the issue in Xenial-Artful and in Debian Sid/Stretch.

This bug is present in Debian too, and Ubuntu currently doesn't make any changes over the Debian package. So this bug would be best fixed directly in Debian, and then Ubuntu will pick up the fix automatically.

Would you mind filing a bug with Debian please and linking it here?

Changed in elinks (Ubuntu):
status: New → Confirmed
Changed in elinks (Debian):
status: Unknown → New
Andreas Hasenack (ahasenack) wrote :

As indicated in the Debian bug, elinks is missing the server name indication (SNI) extension. A debian bug about that specifically is https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=797968.

That gut has a suggested patch, but looks like it was never applied to the debian package.

There seems to be a more recent upstream git repo at http://elinks.cz/elinks.git, but the last change was about a year ago. I'm trying to clone it to see if the debian patch was merged, but it's timing out.

Changed in elinks (Ubuntu):
status: Confirmed → Triaged
Andreas Hasenack (ahasenack) wrote :

#797968 is more specific, as this bug is about the lack of the SNI extension.

Changed in elinks (Debian):
status: New → Unknown
Changed in elinks (Debian):
status: Unknown → New
Vasya Pupkin (shadowlmd) wrote :

I have successfully cloned http://elinks.cz/elinks.git, built ELinks binary against OpenSSL and successfully opened https://metrocom-chat.ml with this binary. So I guess patch is applied or building against OpenSSL instead of GnuTLS did the trick.

elinks@home:~/elinks/src$ ./elinks -verbose 2 -dump https://metrocom-chat.ml/ | wc -l
271

Robie Basak (racb) on 2018-11-22
summary: - ELinks: SSL error with some websites
+ No SNI support
Changed in elinks (Debian):
status: New → Fix Released
Vasya Pupkin (shadowlmd) wrote :

Any chances the fixed version will make it to Ubuntu 16.04?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.