[FFe] Multi-Arch version of elfutils wanted for Precise

Bug #934433 reported by Matthew L. Dailey on 2012-02-17
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
elfutils (Debian)
Fix Released
Unknown
elfutils (Ubuntu)
Undecided
Unassigned

Bug Description

=======
This is a feature freeze exception for elfutils in precise:
=======

The current elfutils (0.152-1ubuntu2) in precise does not have Multi-Arch support, so if the 32-bit lib is needed on a 64-bit system, it cannot be installed via libelf1:i386.

This is necessary for some older 32-bit apps we'll need to run once precise is out that depend on the 32-bit version of libelf.so.1.

This is also a blocker for cross-compiling kernel. As kernel is the most often cross-compiled piece of software, it would be rather important to get it working out-of-box in precise.

Minimal patch to add multi-arch support attached in the first message. While this creates a divergence from Debian, there is nothing "special" in the patch that needs
preserving once synchronizing with Debian next time. It can be simply replaced with the Debian package for precise + 1.

Build logs and packages available at Linaro overlay ppa:

https://launchpad.net/~linaro-maintainers/+archive/overlay/+sourcepub/2290267/+listing-archive-extra

Riku Voipio (riku-voipio) wrote :

Adding debdiff of patch from Debian BTS applied to ubuntu package. Only changing the "elfutils" binary package from M-A: same to M-A: foreign. This minimal package can be chosen to be applied instead of synchronizing the new upstream version from Debian.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in elfutils (Ubuntu):
status: New → Confirmed
Changed in elfutils (Debian):
status: Unknown → Fix Released
Evan Broder (broder) wrote :

Riku - Thanks for the patch. However, we were past FeatureFreeze when you filed this bug, and the current stance of the release team is that multiarchification requires a FFe (http://wiki.ubuntu.com/FreezeExceptionProcess). Could you fill one out?

Also, the patch that you uploaded to this bug appears to be slightly different from what the Debian maintainer actually uploaded. Can you update your patch to match what Debian did so that we can keep the diff minimal going forward? (I realize this will just be a sync for Q, but it would be good to make sure we're consistent)

I'm going to go ahead and unsubscribe ubuntu-sponsors for the time being, but feel free to resubscribe them if you feel you've addressed those concerns.

summary: - elfutils needs Multi-Arch support
+ [FFe] Multi-Arch version of elfutils wanted for Precise
description: updated
Martin Pitt (pitti) wrote :

Approved, please go ahead.

Martin Pitt (pitti) wrote :

Do we still actually have a relevant delta? Unfortunately the last uploaded merge failed to actually describe the changes. If 0.153 are only bug fixes and our delta is not relevant any more, we can just sync.

Evan Broder (broder) wrote :

We're carrying a diff for a -Werror=uninitialized build problem. It doesn't appear to have been fixed upstream. The upstream release carries new features, so I'll go ahead and put together an upload with just the multiarch fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package elfutils - 0.152-1ubuntu3

---------------
elfutils (0.152-1ubuntu3) precise; urgency=low

  [ Marcin Juszkiewicz <email address hidden> ]
  * Convert to multiarch. (LP: #934433)
  * Switched to use 'dh_prep' instead of 'dh_clean -k'
 -- Evan Broder <email address hidden> Tue, 06 Mar 2012 23:34:49 -0800

Changed in elfutils (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.