lubuntu 12.04 incorrect nm-applet icon

Bug #976805 reported by useResa on 2012-04-08
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
elementary-icon-theme (Ubuntu)
Undecided
Unassigned
lubuntu-artwork (Ubuntu)
Undecided
Unassigned

Bug Description

Yesterday I upgraded my lubuntu installation to release 12.04 by modifying the /etc/apt/sources.list and performing the upgrade.
Current situation:
$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu precise (development branch)"
$ uname -a
Linux Dell-Dimension-2400 3.2.0-22-generic #35-Ubuntu SMP Tue Apr 3 18:32:42 UTC 2012 i686 i686 i386 GNU/Linux

What I noticed is that the nm-applet shows an empty wireless connection icon (see attachment) while I am connected using a wired connection.

Based on Bug #936421 I expected that the elementary-icon-theme was here the cause as well, so I tried a reinstall of this package, which resulted in the following:
$ sudo aptitude reinstall elementary-icon-theme
The following packages will be REINSTALLED:
  elementary-icon-theme
0 packages upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/1,979 kB of archives. After unpacking 0 B will be used.
(Reading database ... 131701 files and directories currently installed.)
Preparing to replace elementary-icon-theme 2.7.1-0ubuntu6 (using .../elementary-icon-theme_2.7.1-0ubuntu6_all.deb) ...
Unpacking replacement elementary-icon-theme ...
gtk-update-icon-cache-3.0: The generated cache was invalid.
WARNING: icon cache generation failed for /usr/share/icons/elementary
Setting up elementary-icon-theme (2.7.1-0ubuntu6) ...
gtk-update-icon-cache-3.0: The generated cache was invalid.
WARNING: icon cache generation failed for /usr/share/icons/elementary

Based on Bug #741387 I checked the /usr/share/icons/elementary directory and found the following (partial output displayed)
/usr/share/icons/elementary$ du -d3
<snip>
48 ./status/48/untitled folder
<snip>
48 ./panel/48/temp
<snip>

I removed these two directories and now the icon cache was updated succesfully
$ sudo gtk-update-icon-cache -ft /usr/share/icons/elementary
gtk-update-icon-cache: Cache file created successfully.

However, still the incorrect icon displays.

useResa (rdrijsen) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in elementary-icon-theme (Ubuntu):
status: New → Confirmed
realmagnum (realmagnum) wrote :

Is there any relation between this Bug and Bug #983773?

Mark (markelius) wrote :

In icon theme "nm-device-wired.svg" linked to wrong file (nm-no-connection.svg)

temporary solution:

cd /usr/share/icons/elementary/panel/22; sudo ln system-file-manager-panel.svg nm-device-wired.svg -sf
log off/log on

Julien Lavergne (gilir) on 2012-05-02
Changed in lubuntu-artwork (Ubuntu):
status: New → Fix Committed
useResa (rdrijsen) wrote :

Mark thanks for finding the actual issue.
Your (temporary) solution, as provided in comment #4, solved it for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.28

---------------
lubuntu-artwork (0.28) quantal; urgency=low

  * Use wrap-and-sort.
  * usr/share/icons/lubuntu:
   - Add panel/22/nm-device-wired.svg to fix the status icon of nm-applet
     on wired and connected (LP: #976805)
   - Possible fix for empty icon for 3G.
   - Add a dark icon for screenlets tray icon, from upstream.
  * usr/share/themes/Lubuntu-default:
   - Add a specific gtk theme for chromium.
  * debian/control:
   - Add a depend on gnome-icon-theme-symbolic to the fix missing icons on
     some GNOME applications.
  * lib/plymouth/themes/lubuntu-text:
   - Update the text to 12.10.
  * debian/rules:
   - Rewrite using dh sequence.
  * debian/control:
   - Add build-depends on debhelper >= 7.0.50~ for overrides.
 -- Julien Lavergne <email address hidden> Wed, 30 May 2012 23:03:08 +0200

Changed in lubuntu-artwork (Ubuntu):
status: Fix Committed → Fix Released
Roman (thezub) wrote :

This is related to bug #956371: https://bugs.launchpad.net/elementaryicons/+bug/956371 which has been fixed for elementary 3.0 (past Quantal).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers