Sits in upper left corner of screen when Compiz is enabled

Bug #151380 reported by Andreas Schildbach
24
Affects Status Importance Assigned to Milestone
electricsheep (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: electricsheep

1. Make sure Compiz is enabled (Desktop Effects)
2. Activate electric sheep and wait until sheeps start to play

You will notice that sheeps will not zoom to full display size. Instead, they will sit in the upper left corner of the screen, with everything else blue

Revision history for this message
Andreas Schildbach (schildbach) wrote :

This is on Gutsy, apt-get dist-upgraded today - on a Dell X1 with 1280 x 768 of internal display and 1920 x 1200 of external screen.

Revision history for this message
Leif Walsh (leif.walsh) wrote :

Confirmed on Hardy with electricsheep-2.6.8-9ubuntu1 and gnome-screensaver-2.21.6-0ubuntu3, running XMonad, not Compiz.

In Bug #2379 (https://bugs.launchpad.net/ubuntu/+source/electricsheep/+bug/2379), it was mentioned that the fix was to add "--zoom 1" to the exec line in /usr/share/applications/screensavers/electricsheep.desktop, and that this fix was released in 2.6.8-5ubuntu1, and the exec line is still fine in this version. I expect there is an Xv overlay bug somewhere, could someone more experienced in that area check it out for me? I can run tests if you tell me what to do.

Changed in electricsheep:
status: New → Confirmed
Revision history for this message
Bobby R. Ward (bobbyrward) wrote :

A workaround you might try is to install mplayer and add "--mplayer 1" to the Exec line in the .desktop file.

Revision history for this message
Chris Roddy (cmr) wrote :

with mplayer installed and --mplayer 1 added to the .desktop file, the sheep do not display at all.

I am able to reproduce the bug on a fully-updated 8.04 beta, *regardless* of whether compiz is enabled. I am using the fglrx driver.

Revision history for this message
Kyle Martin (martikj2-deactivatedaccount) wrote :

I can get the sheep to work full screen with Compiz on a Dell Inspiron1420N (Intel 965 gfx) just fine, but if I have Rhytmbox open, my sheep don't zoom. This is on Hardy AMD64.

Revision history for this message
Tom Davies (twdavies64) wrote :

I get this on Hardy final with all of the updates also regardless of whether or not compiz is enabled.

I have an ati x1950 using the latest ati binaries.

I get "Cannot find xv port" when i run it in the terminal.

Revision history for this message
shockwav (betelgeux1) wrote :

Repeated here on an Intel core2 duo, ATI X1600 Hardy, fully updated.
Quarter screen, upper left. Running from the command line with --zoom 1 gives me

"warning: cannot zoom without mplayer or rootwin.
Cannot find xv port"

mplayer is installed and functional.

Revision history for this message
IKT (ikt) wrote :

I have the latest version of electricsheep running on multiple computers from karmic to lucid with compiz enabled, since this report is fairly old I'm going to set it to fix released, if people are still having trouble with compiz and electricsheep feel free to reopen.

Changed in electricsheep (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Francesco Potortì (pot) wrote :

No compiz enabled, no way to see it fullscreen.
Using --mplayer 1 stops it working altogether.

Changed in electricsheep (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
IKT (ikt) wrote :

@Francesco, what happens if you run "electricsheep --debug 1" without the commas?

Any specific errors?

Revision history for this message
Francesco Potortì (pot) wrote :

I discovered that this is one of the symptoms I get because of a problem with the graphics card, see bug 557694. Downgrading the openchrome driver has made the electricsheep bug to disappear for me. Is this enough to consider the issue as closed for me?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers