Firewire camera not found with ekiga 1394avc plugin

Bug #50923 reported by Ben Bacarisse on 2006-06-25
8
Affects Status Importance Assigned to Milestone
Ekiga
Expired
Medium
ekiga (Ubuntu)
Medium
Unassigned
pwlib (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: libpt-plugins-avc

Using ekiga (2.0.1-0ubuntu6) and libpt-plugins-avc (1.10.0-1ubuntu1) my camcorder is not detected.

The correct modules get loaded (dv1394 and raw1394) and the camera works with the dv interface in Kino so the connection and camera setup are fine.

A very similar configuration with the same hardware works in another distribution. The only difference I can see is that it uses version 1.10.1 of the "pwlib" plugins.

Roberto Sarrionandia (rbs-tito) wrote :

For testing purposes would it be possible for you to try and upgrade to the 1.10.1 version of pwlib?

It would be extremely beneficial to the report.

Ben Bacarisse (launchpad-bsb) wrote :

Sure, no problem.

I see the same problem (no devices detected). I ran:
    ekiga --debug=6 >out 2>&1
and the reesult of
    egrep -i 'video|pwlib' out
is:

2007/01/12 01:45:04.021 0:00.551 ekiga Detected video plugins: Picture,V4L2,V4L,1394AVC
2007/01/12 01:45:04.021 0:00.551 ekiga Detected video plugins: Picture,V4L2,V4L,1394AVC
2007/01/12 01:45:04.027 0:00.558 ekiga Detected the following video input devices: No device found with plugin 1394AVC
2007/01/12 01:45:04.028 0:00.558 ekiga Detected the following video input devices: No device found with plugin 1394AVC
2007/01/12 01:45:05.274 0:01.804 ekiga PWLIB version 1.10.1

I have attached the whole output file just in case it helps.

Ben Bacarisse (launchpad-bsb) wrote :

Oh dear. I notice that the test just report above is with an install of ekiga from .debs found somewhere on the 'net, not Ubuntu's packages. Specifically

   ekiga_2.0.2-1.ekiga.dapper.6321_i386.deb
   libpt-plugins-avc_1.10.1.dfsg-1.ekiga.dapper.1887_i386.deb (and similar)

I think these came from the ekiga site when I was trying to see if the original problem had been solved in a later version.

To my shame, I realise that I have no ide how to get the Ubuntu 1.10.1 version of libpt and firends. I am on Dapper and 1.10.0 is later listed version. Do I need to change to 6.10?

Ben Bacarisse (launchpad-bsb) wrote :

I have just moved on to 6.10 and the situation is the same. The camera shows images in Kino (on /dev/dv1394/0) but Ekiga can't see it with libpt-plugins-avc version 1.10.2.dfsg-0ubuntu3.

James Tait (jamestait) wrote :

For me, on Feisty, Ekiga looks to /dev/raw1394 for Firewire cameras, not /dev/dv1394/0 as Kino does. I had to change the permissions on /dev/raw1394 (chmod o+rw /dev/raw1394) for my camera to be detected. Also, I get kernel messages thus:

May 3 16:23:43 ferrari kernel: [66474.165171] ieee1394: The root node is not cycle master capable; selecting a new root node and resetting...
May 3 16:23:46 ferrari kernel: [66477.804818] ieee1394: Current remote IRM is not 1394a-2000 compliant, resetting...
May 3 16:23:47 ferrari kernel: [66478.087124] ieee1394: Node added: ID:BUS[0-00:1023] GUID[0000850000b0f72e]
May 3 16:23:47 ferrari kernel: [66478.087180] ieee1394: Node changed: 0-00:1023 -> 0-01:1023
May 3 16:23:47 ferrari kernel: [66478.269910] ieee1394: raw1394: /dev/raw1394 device initialized
May 3 16:23:47 ferrari kernel: [66478.364845] WARNING: The dv1394 driver is unsupported and will be removed from Linux soon. Use raw1394 instead.
May 3 16:27:42 ferrari kernel: [66713.216068] raw1394: WARNING - Program "ekiga" uses unsupported isochronous request types which will be removed in a next kernel release
May 3 16:27:42 ferrari kernel: [66713.216074] raw1394: Update your software to use libraw1394's newer interface

This is using a Canon MV750i on Fiesty:

Linux ferrari 2.6.20-15-generic #2 SMP Sun Apr 15 06:17:24 UTC 2007 x86_64 GNU/Linux
ekiga 2.0.3-0ubuntu8
libpt-1.10.0 1.10.3-0ubuntu1
libpt-plugins-alsa 1.10.3-0ubuntu1
libpt-plugins-avc 1.10.3-0ubuntu1
libpt-plugins-dc 1.10.3-0ubuntu1
libpt-plugins-v4l 1.10.3-0ubuntu1
libpt-plugins-v4l2 1.10.3-0ubuntu1

James Tait, your problem seems to be diffrent could you open another bug report.
Ben Carisse do you still have this issue with the latest release of Ubuntu ?

Changed in pwlib:
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Ben Bacarisse (launchpad-bsb) wrote :

Jérôme Guelfucci,
Jame Tait's suggestion of making /dev/raw1394 rw by others works for me too. In some ways, this is still a problem in that Ekiga it does not work "out of the box", but the bug is fixed as far as I am concerned.

Ubuntu 7.04,
ekiga 2.0.3-0ubuntu8
libpt-plugins-alsa 1.10.3-0ubuntu1
libpt-plugins-avc 1.10.3-0ubuntu1
libpt-plugins-v4l 1.10.3-0ubuntu1
libpt-plugins-v4l2 1.10.3-0ubuntu1

James Tait: Thank your.

So this is an Ekiga problem (as it works out of the box with kino) or a pwlib problem?

Ben Bacarisse (launchpad-bsb) wrote :

I am sorry but I don't really know. I imagine it should be fixed elsewhere entirely. /dev/raw1394 is group owned by "disc" (no doubt because it gets used for discs) so perhaps the solution is simply to make it group owned by "video" (since as a normal user I seem to be in that group). That might break other stiff of course.

Kino works by using /dev/dv1394/0 (group owed by video).

Ok, I don't have time now, but I will ask for some help on the #ubuntu-bugs channel later.

James Tait (jamestait) wrote :

Jérôme Guelfucci said 8 hours ago:
>
> So this is an Ekiga problem (as it works out of the box with kino) or a pwlib problem?

I just did the following:

$ apt-get source pwlib ekiga
$ grep -R -i 1394 pwlib-1.10.3/ ekiga-2.0.3/

The only lines in the output that showed up for Ekiga were:

ekiga-2.0.3/po/am.po:#: src/endpoint.cpp:1394
ekiga-2.0.3/po/bn.po:#: src/pref_window.cpp:1394 src/pref_window.cpp:1748
ekiga-2.0.3/po/el.po:#: ../src/gui/main.cpp:1394
ekiga-2.0.3/po/is.po:#: src/ldap_window.cpp:1279 src/ldap_window.cpp:1394
ekiga-2.0.3/debian/changelog: Closes: #136701, #139450

There were lots for pwlib, many in the configure script, so I tried to narrow it down by searching for /dev/raw1394 and got the following:

$ grep -R -i /dev/raw1394 pwlib-1.10.3/ ekiga-2.0.3/
pwlib-1.10.3/plugins/vidinput_dc/video4dc1394.cxx: * usual Video4Linux devices, specify "/dev/raw1394" or "/dev/video1394"
pwlib-1.10.3/plugins/vidinput_dc/video4dc1394.cxx: * --videoinput /dev/raw1394" should use your 1394 camera as video input.
pwlib-1.10.3/plugins/vidinput_dc/video4dc1394.cxx: if (devName == "/dev/raw1394")
pwlib-1.10.3/plugins/vidinput_dc/video4dc1394.cxx: PTRACE(0, "devName must be /dev/raw1394 or /dev/video1394");
pwlib-1.10.3/plugins/vidinput_dc/video4dc1394.cxx: if (PFile::Exists("/dev/raw1394"))
pwlib-1.10.3/plugins/vidinput_dc/video4dc1394.cxx: list.AppendString("/dev/raw1394");

From all this I'm *guessing* it's pwlib that's the culprit. A bit of extra info I didn't include before is that I have to select the 1394AVC driver in Ekiga, with the modified permissions on /dev/raw1394, for my camera to be detected.

Ok, After asking some advises on irq, it seems to be an issue with both ekiga and pwlib, I will report upstream.

Changed in ekiga:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Changed in pwlib:
status: Needs Info → Confirmed

Upstream wants to know if it works with the packages available here : http://ekiga.org/index.php?rub=5&path=ubuntu/feisty_x86

Ben Bacarisse (launchpad-bsb) wrote :

Jérôme, This sounds like a "just in case it works" suggestion. Unless ekiga and the plugins have been rewritten to work in an entirely new way (unlikely for a minor bump in the version number) I can't see how anything could have changed.

Anyway, always willing to do as I am told, I tried. Of course the latest versions simple try to open /dev/raw1394 just like before and fail. Also like before, chmod o+rw /dev/raw1394 makes it all work.

If there is a bug at all, it is in whatever subsystem sets up permissions and ownership in /dev and/or the subsystem that decides what group a user should belong to. I can't see how ekiga or its plugins can get round that issue.

There may be a problem in ekiga in that a diagnostic or hint that granting access to /dev/raw1394 might be required would help ordinary users.

Forwarding upstream.

Changed in gnomemeeting:
status: Unknown → In Progress
Changed in ekiga:
assignee: nobody → desktop-bugs
Changed in ekiga:
status: Confirmed → Triaged
Changed in pwlib:
status: Confirmed → Triaged
Fabián Rodríguez (magicfab) wrote :

Confirming the same problem (and workaround assigning permissions to device) in Gutsy, fully updated as of sept. 26.

Yes, this is still being worked upstream.

Changed in gnomemeeting:
status: In Progress → Invalid
Pedro Villavicencio (pedro) wrote :

comment from upstream:

"We indeed use a different device. But for me, if permissions are not right on
that different device, that is a problem of the distribution...
"
Is this still an issue with ekiga 3.0?

James Tait (jamestait) wrote :

In a word: yes.

I'm running currently on Ubuntu 9.04 alpha6 from a Live CD, although I intend to perform a clean installation on this machine over the weekend. Out of the box, neither Kino nor Ekiga works. If I do a chmod o+rw /dev/raw1394 then Kino immediately springs into life. Unfortunately I cannot get Ekiga to capture any video on the interface whatsoever, so the situation is now worse.

James Tait (jamestait) wrote :

I'm guessing this line from syslog is relevant:

Mar 27 22:50:08 ubuntu kernel: [13448.905478] raw1394: old iso ABI has been removed

Changed in ekiga (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Yannick Defais (sevmek) wrote :

Hi,

Support for those devices has been dropped in Debian:

"ptlib (2.6.1-1) experimental; urgency=low
+
+ * New upstream release.
+
+ [ Eugen Dedu ]
+ * Remove DC and AVC plugin packages, since they do not compile anymore
+ with current versions of libraw1394/libdc1394/libavc1394 in debian."

Unfortunately, nobody is currently maintaining DC and AVC plugins in PTLIB. Work is in progress to support GStreamer in Ekiga, this will bring those devices back in Ekiga.

Best regards,
Yannick

Changed in ekiga:
status: Unknown → In Progress
Changed in ekiga (Ubuntu):
status: Triaged → In Progress
Changed in ekiga:
status: In Progress → New
Changed in ekiga:
importance: Unknown → Medium
Changed in gnomemeeting:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in ekiga:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.