ekiga can't authenticate with SIP registrar

Bug #480207 reported by Florian Hars on 2009-11-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ekiga (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ekiga

If I try to connext ekiga to the SIP registrar on my Fritz.Box, authentication always fails.
The reason seems to be that ekiga answers with a fantasy nonce that the server rightfully rejects:

19:45:02.408233 IP fritz.fonwlan.box.sip > laptop.local.1024: SIP, length: 479
...
WWW-Authenticate: Digest realm="fritz.box", nonce="A3078DB55DD74138"
User-Agent: AVM FRITZ!Box Fon WLAN 7170 29.04.76 (Jul 13 2009)

19:45:02.423782 IP laptop.local.sip > fritz.fonwlan.box.sip: SIP, length: 697
...
User-Agent: Ekiga/3.2.5
Authorization: Digest username="622", realm="fritz.box", nonce="E89133C4CB4A9D9B", uri="sip:fritz.box", algorithm=MD5,

For comparision, a successful connect with correct nonce handling by the client:

20:08:03.276538 IP laptop.local.1024 > fritz.fonwlan.box.sip: SIP, length: 4
...
WWW-Authenticate: Digest realm="fritz.box", nonce="F8F0D674D1AD00FD"
User-Agent: AVM FRITZ!Box Fon WLAN 7170 29.04.76 (Jul 13 2009)

20:08:03.311674 IP laptop.local.1024 > fritz.fonwlan.box.sip: SIP, length: 528
...
Authorization: Digest username="622", realm="fritz.box", nonce="F8F0D674D1AD00FD", uri="sip:fritz.box",
User-Agent: Linphone/3.1.2 (eXosip2/3.3.0)

ProblemType: Bug
Architecture: i386
Date: Tue Nov 10 19:45:30 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/ekiga
Package: ekiga 3.2.5-1ubuntu1
ProcEnviron:
 LANGUAGE=de_DE.UTF-8
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: ekiga
Uname: Linux 2.6.31-14-generic i686

Florian Hars (hars) wrote :
Yannick Defais (sevmek) wrote :

Hi,

Please try the latest Ekiga version:
https://launchpad.net/~sevmek/+archive/ekiga-released

If it is still the same, I'll forward the issue upstream... We will need a complete debug output:
http://wiki.ekiga.org/index.php/Debugging_Ekiga#How_to_get_a_debug_output

Best regards,
Yannick

Ingo Busse (ingo-busse-web) wrote :

I encountered the same problem. I have attached a debug output of ekiga. Not sure if it is an ekiga problem.

Florian Hars (hars) wrote :

I checked with the ekiga from the ppa, ans it too breakes the protocol by ignoring the nonce and inventing its own,
tcpdump log:

21:03:58.341196 IP fritz.box.sip > laptop.fritz.box.sip: SIP, length: 477
SIP/2.0 401 Unauthorized..%
Via: SIP/2.0/UDP 192.168.178.22:5060;branch=z9hG4bKc895b9d6-0fd6-de11-9d96-001d72cc64dc;rport=5060
From: <sip:<email address hidden>>;tag=5e7116d6-0fd6-de11-9d96-001d72cc64dc
To: <sip:<email address hidden>>;tag=CD907110002F38FA
Call-ID: 2e6a16d6-0fd6-de11-9d96-001d72cc64dc@laptop
CSeq: 1 REGISTER
WWW-Authenticate: Digest realm="fritz.box", nonce="1D0B46CAD0137719"
User-Agent: AVM FRITZ!Box Fon WLAN 7170 29.04.76 (Jul 13 2009)
Content-Length: 0

21:03:58.354448 IP laptop.fritz.box.1024 > fritz.box.sip: SIP, length: 695
E.....@.@.R.................REGISTER sip:fritz.box SIP/2.0
CSeq: 2 REGISTER
Via: SIP/2.0/UDP 192.168.111.1:5060;branch=z9hG4bK20a3bdd6-0fd6-de11-9d96-001d72cc64dc;rport
User-Agent: Ekiga/3.2.6
Authorization: Digest username="621", realm="fritz.box", nonce="07E3E41E42B25696", uri="sip:fritz.box", algorithm=MD5, response="ef7826efac8caed981dcb84249e7f004"
From: <sip:<email address hidden>>;tag=5e7116d6-0fd6-de11-9d96-001d72cc64dc
Call-ID: 2e6a16d6-0fd6-de11-9d96-001d72cc64dc@laptop
To: <sip:<email address hidden>>
Contact: <sip:621@192.168.111.1>;q=1, <sip:621@192.168.178.22>;q=0.500
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,SUBSCRIBE,NOTIFY,REFER,MESSAGE,INFO,PING
Expires: 3600
Content-Length: 0
Max-Forwards: 70

Eugen Dedu (eugen-dedu) wrote :

There were many fixes on connectivity issues, your issue is likely to have been solved, please tell if ekiga 4.0.0 still has this issue.

Changed in ekiga (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for ekiga (Ubuntu) because there has been no activity for 60 days.]

Changed in ekiga (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers